Installed openSUSE 11.0, got gibberish

Just finished installing from the gnome livecd on my presario 17XL370. The installatiion seemed like it was going great but after reboot I got a blank screen with some gibberish:

It looks like something went wrong with a the boot record, but I’m at a loss for what to do next (and google didn’t help much either).

I’m a programmer and a power user and this is my first embark into Linux - so any help will be appreciated :slight_smile:

have you tried the repair facility on the install media ?


i don’t mean to disrespect your hardware, but that is a pretty puny
system to be asking to run an operating system as powerful,
sophisticated, robust, capable and MODERN as SuSE 11…

or, maybe my web search for the specifics for your compaq presario
17XL370 is incorrect:

cpu: pentium III 650 MHz 256kb cache
mem: 128 MB PC100
drive: 10 GB
graph: ATI 8MB

tell me: does your system meet the minimum requirements for Vista? XP?
ME? or do you have to go all the way back to win 98?

i do not know the minimum requirements for SuSE 11.0 (can’t find it and
don’t know how), but i use almost 10 GB just for the root partition on
SuSE 10.3

maybe your first look at Linux you should shoot for a distribution that
claims it will run from a 10 GB hard drive, 650 MHz, etc…i think i’d
try DSL (damn small linux) <> or Puppy

i guess what i’m saying if you (as a power user and programmer) wanna
try out Linux you should at least try to give it a fair chance…maybe
you can go back and install a version of linux which was current when
your machine was made/sold (maybe SuSE 9.2 or so)…and, compare its
capabilities to the OS the machine was born with…

welcome to the community,

DenverD >
This laptop is used mainly to watch movies and fetch email, not as my main development pc…

Up until this morning it ran win2k. It ran slow, true, but it did run. I chose to install openSuse on it as a test (which so far hasn’t been coming together too well…). A test that might convince me to change os on my main computer. I do not expect openSuse to make its old hardware more than what it is, but I was pretty much under the impression it can outperform windows for these simple tasks I need it do.

Since 2001 I’ve also upgraded its RAM and HD. 256mb and 40HD. It’s hardly much, I know, but it was enough to perform the simple functions I needed it do.

I don’t want to try out “linux”; I want to try this specific dist to see if I’m comfortable with it. Hope that makes sense.

Having all that said, I hardly think it’s the hardware configuration that’s preventing me from running it.
So sure, disrespect away, but also help me solve my problem :slight_smile:

Anyhow, I’m pretty convinced this is a grub error - I’ve noticed after a couple of reinstalls that grub fails with

/usr/sbin/grub-install: line 15: /etc/grub.conf: No such file or directory

before claiming the install was successfully completed.

I ran windows’ fixmbr and now the error message is “No Operating System Found”.

I tried to install grub manually with

grub-install /dev/sda

but it fails with “Because of the partioning, the boot loader cannot be installed properly”

Now, the partitions are as the openSuse installation suggested:
/dev/sda1 for swap
/dev/sda2 for root
/dev/sda3 for /home

So what am I missing?

have you tried post #2 ? failing that, pop in your dvd,select boot from hard drive,then once in, go to YaST - system - bootloader & redo grub. BTW, I have SuSE 11.0 running on a dell latitude cpx, 650mhz cpu,256mb ram & 20gb drive,added cd/dvd drive & it runs no problems,a bit slow,but only when i open more than 4 progs


> So what am I missing?

are you trying to load as a dual boot with w2k?

if so, your “I ran windows’ fixmbr and now the error message is “No
Operating System Found”.” is gonna mess things up because you have to
let the SuSE install routine load the MBR up with grub…that way,
after your bios is finished it calls the code in the MBR which then pops
up a screen where you can pick either Linux or win…

see, the thing is that (as far as i know) windows will NEVER see the
Linux partition or boot from it (thank you Mr. Gates)…which is why you
have to let grub do the work (it WILL boot win if you want it, OR linux)…

didn’t the install routine see your win and offer you a dual boot?