Installed Kdevelop et. al. & my soundcard stopped working?

Hi folks.

I’m having sound card problems using openSUSE 11.0 on a Tohsiba Satellite L25-S119. This problem did not exist in 10.2, but it did in 10.3. I think I know what’s causing it, but I don’t know why.

I used openSUSE 10.2 for a long time on this laptop. I loved it, it worked great.

I made a fresh install of 10.3 back in January, and my soundcard started “skipping.” The original forum posts and a description of my hardware are here.

I never sorted it out, but switched to Kubuntu for a while, and it worked for my needs, but didn’t like it.

After testing the sound on a live CD four days ago, I installed 11.0, and my soundcard worked superbly for four days. I thought the problem was resolved. The difference from my 10.3 install (I think) is I didn’t immediately install all the apps I need. A few minutes ago, I installed Kdevelop and a few pdf viewers. A ton of dependencies got installed as well. I noticed some of these were kernel headers “for development.” Now the soundcard problem has reappeared, exactly as before.

I would post my /var/log/y2log for today, but I don’t have attachment posting rights.

Does anyone have suggestions of what else I can look for?

Thanks in advance

For your own purposes (but not for posting here as it is MUCH too large), you could check precisely what apps you installed. Do that by typing:

rpm -qa --last > installed-rpms.txt
and use a text editor to open “installed-rpms.txt”

Then look at the dates/times in which rpms were installed and see if you can identify the culprit.