Installed(I think) but I can't get it to boot with windows 10 and 7

I didn’t intentionally use “btrfs”. If it is ext3 then I did. But I was under the impression the ext3 was what linux wanted.
And if partition 3 is “/” (where I told the installer to put bootcode, then that is probably beyond the 1024 mark and I doubt any boot manager will pick it up.

Another thing, I looked at the BIOS again, and the SATA HDD is have opensuse on is listed 2nd in the drive configuration area, and there is no way in the BIOS I have to change positions of SATA HHD 1(my windows drive) and SATA HDD 2( where I am putting opensuse).
The only way I can change that is to reposition the cable ends on the MOBO, and I am not sure how that would affect Windows boot.

Hate to keep bugging you, and I appreciate all you are trying to do for me.

“ext3” should be fine.

I have not had a problem with “beyond the 1024” with computers bought in the last 14 years. It is unlikely that your computer is so old that it has this problem.

“Proper” boot code location when not installing Grub to MBR means (legacy) Windows-compatible boot code needs to be in the first sector of the first BIOS disk. The master-boot-code rpm contains such code which is typically used to restore an MBR that has had Grub installed, without having to perform a rescue boot. When legacy-compatible code is used, a single primary partition that contains boot code must have its boot flag set. More or fewer than one will prevent booting. Boot flags on logical partitions if present are superfluous. Legacy code can only be used for booting a primary.

With legacy/Windows code on the MBR and a boot flag set on the 39GB / partition you should be able to boot openSUSE’s Grub, which should be able to chainload the Windows bootloader as well as boot openSUSE.

Can I create a /boot partition PRIOR to the install using a partition manager? after it is formatted?
Partitions have to be created before they can be formatted. Adding a /boot partition after formatting involves repartitioning. All my own partitioning is completed before I ever start any OS installer.

I am still confused about that BOOTING section as shown in the 6th photo in openSuse install link.
Where the boot code is going there isn’t necessarily clear to all who read it. If you click the bold link booting you’ll get a three-tab screen with more detail that ought to clarify if carefully studied. IMO on multiboot with Windows Grub should never be installed on an MBR. This philosophy is consistent with that image, and this ancient link about neutral multi-booting.

You never did answer where I look for “/boot/grub2/” mention in one of your posts. explains ordinarily is not needed and thus not present with Grub2.

If you’re still not booting yet and plan on yet another try at installing, I suggest to remove the SCSI disk’s power or PCI card until everything is booting. If the PCI card has a SCSI BIOS, it can interfere in device recognition by bootloaders and create consternation trying to figure out what is or is not happening. I used SCSI almost exclusively for well over a decade, until SATA had fully displaced PATA on new motherboards. Multiboot for the inexperienced is hard enough without including SCSI in the mix. Add it later unless some special configuration is requiring it be booted from.

A lot to absorb. But will go over it again and again until I understand.

I will add this> regardless of which of the three ‘linux’ in easybcd I select, I get this ‘minimal bash’ message.
**Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device or file completions.
**That is what is telling ME the bootcode is lost or not where it should be. Googling ‘minimal bash’ gets me all kinds of answers, but even more confusng to me since I don’t have a working linux to get the ‘fixes’.

LOL, I got the PC from a business friend, and I really don’t know it’s age. My best guess is around 2008. I will look to see if I can find out.
HP Compaq DC7700 CMT, that originally ran WinXP 64bit.

EDIT>> BIOS date is 2011, and I seriously doubt the previous owner flashed it. So it is probably built and sold in 2011.

BIOS date is 2011, and I seriously doubt the previous owner flashed it. So it is probably built and sold in 2011.

I have a Dell with the same Q965 chipset as the DC7700 HP. It works fine with 42.3, so it’s very unlikely that hardware compatibility or age has anything to do with bootloader being inappropriately placed.

Could the TPM be engaged and blocking either correct Grub2 installation, or operation?

“Minimal BASH-like line editing is supported” is telling you Grub2 is installed, but either isn’t finding its menu.cfg file, or the file’s content is invalid. The grub> prompt enables manual kernel and initrd loading (among other things), so what you have should be bootable, just not so easily until it can be found what’s causing the menu.cfg failure.

I am in Leap 42 as I type this on my iPad, waiting for updates to finish.
I don’t like how I had to get there, but it worked. I put the install stick in and asked it to,boot from the hard drive.
it found it, and booted it. Now I need to find out how to it so it boots ‘normally’, and will be back seeking help with that.

At least I know it is there! And am sure it can be fixed.
I don’t like this way, But for now, I can live with it as long as the USB stick doesn’t corrupt.
thanks for all the help folks!

PS. What is TPM?
PS2. can I find the grub menu.cfg in Windows search?

I found what TPM is. Will look to see if it in the BIOS,and if so it’s state.

Post the result of running bootinfoscript and we should be able to figure this out. Windows cannot access the Linux native partition that menu.cfg should be on in BIOS booting mode.

At least you have found a way to boot it.

When you are booted into the system, see if you can list the content of

  • /etc/default/grub_installdevice
  • /boot/grub2/

You can use the following commands:

cat /etc/default/grub_installdevice
cat /boot/grub2/

It is possible that those files do not exist.

And the suggestion by mrmazda to provide “bootinfoscript” output is also useful.

I foolishly opened yast2 and went to the boot loader section.
The box for boot from mbr was ‘blued’ out, and I changed it to the 2nd boot option ‘boot from root partiton’ and now I can’t get it to boot up again.
now all I get are boot failures ‘remove disk and hit any key to continue.
will probably reinstall AGAIN tomorrow, and see if it works.

BTW, I have re-written the USB STICK, so I hope that hasn’t messed things up.

life lessons!

Is the boot flag set on your openSUSE root (/) partition (39GB sda3?) and on no other primary on sda?

As far as I know, yes. But if that is the case , I don’t know why yast2 boot area showed MBR.
I don’t recall all of the strings of text during boot, but I do remember seeing it was going to boot from the 39GB partition(sda3?).

Reinstalled a couple of times now, and i just get the ‘BOOT FAILED, remove disk and hit any key to continue’

I watched the installer very carefully this time, and it appeared to me that the installer makes a difference if the machine has is x64-efi or x86.
My desktop is 64bit, but it is BIOS controlled. Not UEFI.

Should I be installing the 32 bit version?

Leap has no 32 bit version. if the processor is 64 bit then install 64 bit or need to go to TW.

Pay attention to the install and where the grub boot code is set to install. Best to install generic code to MBR or if already generic skip and just install grub code to the boot partition which is normally root.If root is in an extended partition install to the extended partition. When using MBR generic boot you need a boot flag set on the partition you want to boot to. Be sure only one partition is marked with boot flag…

I believe it was set to install the bootcode to root partition,BUT not all that sure as the BOOTING SECTION is kind of confusing. Done the install several times, so I don’t remember for each time I did the install.
I haven’t tried the generic code to MBR, so maybe that is next.

What disturbs me is that I did get it to boot ONCE by selecting ‘boot from harddrive’ in the USB menu after an install. Then I messed around in yast2’s boot section (DUMB THING TO DO!!!) and thought I had changed it to “/”(see a post above) and since then, all I get are the ‘BOOT FAILURE, remove disk and hit any key to continue’ messages regardless of how the booting section is set up.

This smells like the boot flag is either missing or on the wrong partition. Please share output from

fdisk -l /dev/sda

Again, bootinfoscript would help us help you.

I would be more than glad to do that IF I could get it running!
Can’t! Just keep getting the BOOT FAILURE messages.
I don’t know if Installing Win10 WSL and then putting WIN10 store app for opensuse and trying to use that bash shell to help track down the problem would help or not.
About to give it up, and try with another linux. Don’t know if the same thing would exist or not. But I have done everything the opensuse install page I have listed in a couple of posts, and then some, and it is getting to me. TIME TO QUIT?! Move on.

It just should not be this danged hard!

One can boot the installation media into rescue mode, or append to the kernel cmdline the string rescue, and then run fdisk -l. AFAICT, the bootfinfoscript isn’t on the boot media, but you could put it on another USB device, a floppy, a CD or a HD partition which could be mounted manually in rescue mode.

In particularly difficult times like you seem to be having I boot a Knoppix DVD or CD. Knoppix was the originator of and remains the standard to beat in live Linux media.