Installed codecs with opi codecs

Hey everyone,
I recently just installed codecs by installing opi and then running opi codecs. However, yesterday night when I tried to run sudo zypper dup, I got the errors down below.

I do want to note that I do see a recent topic here that deals with codec issues. However, from what I gathered in the thread, the issues of that poster were due to problems with their repo list, and also they were using Leap, whereas I am using Tumbleweed, so there might be a different solution.

Problem: 1: the installed Mesa-32bit-24.0.9-1699.381.pm.1.x86_64 requires 'Mesa = 24.0.9', but this requirement cannot be provided
not installable providers: Mesa-24.0.9-378.1.x86_64[download.opensuse.org-oss]
                   Mesa-24.0.9-378.1.x86_64[https-download.opensuse.org-1c103d03]
                   Mesa-24.0.9-378.1.x86_64[https-download.opensuse.org-c9b77e1f]

Problem: 2: the installed Mesa-24.0.9-1699.381.pm.1.x86_64 requires 'Mesa-dri = 24.0.9', but this requirement cannot be provided
not installable providers: Mesa-dri-24.0.9-378.1.x86_64[download.opensuse.org-oss]
                   Mesa-dri-24.0.9-378.1.x86_64[https-download.opensuse.org-1c103d03]
                   Mesa-dri-24.0.9-378.1.x86_64[https-download.opensuse.org-c9b77e1f]

Problem: 3: the installed Mesa-24.0.9-1699.381.pm.1.x86_64 requires 'Mesa-gallium = 24.0.9', but this requirement cannot be provided
not installable providers: Mesa-gallium-24.0.9-378.1.x86_64[download.opensuse.org-oss]
                   Mesa-gallium-24.0.9-378.1.x86_64[https-download.opensuse.org-1c103d03]
                   Mesa-gallium-24.0.9-378.1.x86_64[https-download.opensuse.org-c9b77e1f]

Problem: 4: the to be installed phonon-vlc-qt6-0.12.0-2.3.x86_64 requires 'vlc-noX = 3.0.21', but this requirement cannot be provided
not installable providers: vlc-noX-3.0.21-1.1.x86_64[download.opensuse.org-oss]
                   vlc-noX-3.0.21-1.1.x86_64[https-download.opensuse.org-1c103d03]
                   vlc-noX-3.0.21-1.1.x86_64[https-download.opensuse.org-c9b77e1f]

Problem: 5: the installed vlc-noX-3.0.20-1699.11.pm.19.x86_64 requires 'libvlc5 = 3.0.20-1699.11.pm.19', but this requirement cannot be provided

What’s the best way to go about this? I tried to see if I could uninstall the codecs with opi, but from what I can tell opi does not have a remove function. If I were remove them, I would still want to install the codecs again eventually, so that might not be the best result if opi is the best way to install them. If someone could guide me which options I can pick above that won’t break anything on my system, I would be very grateful!

Thanks agaiN!

There are several topics here about this - Packman hasn’t released updates yet, so you can either switch to the main repo versions until Packman releases their updates (and then switch back), or you can tell zypper to leave the installed packages alone.

You can tell it to switch them all by adding --allow-vendor-change to the zypper dup command.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.