installed bumblebee on my asus N552VW-FY204T but doesn't work

on my son,s new laptop=asus vivobook pro N552VW-FY204T, CPU=i7-6700HQ @ 2.6GHz, GPU=intel HD Graphics 530 & NVIDIA geforce GTX 960M, RAM=16GB, storage=SSD 512GB
I installed opensuse leap 42.2, uefi, filesystem ext4, swap file, fstab options>arbitrary option value=discard, dual boot with windows10 following this:
https://tweakhound.com/2015/11/04/dual-boot-opensuse-leap-and-windows-10-uefi/.

I tried to install bumblebee, following this:
https://en.opensuse.org/SDB:NVIDIA_Bumblebee
so I

zypper in -t pattern devel_kernel
zypper in nvidia-bumblebee
zypper in nvidia-bumblebee-32bit

after instalation

systemctl enable dkms

rebooted
and

procuste@eros3-ST:~> optirun --status
If 'optirun' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf optirun
procuste@eros3-ST:~> 

how can I have bumblebee working??

By following the procedure **thoroughly **and from line 1 maybe?
It appears that you **didn’t install bumblebee **in the first place, just the optional nvidia-bumblebee…
It works beautifully here on a similar N551 laptop.

aaahhh :slight_smile: ok, manythanks, now it seems to work.

procuste@eros3-ST:~> optirun --status
Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.

procuste@eros3-ST:~> 

but, the fan now is always on at the maximum, (before to stop the fan I added acpi_osi=linux at kernel parameters and it worked)
and, as I understood the discrete card works only when you call it in a program name as

optirun program-name

but, how can I have the discrete card always on??

Nice to see you are up and running. You are correct, if you installed bbswitch along with bumblebee (as it should) the discrete GPU is switched on only when invoked.
To have the discrete GPU always on you need something like suse-prime, but it has issues currently on Leap 42.2: please see https://forums.opensuse.org/showthread.php/512260-Leap-42-1-Optimus-system-with-nvidia-prime-instead-of-bumblebee

I don’t know about the fan always being on, but my ASUS seems to like "acpi_osi= " (including the trailing blank) for everything to work properly.

with bumblebee "acpi_osi= " doesn’t works, now I have no advantages to install bumblebee, the intel card works the same as without bumblebee and the fan now is always on, suse-prime doesn’t works, to uninstall bumblebee, as I did this:


systemctl enable bumblebeed
systemctl enable dkms

and also
Packages notifications
You have notifications from the following packages:
bumblebee
This message will be available at /var/adm/update-messages/bumblebee-3.2.1-32.1
INFO: Please ensure that users using bublebee/video card are in following group(s):
INFO: gpasswd -a bumblebee
INFO: If going to use nvidia binary driver:
INFO: gpasswd -a video
INFO: Also ensure the nouveau module is blacklisted (even if you plan to use it):
INFO: echo "blacklist nouveau" >> /etc/modprobe.d/50-blacklist.conf
INFO: mkinitrd 

have I to do something other or only deselect all bumblebee software is ok??

https://forums.opensuse.org/showthread.php/505270-ultimate-tutorial-installing-Bumblebee-driver-for-SUSE

Just uninstalling everything bumblebee should be enough; maybe you have to rebuild the initrd afterward if that is not automatically triggered and a reboot fits well anyway.
I wouldn’t care of “blacklist nouveau” at this stage, since the current nouveau driver doesn’t engage your GTX960M anyway.
As said, suse-prime has issues with 42.2, so no surprise that it doesn’t work on your laptop.
I doubt that the fan issue is bumblebee-related, maybe there is some hidden load like desktop indexing or the like, if that is a fresh install.
Also please be aware that the Skylake Intel GPU may need the “i915.preliminary_hw_support=1” boot param to work properly.

manythanks, it worked :slight_smile:

for the fan maybe you are right, becouse before insert acpi_osi=linux the fan started just at the boot, after the insertion of acpi_osi=linux it didn’t start, after installation of bumblebee the fan started just after login, after uninstalled bumblebee the fan doesn’t start.
I will try i915.preliminary_hw_support=1 kernel parameter too
…how can I know the active video driver in use??

it seems that i915.preliminary_hw_support=1 has no effect,
also before, compositor is enabled and seems ok, rendering backend openGL 3.1 and 2.0 works, but dektop cube effect doesn’t work, is there any way to have it working

If you have Mesa-demo-x installed, you can try glxinfo, like:


LT_B:~ # glxinfo |grep 'renderer string'
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile 
LT_B:~ # optirun glxinfo |grep 'renderer string'
OpenGL renderer string: GeForce GTX 960M/PCIe/SSE2
LT_B:~ #

it seems glxinfo is not installed

eros3-ST:/home/procuste # glxinfo |grep 'renderer string'
glxinfo: command not found
eros3-ST:/home/procuste # 


As said in post #10 you need to install the package Mesa-demo-x.
If you are using Gnome, checking “System settings”, then “Details” should show a line reading “Graphics <Intel or whatever>”.
With KDE, check kinfocenter > Graphical Information > OpenGL for similar information.