Installed ATi Driver

I installed the latest linux drivers for my ati graphics card, now whenever I boot up I just get a black flickering screen, so I tried booting with x11failsafe in the boot options and that allows to get into SUSE, so I’m wondering where should I go from here?

I had similar problem, added the “nohz=off” to /boot/grub/menu.1st

###Don’t change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.1 -
root (hd0,1)
kernel /vmlinuz- root=/dev/sda3 resume=/dev/sda1 splash=silent showopts vga=0x317** nohz=off**
initrd /initrd-

Caution: other than the bolded text, I’d not blanket-copy this into your own menu.1st unless you are running the same kernel as me.

Also, if you add “3” to the boot line (go to runlevel 3) and then “init 5” afterwards, do you get the same result? For some reason, I was able to work this way…

That nohz=off didn’t do the trick for me, this is quite a frustrating problem as I only installed this distro this afternoon after moving from Fedora 10, been using Fedora since Core 6 but moved after hearing good things about openSUSE 11.1, however it seems at the moment I can’t even get a simple thing like drivers to work on it.

Hi, tricky stuff, the ati driver. I haved problem allso. on fresh install i have installed ati drivers with default settings. it worked fine. when i updated it it goes black, where should be logon screen, but if you update it first and then installs it, it should be fine. try also:

xgl-switch --enable-xgl

by defult it is disabled.

Try the 9.2 beta, works fine for me now after a world of pain.

I have this running, well right now actually with a Radeon 9600.

Of course the obligatory beta code hosed systems and dire warnings of make backups comment.


from the suse wiki page for ATI drivers:

ATI - openSUSE

there is something about fixing blank screens.check it once.