Installed 11.2, now get GRUB error! Won't boot.

I installed openSUSE 11.2 and it started into it after install and finished some configuration stuff. Then I got online in firefox and then shut down. when I restarted i get:

GRUB Loading stage1.5.

GRUB loading, please wait...
Error 21

boot into rescue system from the DVD, then reinstall the bootloader. Do you have any other systems on the machine?

I can get you thru this
Where are you up to?

One of the easiest ways to fix this is a live cd or the install dvd and getting a root console.
Like explained here:
All About Grub - openSUSE
This part:

If you have a Linux Live CD, boot from it and log in. Then open a console window and enter su and you will be at the command prompt with root powers and ready to proceed. If on the other hand you have the openSUSE install DVD, boot from it and on the first menu of options select the Rescue System option. That will start an elementary Linux Live operating system and bring you to the login prompt. Enter the username root and you will be at the command prompt with root powers and ready to proceed. Whichever way you started (the openSUSE install DVD or a Linux Live CD) when you are at the root command prompt, first you find the partition containing openSUSE’s bootloader. Then you reinstall Grub with a pointer to that partition. First find the openSUSE installation:

You enter this ---------------- grub
Computer returns like this ---- grub>
You enter this ---------------- find /boot/grub/menu.lst
Computer returns like this ---- (hd0,5)
Here, (hd0,5) is Grub’s pointer to my openSUSE installation. Your pointer will be different from my example (hd0,5). Substitute your values for my example (hd0,5). Now that you have the pointer, proceed like this:
You enter this ---------------- root (hd0,5)
Computer returns like this ---- Filesystem type is ext2fs, partition type 0x83
You enter this ---------------- setup (hd0)
You see several lines like this — Checking if /boot/grub/stage1 exists … yes Computer finally returns this-- Succeeded…Done
You enter this ---------------- quit

Here’s what’s weird:

  1. If I go into the BIOS and choose the boot priority and change it (to anything since the CD is empty), it boots perfectly.

  2. I then booted into the GRUB menu and chose windows, booted fine.

  3. I restarted, and got the error again!

  4. Again went into BIOS, changed boot priority and again it booted perfectly, this time I went into openSUSE.

What could be causing this?

Are you saying you have more than One HD?

Yes. But everytime I change the boot priorities, I don’t change the HD priorities, only HD vs CD. So really going into the BIOS should make no difference.

So try changing HD boot order

In BIOS? But how does that make sense when it works with the current order? (Albeit not all the time)

And GRUB/MBR is on the master HD, so shouldn’t I load that first? (Although OpenSUSE is on the slave HD)

Look. You know the order they are now. OK. So don’t forget.
Just try changing it to have them the other way round.

What’s with Master/Slave ? How old are these. I was assuming they were SATA drives?

They are and are both set to cable select but for some reason they showed as master/slave in opensuse’s install window. That’s why I referred to them that way.

You need to give me more detail. I’m not clairvoyant.

Cable select suggest these are old PATA/IDE drives.
Are they sharing a cable?
Have you used them successfully like this before?

OK, this is WEIRD. Here’s what I discovered is going on:

When I start up and go into the BIOS, it will only show ONE Hard Drive (thr original one that came with the computer). I restart again, and it shows BOTH! (This keeps happening every time I restart. Everyother time it isn’t there)

So, I think I might know why, but not sure.

The computer cable connecting to the original HD only had one connector. So I put the new HD onto the cable with the CD/DVD. So somehow this causes it to not always be loaded in. I’m going to try switching the cables and see if that fixes the problem.

ideally individual cables for each drive
IIRC, way back when I had 2 drives like this. Both were master on the jumper settings. Then just set the boot order in BIOS.

OK, I think I’ve solved it.

I pulled out the cable from the CD/DVD (which had two slots) and pulled out the one from the HD drive (which had one slot). Then I switched them and hooked both HD’s to the multiple slot cable (it only has two) and the CD/DVD to the single one. I was then able to restart two times in a row without a problem (which I couldn’t do before). I’ll keep monitoring it for grub error 21, but I think that solved it.

It’s pretty stupid. I’ve never heard of a computer (made in the last 5 years) that had physical slots for a HD but no slot on the cable to actually connect it to the motherboard. It has a slot for an extra DVD drive too but now I don’t have a slot on a cable to connect it?! Weird.

Well done;)
Sorry I wasn’t much help

Not a problem, I REALLY appreciated the help/effort. It keeps me plugging away without despair to know I’ve got another mind on the issue. :slight_smile: And I only think it’s solved, it’ll take a few days before I feel pretty safe this fixed it.