installation was pretty cdrom,webcam..

pretty upset…just a bit

I decided to try a Linux distro because I got annoyed for virus and windows “actualizations”, and I wanted to try something new. I did my research and opensuse looked very good, with a cool comunity like this trying to help and solve the problems of others.
I succesfully downloaded the livecd KDE and Gnome, tried both, but as many others, I’ve got caught for the eyecandy and applications that KDE offers, I even got surprised when I ran the live cd, everything was working, SD card reader, sound, USB drives, mouse, of course the CDROM, and the webcam. I’m a normal computer user with some knowledge about, so as I said, everything was running good so I decided to install it along with vista (just for a while, because I assumed I’d turn to suse 100% later if that promising OS continued the good working.
Well, I read the partition advices, applied them and installed the opensuse 11.1 via live cd…and this is the result:

Webcam not working, as I said, using live cd and check the webcam with Kopete, webcam worked well, now it isn’t, there’s only one black screen, sometimes if I move the whiteness or saturation controls I get a couple of distorted horizontal white lines, but that’s all.

The biggest problem for me is this: the cdrom-writer. it looks like there’s no cdrom in computer, if I put a cd in the tray nothing happens, I hear something in the drive, like if the drive was trying to read but there’s no notification in the recently plugged devices. K3b tells me that there’s no device. How is this possible? I used the drive to install suse? isn’t it? :frowning:

If I put the computer to sleep or hibernate, when I press enter key to use it again, I can’t use the keyboard to enter my password, nothing happens if I hit the keys !! I remember that I did this using livecd session, when I changed the screen configuration and sax2 told me I had to restart session to get the new screen config, in live session there was no problem with logout and then going back, but I have to admit that when I did this there was no password asked.

The good things after installation are: SD card reader, USB drives, mouse, sound, and wireless network are working well.

I’m an enginner, I like to think and solve the problems, and that’s what I want to do, get back my whole computer to work with opensuse, and that can be done with some help of this cool community now I’m in, please, any advice would be great.

Oh, this is my computer, a laptop in fact : Acer Apire 5810tz, intelcpu U2700@1.3GHZ Processor, 3 GB RAM.

Thanks a lot in advance

Open a terminal and become super user by typing su (hit enter)
now type root password (hit enter)


zypper ref


zypper up

Make sure you use k3b from Packman and have k3b-codecs
Multi-media and Restricted Format Installation Guide - openSUSE Forums

This is usually a permissions problem. As a regular user you may not have access to the drives, possibly depending on the security level you chose at installation time. You can:

  1. Try to access the CD as root JUST ONCE to check if it is a permissions problem. If you can, it is. DO NOT run regular apps or browse the internet as root or TERRIBLE things may happen, like messing up your system, getting a virus/trojan, your cat climbing the roof, your daughter getting pregnant, etc.:slight_smile:


  1. check in /dev to what group your drive belongs and add yourself to it. In this computer with two DVD-Writers, running OS 11.1/KDE3.5, /dev/sr0 and /dev/sr1 belong to group disk and users belonging to this group have read and write access.
$ ls -la /dev/sr*
brw-rw----+ 1 root disk 11, 0 Out 24 19:28 /dev/sr0
brw-rw----+ 1 root disk 11, 1 Out 24 19:28 /dev/sr1

Also you may want to seach this forum for “CDROM”, you’ll see many similar posts. It’s just a teething problem, you’ll get over it in no time :slight_smile:

THANK YOU, THANK YOU VERY MUCH, caf4926 and brunomcl for your replies.

but another thing has just happened, I can’t connect to internet(I need to do that for apply the commands that caf4926 told me, am I right?), because I can’t find the little world icon that I use to connect to the wireless network here at my home,it’s just simply dissapeared of the widget group, (I selected not automatically connect, because I’m not using the suse laptop as an everyday computer of course, I have another desktop comp) well I’m working on that.
I’m sorry if this could sounds little dumb from me for your expertises, but I just can’t find the way to get the wlan0 connection again…:frowning:
For now I’m gonna check what brunomcl says, and read the links you showed me

thank you again

If you can’t use a eth cable
You need networkmanager. As I am unsure if you are using kde or gnome I can’t be sure what you need to do next. But if you look for networkmanager or knetworkmanager from the menu, you should find it.

There was a bug in 11.1 when it first hit the streets as a GM release, in that the permissions for CD/DVD read/write was messed up. A work around that was put in place at that time by many users was to add their user to group ‘disk’ and group ‘cdrom’. One can do that by going to: YAST » Security and Users » User Management » “select your user” » Edit » Details » Groups » check “disk” and “cdrom” and then click on “ACCEPT”. Then one must restart for those settings to be applied.

Instead command line users may try in a terminal with root permissions:

run `usermod -A disk yourusername` 


run `usermod -A cdrom yourusername` 

If you are using KDE-4, then the network icon in the lower right does not work well. IF your wireless hardware already has the necessary drivers installed and running, you could try the approach I suggested in post#2 in this thread: wireless works with gnome but not with KDE - openSUSE Forums

Many of us, with a wired connection in place, have taken to installing wicd so that wireless will work with wicd: Wicd - openSUSE

Note we have a forum area specific to wireless problems. You could go there, read the stickies, and then make a post for help and our wireless experts will try to give you some assistance. Wireless - openSUSE Forums

For your webcam, there is guidance here: HCL/Web Cameras - openSUSE

Absolutely! Wicd is, ATM at least, much easier to use.

thanks, :slight_smile: i’ll take a look to Wicd too.

thank you very much to all,
this community and the allgreen thing in opensuse :), are some of the reasons why I’ve chosen suse to start my linux experience.

Well if openSUSE 11.1 offers you too many issues you dont have long to wait for openSUSE 11.2.
I tried 11.2 already and my webcam worked right away, I dont use wireless but I did see network manager made its way into 11.2 (its not there in 11.1).
Is it possible for you to hook your computer to the net without the wireless, do you have a LAN connection or anything like that?

TaraIkeda wrote:
> Well if openSUSE 11.1 offers you too many issues you dont have long to
> wait for openSUSE 11.2.
> I tried 11.2 already and my webcam worked right away, I dont use
> wireless but I did see network manager made its way into 11.2 (its not
> there in 11.1).

NetworkManager is in 11.1. The above statement is wrong.

Its not there on my installation, appeared right away on 11.2 though.

TaraIkeda wrote:
> Its not there on my installation, appeared right away on 11.2 though.

If you have only a wired interface when you install, 11.1 does not
install NM; however, you can always go to the repos and get it. I have
not tried an 11.2 install without a wireless interface.

Gotcha, yeh I have a wired interface so I never took notice of network manager… I am always connected.

Thanks :slight_smile:

CD’s are now detected, internet came back again too, thank you very much.

Now I’ working with my webcam issue.

HI everyone.

Well I’ve been doing my homework and at this time I fixed with the help of you, all the issues in my laptop, now I have fully functional laptop, I even now have all the media things set and I can watch videos, play CD, mp3 etc. All of this thanks to the tutorials and the replies of the kind people here in the forum.

So my installation was “pretty bad” at start but now it’s really really good.
So I’ll be around here to see if I can help another people, even when I’m not a totally expert.

Thanks to all.


Good to know we helped a little. See you around for sure;)

Great news ! I find with each openSUSE release it gets easier, as one remembers the techniques applied from previous time one installed. … Although sometimes, as one would expect, some of the hiccup areas just work in a new release and less customization is needed.

Its down to the point now where dependent on the PC and on the Internet speed, I can typically complete an openSUSE installation in less than 2 hours, including full multimedia, full office suite, and many different utilities. It took my wife something like 4 evenings to setup winXP the way she wanted (with only partial multimedia, full office suite, and many different utilities) with a few hours work every one of the 4 evenings, so the packaging of a Linux distribution like openSUSE (together with independent installation of the 3rd party packages available) is pretty good. Of course an underlying assumption here is familiarity with openSUSE Linux and a good internet connection, so that one does not waste time searching while trying to figure out what to do.

Welcome to our community! :slight_smile:

Very true. Given a good Internet connection, starting at 1Mb/s, i think, installing an working, personalized OS system takes about an hour (With windows it takes at least three for an incomplete system, not counting the d*mned reboots). Knowledge of the repo system is necessary, however, so it’s not trivial to a newbie - but not so hard as windows…