Installation stuck on hard drive detection

I downloaded x86-64 hybrid DVD and done everything according to instructions from Installation without CD - openSUSE.

After booting from USB HDD, the first page took about 3 minutes to switch menu to the installation media option then afterwards the installation got stuck on Hard drive detection (probably 2 hours before i rebooted into windows 7). Installation scenario is:

Machine: Compaq presario C767TU
HDD: 320 GB with Windows 7 Ultimate on root partition, all other partitions NTFS
Free Space for Linux: 30 GB (Extended partition) currently having Mandriva 2010 with /swap 2GB, / 10GB, /home 18GB
DVD drive: Dead (No)
USB HDD: 120 GB SATA 2.0 with 10 GB primary partition for installation files FAT 32

Mandriva 2010 installed with exactly the same method without any problem. Now I want to replace Mandriva with OpenSUSE 10.2

I have absolutely no idea why it is taking so long to detect 2 HDDs while it got into installation source window within a couple of minutes. Any possible explanation/suggestion would be highly appreciated.

Download the x86_64 Net install CD, follow same instructions to get it on USB-disk. That will work.

Do you mean installing over internet? That will take a whole day i guess on my 1 Mbps connection. Or just take the boot file from there an put it into the same / where all the DVD is extracted? I forgot to mention this before that i tried the above mentioned method before and installation went so smoothly that my custom installation took only 40 minutes. The external USB drive is the same source i tried 2nd/3rd/4th/5th time and that turned into total chaos. Installation has become as slow as i am installing it on 486 pc since 2nd installation try. The installation is progressing not halting but took 5 hours to just probe the hardware :smiley: resulting in making me nuts. Any solution/suggestion will be highly appreciated. Thanks for reading my post.

Find out in Windows, on which partition C:\ is located (1st,2nd ?)
Copy the content of the DVD-iso to C:\11.2
Boot from USB-disk, at bootmenu, pick HardDisk, point to /dev/sdaX, folder /11.2, where “X” is the found C:\ partition number, i.e. 1st becomes /dev/sda1

This should start the install from the internal HDD, see what it does.

Same result, It got stuck on probing hard drives, After 2 hours i have to manually switch off the notebook. Hard drives are neither huge nor something that is outta blue. Primary HDD is WD Cavier Blue 320GB (4 partitions all NTFS with 30GB for Mandriva 2010) while USB HDD(used for boot only) Seagate 120GB with one FAT32 Boot partition and two NTFS partitions). Both are detected good while launching Installer, once installer starts everything starts running at snail speed. I tried VESA as well. Do you suggest Text only for any kinda troubleshooting OR something else?

Anyone having some kinda suggestion please???

During POST (Power On Self Test “whene the pc start-if you dont see it normaly need to press tab to see it”) BIOS try to get information about all the devises Connected to the system do you see your hard drive there? , check if the hard drive is not encrypted in windows

win7 use BitLocker look at settings ,( mandriva got a buy edition"That means more tester and compatibility with a salary ", open suse is a free version)

Well bitlocker has nothing to do with it as none of the HDDs are encrypted. Hardware firewall is enough to counter anything. I am not advocating Mandriva either infact I have been a fan of OpenSUSE since its launch. I am neither a newbie nor much expert but i can handle any kind of OS. Everything is ok with BIOS, both HDDs are detected perfectly. I am wondering how this can be possible that same setup installed custom configuration in 40 minutes and now it is showing me the symptoms of 2 days long installation process. That’s a strange thing to notice, moreover i have switched USB HDD with three different USB HDDs to make sure nothing is wrong with USB HDD. Internal HDD is rather a new one, upgraded it 2 months back when i purchased Windows 7 as you know it’s hard to live in corporate world without having windows. If you have any suggestion please share it. Thanks n regards.

Well … I never had such issues under any Linux but I’ve experienced similar problems on openBSD. In my case, the SATA controller on some new mainboards wasn’t entirely supported: booting was possible, as well as installing, but Ultra DMA mode failed and all HDs were downgraded to PIO mode … Then everything became extremely slow. A basic openBSD installation (nothing compared to Linux) took several hours.
I believe your HDs are running in PIO mode.

That convinces me as well. As far as i know, to correct that i need to give SUSE kernel mode driver then. Ah same old floppies which i don’t have. Is there any solution to make the installation process switch to DMA instead of PIO mode, apart from boot time driver provision? Thanks for hinting that out.

Anybody having answer?

Hello ppl, no answer yet? come on guys I think i am asking Guru.