Installation program cannot write into home directory

I am used to have OpenSuSE run with a root partition and a separate home partition.
When upgrading, I normally delete all files in the root partition (using a rescue disc or some other means) and leave the home partition intact as it contains valuable configuration items that I want to preserve.
This approach has worked for many years.
Now, trying to upgrade from Leap 15.4 to 15.5, I have for the first time encountered the problem that the installation program refuses to update config files in the home directory.
It says, for example, that it cannot write /home/vaessen/.config/plasma-localerc and other plasma configuration files, with ‘vaessen’ here being my user name. It doesn’t explain why this is so.
To this story I have to add that the UID of vaessen in the home directory is 1026 and not the default 1000. After installation of SuSE I always give user vaessen this specific UID since the day that I bought a Synology NAS, in which 1026 is the first UID that can be given to a user and I want username and UID to match on both the NAS and on SuSE. This approach has not caused any upgrade problems so far with SuSE and I have this NAS for many years now.
Why does the problem arise now?

How do you try to upgrade?

It has become quite a story.
I began with downloading the Offline Image from the site op OpenSuSe and wrote it to a bootable USB stick.

I started with an installation from this stick and the write problem with regard to the configuration files in my home directory arose.
I wiped the home directory and installed again, generating a fresh home directory. Things went all right, were it not that the system again and again forgot my user password and when looking at the user and group management in Yast, I saw that my password of 10 characters was again and again shortened to 6. I then suspected something was very wrong with my USB stick from which I had installed.
I wiped the home directory again and installed SuSE, now using the Network image and also using a different USB stick as installation medium.
Things worked. So I thought I had found the answer and so I then used fsarchiver to write back the 15.4 home directory and tried an installation with the Network image again.
It came back with the error that it could not change configuration files in my home directory.
As stated before in that directory user vaessen has UID 1026 instead of the default 1000.

I would not expect any installer to “update” anything in a pre-existing /home/. I would expect it to either create new, or do nothing. Normally I only create root user during installation, and then manage users manually post-installation.


grep vaessen /etc/passwd

That pretty much sounds like a permission mismatch.

I think you would need to change the ownership to your new installed user.

You can do this by using root dolphin, right click on your username directory, about - and set ownership to the user for all subdirectories and users.

or with terminal chown


  1. If that is not it.
    do you have a corrupted filesystem and need a file check.

3.) is the parttion mountes read only?

Skip this now. Detach and power off the NAS. Upgrade. Attach and power on the NAS.

Well, I will suggest you before starting the upgrade process, temporarily change the UID of the “vaessen” user account back to the default value (1000). Once the upgrade is complete, you can revert the UID back to 1026.