Installation process freezes or does not detect partitions

Hello everyone,

After breaking my Leap 15 installation, I am trying to make a new installation of Leap 15. My computer is an old Acer laptop with two GPUs, working with Nvidia Optimus technology. Recently, my Nvidia GPU gave up the ghost, but I can still use my laptop except for video games.

I tried to download the two installation ISOs of Leap 15 (DVD and network) and I created bootable USB keys with Etcher on Windows - I have a dual boot with Windows 7. With both images, the same bug appears : the installation process freezes after starting the graphic installer, just after downloading the language package.

When I try to switch to “text mode” in the USB boot menu, the installation starts and I can set up network connexion but when the partitioner tries to detect my hard disks, it cannot find the partition table on my main drive. I tried to run fdisk -l on a Linux live-USB and it manages to find my partitions.

I do not know how to diagnose this, any idea ? My previous Leap installation showed ACPI errors at startup.


If you have broken hardware thing may hang trying to deal with it. If it was a desktop I’d say remove the Bad NVIDIA card but you can’t do that with a lappy. Maybe there is a disable in the BIOS??? Some older hybrid graphics machines had switches there.

How old is old? 5 years, 10? What model laptop and/or CPU?

I do not know how to diagnose this, any idea ? My previous Leap installation showed ACPI errors at startup.
You can try appending to grub menu’s kernel cmdline (F5]( acpi=off and/or nomodeset to change behavior, maybe to something successful. SDB:Linuxrc - openSUSE Wiki and both could have something useful to try.

I bought my laptop in 2010 (Acer Aspire 5742G), it has a Nvidia GT540M GPU and an Intel Core i5 CPU.

I recently updated my BIOS but there is no option to disable the auxilliary GPU ; when I try to disable ACPI, the installation starts but it cannot detect the partitions on the harddisk and the Wi-Fi card cannot be switched on.

Any other ideas ? I do not know really well how to play with the options in the installation start-up menu.


You shouldn’t need to “play” with options. If simply choosing “Installation” fails to proceed successfully, use the F5 key to choose safe settings installation. If that fails, try again but this time simply type nomodeset on the “Boot Options” line before proceeding. If that too fails, try choosing “Text Mode” via the F3 key.

FWIW, F5 -> Safe Settings puts the following options on the cmdline when I try it here:
apm=off acpi=off mce=off barrier=off ide=nodma idewait=50 i8042.nomux psmouse.proto=bare irqpoll pci=nommconf initrd=initrd splash=silent install= so I would try nomodeset before trying safe settings with an Optimus laptop.

If nothing works, try following the instructions on

Reading through Installing openSUSE Leap 15.0 and bumblebee on hardware with NVIDIA Optimus graphics - Forums Feedback - openSUSE Forums also might help.

Kinda convoluted instructions, though detailed.

To the OP

You have two easy choices for your first attempts, one of them should get you installed and you can then deal with the graphics thing.

You can add


to the end of the original startup command, that will probably work.

If not, instead add


This will give you a “kludgier-looking” ncurses installer, but it has all the functions of the GUI installer. I actually am comfortable with it and do not mind using it now & then, so give it a try.

If that does not work (one of those should, though), come back. If they do work, come back and let us know it worked and which one you used.

Thanks for your help.

Unfortunately, the same thing goes on happening when I try to start the installation process. I tried to download several versions and types of ISO images (DVD, network installation, live, Leap 15.0 and Leap 15.1…) and nothing changed.

  • When I use no special option, the installation program freezes after loading its GUI ;
  • When I use nomodeset, text mode or acpi-off mode, the installation program starts correctly (with or without the cute GUI) but when it comes to the partitioner, my main HDD (sda) is shown as a 700 Gb unpartitioned volume, whereas it has 7 partitions. I cannot go on the installation process as I do not want to reset my partition table and to delete my Windows dual-boot.

The Windows 7 partitioner manages to detect partitions and so does fdisk when I run it through a Debian live USB session. Should I repair my partition table or something like that ?

TIA for your help

The apparently broken NVidia gfx hardware makes it look like the only practical solution may be to pull the HD, attach it to SATA on a similarly aged Intel CPU/GPU PC, install there, and then return the HD to the laptop. Another possibility is install a minimal 42.3, then do an online (zypper) upgrade to 15.0. Also I’d file a bug so that there would be some likelihood this problem won’t remain when 15.1 gets released.