Installation problems on dell Studio 15 laptop

I recently tried to install openSUSE 11 from DVD onto my Studio 15 laptop. When I first got the laptop, I reinstalled my own Windows Vista and partitioned the main HDD to leave about 10gb for a Linux distro when I got around to it. I decided on SUSE, so I downloaded the DVD iso, burned it, and then put it in while windows was running to install. It installed a little program to install it, then rebooted. It installed SUSE, seemingly successfully, but after the end of the installation it just hung on a black screen.

Now it won’t boot into SUSE or windows from grub, but will boot under the safe boot for SUSE. I later checked the DVD and it’s not a valid copy, which likely caused the initial problem, but I find it strange that it won’t boot into windows anymore either. When I try to, it attempts to start the SUSE install again, and if the disc isn’t in, it hangs waiting for me to insert it.

Since I can’t get into windows anymore on my laptop, I don’t have access to the DVD burner I used to burn the disc, so I burned a copy of the SUSE liveCD on my desktop. When booting off the CD it hangs at a black screen similar to what happens when I try to boot the installed copy of SUSE, and the check of the CD says that it’s a good copy.

My thought is that since it boots under the safe mode of SUSE that I could try to figure out which of the parameters it uses makes it work, and then use that until I could figure out the problem, but I don’t know what any of them mean, and I couldn’t find a decent explanation of them. Some are rather self-explanatory, but others I’m less sure about.

The string it passes in from GRUB:
ide=nodma amp=off acpi=off noresume selinux=0 nosmp noapic maxcpus=0 edd=off

Have you tried booting from the dvd? Try using the repair feature.

You say the dvd is not valid = You mean it failed the media check? Umm… allways do a media check first!
But it may still work for you. I have had dvd’s fail the media check and then go on to install without error.

In the future, I would not run an install from with windows.

nyway, give the repair a go. Or even see if it will do a fresh install.

The problem with the repair feature is that I don’t know what commands to use.

It should boot to offer automatic - or you can select expert. But first, just clarify_

You say you can boot suse but only in safe mode? Do you mean failsafe?

At what do you arrive at the end of the boot? Is it a CLI login prompt? Or full GUI?

Yes, failsafe, not safe mode (normally a windows user). After booting into failsafe mode it gets to a GUI.

I tried the repair again, I mistakenly picked the custom repair instead of the automatic repair previously. However, I reach a point where it wants to repair the boot loader, and it doesn’t have an entry for my windows kernel. I’m not sure what to put in the fields on the editor screen, specifically “Kernel Image” or “Initial RAM Disk” as I believe I should leave “Vga Mode” and “Optional Kernel COmmand Line Parameter” blank.

So you can login?

Open a terminal
type:
su
then your root password

now type:

fdisk -l

Next using file manager super user mode

go to: /boot/grub/menu.lst

paste here

then the same with

/etc/fstab

I was mistaken about it being a GUI after booting failsafe. I was able to follow those instructions though, and the fdisk command didn’t do anything in either location.

Also, there is not a fstab directory in /etc

I was mistaken about it being a GUI after booting failsafe.

So tell us. Is it a command prompt? Saying:
login

If so: type:
root

then your root password

now type:
sax2 -r -m 0=vesa (N.B.* The 0 is a zero not a letter)

Now re-boot and try normal boot first
If that fails go failsafe

at login type your username
then your password

then
startx

I managed to figure out the problem with the SUSE install. It the default main monitor was an external monitor, and it wasn’t set up to mirror that to the actual laptop screen. I did some setup to get the SUSE install working properly, though I still can’t get into my windows install.

Post contents of
/boot/grub/menu.lst

and from a su terminal

fdisk -l

menu.lst


# Modified by YaST2. Last modification on Mon Oct 13 19:02:29 EDT 2008
default 1 timeout 8

###Don't change this comment - YaST2 identifier: Original name: linux###
title Debug -- openSUSE 11.0 - 2.6.25.16-0.1
     root (hd0,5)
     kernel /boot/vmlinuz-2.6.25.16-0.1-debug root=/dev/disk/by-id/scsi-SATA_WDC_WD1600BEVT-_WD-WXE608NN0390-part6 resume=/dev/sda5 splash=silent showopts
     initrd /boot/initrd-2.6.25.16-0.1-debug

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.0
     kernel (hd0,5)/boot/vmlinuz root=/dev/disk/by-id/scsi-SATA_WDC_WD1600BEVT-_WD-WXE608NN0390-part6 resume=/dev/ssda5 splash=silent showopts
     initrd (hd0,5)/boot/initrd

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.0
     kernel (hd0,5)/boot/vmlinuz root=/dev/disk/by-id/scsi-SATA_WDC_WD1600BEVT-_WD-WXE608NN0390-part6 showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off x11failsafe
     initrd (hd0,5)/boot/initrd

title Windows
     rootnoverify (hd0,5)
     chainloader (hd0,0)+1

I should also note that there’s a menu.lst in the root directory on my windows partition


hiddenmenu
timeout 0
title openSUSE 11.0 installer (LOCAL)
find --set-root /openSUSE_hitme.txt
kernel /openSUSE/linux devfs=mount,dall ramdisk_size=65536 lang=en splash=silent vga=0x31A
initrd /openSUSE/initrd

ALso, I may be doing it wrong, as I’m not entirely sure what you mean by “from a su terminal”, do you mean run the command “sudo fdisk -l” because that returns an error “sudo: fdisk: command not found”
I’m not sure how to open a higher privileged terminal.

su
means

type
su
then your root password

then fdisk -l (-l as in lost)

You might want to PM mingus here:
openSUSE Forums - View Profile: mingus725

When I do “fdisk -l” all that happens is a bunch of information about my partition table spits back.


Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 1605 * 512 = 8225280 bytes
Disk identifier: 0xa668c156

    Device Boot   Start      End      Blocks    Id   System
/dev/sda1    *        1    18276   146800640     7   HPFS/NTFS
/dev/sda2         18277    19457     9486382+    f   W95 Ext'd (LBA)
/dev/sda5         18277    18538     2104483+   82   Linux swap / Solaris
/dev/sda6         18539    19191     5245191    83   Linux
/dev/sda7         19192    19457     2136613+   83   Linux

That displays instantly, then it puts me right back at the command line.

Seeing you installed suse from windows
Read this thread carefully - particularly from this permalink: Cannot boot into Vista after openSuse 11.0 Install - openSUSE Forums

Normally this part of your menu.lst:

title Windows
rootnoverify (hd0,5)
chainloader (hd0,0)+1

should read

title Windows
rootnoverify (hd0,0)
chainloader (hd0,0)+1