Installation problems of amdgpu driver

Hallo all,

in my newly installed system (Leap 42.2) with AMD Firepro W5100 graphics card, I wanted to install the driver of the graphic card to have OpenGL hardware support (essentially rotating/manipulating 3D geometry). To do this, I downloaded the radeon pro driver for SLED (amdgpu-pro-16.60-379184), but was told to first install the amdgpu-pro-dkms package via Yast, which I did… and, if I remember well, getting a warning that the system could get inconsistent. But since it seemed that I had no choice I installed it anyway.
Anyway, afterwards I installed the driver, getting warnings and error messages. I tried back and forth and managed to get rid of some errors (to be honest I don’t remember what I did exactly), anyway this last warning remained :

(1/1) Removing amdgpu-pro-dkms-16.60-379184.noarch …[error]
Removal of (59)amdgpu-pro-dkms-16.60-379184.noarch(@System) failed:
Error: Subprocess failed. Error: RPM failed: /var/tmp/rpm-tmp.y31u5P: line 1: dkms: command not found
error: %preun(amdgpu-pro-dkms-0:16.60-379184.noarch) scriptlet failed, exit status 127
error: amdgpu-pro-dkms-0:16.60-379184.noarch: erase failed

Notice that I installed dkms previuosly.
I chose to ignore it and it got installed without any further error, but then 1) the lock screen was blocked and 2) at reboot there was no GUI anymore, so I had to manually uninstall the radeon driver, then again the GUI worked. What’s more, when I try to uninstall the amdgpu-pro-dkms package (via Yast) it fails with essentially the same error message as above.
I got stuck there, with my little knowledge of Linux command line/architecture.
Can anyone help me? Is this an issue of the operating system or of the proprietary driver?


Had the same problem some weeks ago, without dkms loaded previously.
I think, i´m no specialist, the script has an error.
What helped me was installing 16.50-xxx instead of 16.60-xxxx.
The error isn´t there in 16.50 and it also rolls back fine to 16.50 with all
components without yast.

Thank you, testi55, for your reply, that’s good news… but do you know where I can get it? Since on the amd site I can’t find where the 16.50 version is…

Download :

If it don´t works take a look here :

Downloaded the first link and tried to install… but it tells me:
“Unsupported RedHat derivative OS” :frowning:
The second link, too, had the very same file (amdgpu-pro-16.50-362463) attached…

Ouch, had no time to test it.
Hmm, running out of ideas, but if you give me your
e-mail via PN i´ll send you the driver.

amdgpu-pro-16.50-365149.tar.xz is here;

You may also need to add the boot option: amdgpu.exp_hw_support=1

Thanks for your help!
I downloaded and installed the driver, and the following warning prompted (more or less the same as before):

The following package is going to be REMOVED:

1 package to remove.
After the operation, 48.9 MiB will be freed.
Continue? [y/n/? shows all options] (y): y
(1/1) Removing amdgpu-pro-dkms-16.60-379184.noarch …[error]
Removal of (59)amdgpu-pro-dkms-16.60-379184.noarch(@System) failed:
Error: Subprocess failed. Error: RPM failed: Error! There are no instances of module: amdgpu-pro
16.60-379184 located in the DKMS tree.
error: %preun(amdgpu-pro-dkms-0:16.60-379184.noarch) scriptlet failed, exit status 3
error: amdgpu-pro-dkms-0:16.60-379184.noarch: erase failed

I think it tries to uninstall the previous version, but doesn’t succeed.
if I ignore it, it goes on installing, but with the problems mentioned before (lockscreen not working etc.).
It seems that there is this broken dependency I can’t get rid of …

So you have to fix the rpm database first and delete the wrong entry.
Ask Google.

Ok, here we are again… after trying for some days desperately and bloody-hardly to restore the system through the package manager, I found the most elegant way to restore my system… through the snapshots.
Anyway, the wrong entry is now cancelled. So I tried again to install the driver, now the version 16.50 of it -and that’s the warning I get:

nothing provides dkms >= 1.95 needed by amdgpu-pro-dkms-16.50-365149.noarch

 ] do not install amdgpu-pro-dkms-16.50-365149.noarch

 ] break amdgpu-pro-dkms-16.50-365149.noarch by ignoring some of its dependencies

… and if I remember well, it was exactly the one that I got from the 16.60 version I chose to ignore. This time I was wise enough not to go on (another lesson learnt;))
Again, is it a driver issue? Or is my system misconfigured? (although it is a very early version soon after installation)… or what?
Please help!

Do you have the packman repo enabled?

For reference I get

# rpm -qi dkms
Name        : dkms
Version     : 2.3
Release     : 2.1
Architecture: noarch
Install Date: Wed 15 Feb 2017 15:45:58 NZDT
Group       : System/Kernel
Size        : 208557
License     : GPL-2.0
Signature   : RSA/SHA1, Thu 02 Feb 2017 21:26:25 NZDT, Key ID 45a1d0671abd1afb
Source RPM  : dkms-2.3-2.1.src.rpm
Build Date  : Thu 02 Feb 2017 10:49:45 NZDT
Build Host  :
Relocations : (not relocatable)
Packager    :
Vendor      :
URL         :
Summary     : Dynamic Kernel Module Support Framework
Description :
This package contains the framework for the Dynamic
Kernel Module Support (DKMS) method for installing
module RPMS as originally developed by Dell.
Distribution: Extra / openSUSE_Leap_42.2

Hallo everybody,
installing dkms, finally it worked. Thanks to all for help and support!

Glad to have been of help!

I’m not sure if this belongs to this topic, but has anyone tried to install amdgpu-pro following official instructions?

Is is possible that nothing else is needed?

I’ve not yet gotten the official instructions to work successfully. I keep getting “file ‘repomd.xml’ from repository is unsigned” instead of the GPG accept popup, and “Package amdgpu-pro-core is broken , integrity check has failed.” when I ignored the aforementioned warning and attempt to install the amdgpu-pro drivers.