installation problem with openvpn from sourcecode

I am running a copy of 11.1 (a bit modified, new kernel. and evergreened).
KDE is 3.5.
I have currently the rpm Openvpn 2.09 installed but I need for my provider 2.2.1.
I therefore downloaded the source code, checked the integrity and did

su -

make install

All this gave no error and went flawlessly. But if I write

openvpn --version

I get

openvpn --version
OpenVPN 2.0.9 i586-suse-linux [SSL] [LZO] [EPOLL] built on Dec  3 2008
Developed by James Yonan

In yast the rpm shows in altered. Do I have to link to the new version?
How do I proceed in order to make the system recognize the new version installed.
And: once installed and recognized - will I have to uninstall 2.09 (I am asking because it has a huge number of dependencies).
Thank you.

You should have paid attention to where it was installed when you ran the make install step. Chances are it went into /usr/local/bin or /usr/local/sbin and that is either not in your $PATH or behind /usr/sbin.

For what I see it went to /usr/local/sbin/openvpn
My path is:

-bash: /sbin:/usr/sbin:/usr/local/sbin:/opt/kde3/sbin:/root/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/opt/kde3/bin:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin**:/usr/lib/mit/sbin: No such file or directory**

That seems odd. Any suggestion on how to deal with this?

/usr/local/sbin # dir
total 1868
-rwxr-xr-x 1 root root 1906289 Sep 19 15:13 openvpn


/usr/lib/mit # dir
total 4
drwxr-xr-x 2 root root 4096 Mar  4  2011 helper

/usr/local is the default prefix for software that uses GNU configure.

For testing you can invoke it with the full path /usr/local/sbin/openvpn

When you are happy that it works, remove the openvpn package and recompile the source, setting the install directory to /usr/sbin, then it will be available in the same location as the previous version. You do this at the configure step:

./configure --prefix=/usr

BTW, executing $PATH is incorrect. You just want to view it, not run it like a command. Just do

echo $PATH