installation over network--goal 13.2

I have an older system running 11.3 which has been out of use and I now want to upgrade or install to 13.2. /home is a separate mount so i have no problem with a install. This older pc cannot boot from usb or dvd. So I made the network installation CD as show and fired it up. I set the network settings: node ip, gw ip, nanmeserver ips. But when I say install. it pops up the download points ‘download.opensuse.org’ and ‘.13.2/repo/oss’ but It returns a few seconds later saying it cannot find. But I can go there from my browser with no problem. Any suggestions
Tuck

Which steps did you use?
After a installation of 11.3 you need a upgrade to every separate version of openSUSE until 13.2 or it won’t run.

I already have a clean 11.3 on an older system, as mentioned. I want to upgrade directly to 13.2. I thought a ‘new’ install would do the trick via the Network INstall CD, but I cant get that to work. Perhaps I should continue as you suggest doing incremental updates?
Tuck

This is the german sub forum, posts should be in german.

I’ll request this thread to be moved to the international forum instead…

Hi
Thread moved from German subforum…

How are you connecting to the internet, afaik the net install can be run only from a direct wired connection, you could try and do a live online update but that will require upgrading a from 11.3-11.4-12.0-…-13.2 you could try and jump a few versions but that’s probobly not going to work.

I set the network settings: node ip, gw ip, nameserver ips.

I think this is your problem, I’m not sure how you connect to the internet, check that info, a wrong dns server and you won’t connect to anything.
Are you sure about usb install, I ran the installer on a rather old pc with usb 1.1 and it installed fine.

Did the ethernet connection fix it?

If not, I would strongly recommend using dhcp to configure the network automatically. This has worked like a charm for me on any workstation so far.

If it HAS to be a manual network config, then everything has to be set exactly right, or weird things will happen!

In particular, check the netmask:

EITHER you have to enter it in standard notation, e.g. 255.255.255.0, in the netmask field.
OR you have to append it in slash notation to your IP, e.g. 192.168.1.15/24, and leave the netmask field empty.

Then for me everything works as expected and the manual config is taken into account.
However, if I put, say, /24 into the netmask field then the manual config gets discarded and a dhcp request is sent instead via the ethernet interface.

So after you start the installation and the progress bars at the lower bottom of the screen appear, make sure you hit ‘esc’ and watch the network configuration carefully.
If everything is in order, the manual-config should go through without any further notification.
If not, the ‘dhcp request’ line will show up.

Lastly, if I change the netmask field to, e.g. 192.168.1.15/24, then the installer doesn’t use ethernet at all but instead tries to configure my wifi interface, for some reason that is way beyond me.

Hope this might help to get your installation going.

The really big question you need to address is whether there are any applications you need to upgrade and if they’re even supported on a modern version of Linux.

Assuming that there is no app you’d want to upgrade (you’re wiling to install all new apps or re-install apps from scratch), then you should instead opt for safeguarding your personal data (typically copying your /home to a cloud drive or external direct attached storage like USB), wipe your hard drive (do an fdisk) removing all existing partitions and then install brand new with any currently supported openSUSE.

After you’ve installed a brand new openSUSE, you can then copy your files back to your /home directories (well, I recommend excluding all hidden files which are files and folders which start with a period).

TSU

Looks like the man already knows what he wants.
13.2 without having to do all intermediate upgrades, so he opts for a new installation via network. But the network, unfortunately, is not working!

No problem there…

If I’m not mistaken, he can do all that comfortably during the installation.

If he does that, he loses all his custom configurations and info (if he has any), like .ssh, .bashrc, .bash_history, browser stuff …
We have been upgrading our workstations for a long time now while the users kept their nfs-mounted home-directories unaltered. Afaik, this has never caused any problems.

No disrespect, really. Rather, my intention is to clarify for myself if I understood the question correctly.

So the question remains: how to get the network going? (?)

On 2015-08-28 21:16, tsu2 wrote:

> then install brand new with any currently supported openSUSE.

He can’t. Media will not boot. Read his post :wink:


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

as I understood the question the OP does not have a DVD drive and probobly a large enough usb stick so he tried to do a net install but it failed.
I’m thinking it was a bad network configuration …
Another choice would be for the OP to download the install DVD and unpack it somewhere in his home partition and then do a local (folder) install.

On 2015-08-29 03:16, I A wrote:
>
> as I understood the question the OP does not have a DVD drive and
> probobly a large enough usb stick so he tried to do a net install but it
> failed.

I understand the machine reads CDs, not DVDs. And too old to boot from
USB sticks. Thus network install is the only option.

I have the fuzzy remembrance of a bug with the network install. But I
can’t remember what it was. :frowning:


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Great idea with the install from hdd. It might not be all that easy to get that going, though. It might be best to use a separate physical harddrive, format it as bootable (fdisk), and put the iso in the root-dir. Then you should be able to select this hdd for booting via BIOS and install to the other hdd. Just be careful with the partitioning options during install, as the defaults might not apply in this case.

Or, maybe more elegant: If there is any chance of setting up a web-server within your LAN (or any other supported server-type, like tftp), you could do a network installation via LAN. Even if you can’t reach the sources from online repos, it should be possible to configure the networking sufficiently for LAN at least.

If you want to take this route, just (for http):

  • mount the iso into your web-root directory on the server via
mount -o loop image.iso /srv/www/opensuse/

and make sure that it is accessible via http.

  • boot from your net-install CD, press ‘F4’ and select ‘http’. Enter server IP and directory (relative to web-root, meaning ‘/opensuse/’ in this example). Hit install!