Installation on ASUS Z270-P Mainboard fails

Hi,

i’ve tried to install OpenSUSE Leap 42.3 on a computer with an ASUS Z270-P mainboard with 8GB RAM, a core i5 and a NVIDIA GTX 670 graphics board. The installation however fails to a very stage of the installation :(. Unfortunately i don’t have much information at this point of time. The last messages on the screen are


Loading basic drivers... ok
Starting hardware detection... ok
(If a driver is not working for you, try booting with brokenmodules=driver_name)

Intel 200 Series PCH SATA controller [AHCI mode]
  drivers: ahci*
Activating usb devices... ok
General USB Flash Disk
  drivers: uas, usb_storage*
Generic SD/MMC
  drivers: uas, usb_storage*
Alcor Micro AU6477 Card Reader Controller
  drivers: usbhid*
Logitech Unifying Receiver
  drivers: usbhid*
Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
  drivers: r8169*

I’ve already tried, to install with parameters line acpi=off and nomodeset. Since r8169 is the last driver that got loaded during the installation process, I also disabled it with brokenmodules=r8169. Nothing of this works so. Does anyone of you have an idea?

Thanks for your help!

Most likely it’s the driver after 8169 that’s crashing, actually - try completely disabling ACPI with: acpi=off

as i wrote before, I already tried acpi=off. No success. Is there a way, to find out, which driver gets loaded after 8169?

My apologies, I must be suffering from morning blindness apparently :slight_smile:

Could you by any chance try the Tumbleweed -NET boot to see if it also crashes on this particular hardware?

completely ok :slight_smile: I am very fast reader too and sometimes, I miss an important point. Thanks for your help btw.

Tumbleweed manages to boot further. So this problem only exists in Leap 42.3

After the message with Realtek-driver tumbleweed show the following


...
Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
  drivers: r8169*
enp4s0: network config created
Sending DHCP request to enp4s0...
ok, ip=192.168.178.49/24
Loading http:// ......

it seem, that Leap is not able to initialize its Ethernet-Controller while Tumbleweed manages this.
I´d really prefer to use Leap, because its my working computer and I can´t need experiments on it.

Do you have any ideas?

Greetings
Ralf

It might be worthwhile to examine it through disabling your LAN controller from BIOS/EFI, this should let you see if it truly hangs because of the LAN driver or something after that.