Installation on an Intel based MacBook (not a question, but rather an FYI)

I installed OpenSUSE Leap 15.2 on a MacBook Pro 5 laptop which had Manjaro on it. This laptop is from 2009. The install proved to be more difficult than I expected.

The first challenge was getting the WiFi to work. The laptop’s WiFi is Broadcom, which is proprietary. Eventually I found some packages and installed them to get the WiFi working.

The bigger challenge was getting it to boot on its own. After installing Leap, it required the install DVD to boot. It would not boot on its own. If the install DVD wasn’t in the DVD drive (giving the options of “boot from Hard Disk, or Install”), then I ended up with the monitor just showing a big grey question mark and not booting the OS.

The MacBook Pro 5 is an Intel based Mac. So, it uses the same architecture that most common computers now use, which is x86_64. But, it seems to have a different partitioning scheme (I believe GPT rather than MBR) to support a different boot process (I think EFI rather than BIOS). The OpenSUSE install kept defaulting to setting it up for a BIOS boot, which would only work as long as it booted from another entity (in my case, that was the install DVD).

So to try to fix it, based on some description I found on some blog, I created an EFI install partition during a subsequent install effort, using the install partitioning tool. This failed, as it still did not set up the system for EFI. But, in a subsequent install, I kept the partitioning scheme that I had previously set up, rather than accepting its proposed default setup (though I did accept its help to modify it slightly to correct my partitioning errors).

It then clued in that I wanted an EFI boot scheme, and voilà, the last install worked. It now boots up on its own.

I do wonder though why the installer didn’t proceed with an EFI boot scheme in the first place. Anyway, the laptop works well (in fact, I’m using it type this post now.)

I don’t have any personal experience with a MacBook. However, the general principle is this:

If you boot the install media with EFI, then it will default to setup booting to use EFI. If you boot the install media with BIOS booting, then the defualt is to setup the installed system for BIOS booting.

Hi
On the MacBook 2007 I have here, if you hold down the command key, here it gives the option to boot from the uefi media. As always I setup the disk with gpt and partitions including the efi one, installed osX then installed openSUSE…

On my 2007 iMac, I partitioned GPT first, then installed Leap, then installed MacOS.

I got this MacBook Pro 5 from a friend who spends a lot of time collecting old computers from people, installing Linux on them, and then giving them away. He recently got a bunch of Macs. He claims, from his experience, that only Manjaro and KDE Neon are relatively straightforward installs on an Intel based (EFI) Mac, and all other Linux distros are hell-on-wheels to try. He, like myself, is not an IT professional, but rather is simply a Linux enthusiast. I am talking about solely installing Linux on it, rather than dual booting.

Hi
Never had issues, the trick is to pre-configure the disk…

As noted by others, no special steps are required to make a Linux distro (be it openSUSE, Manjaro, OpenMandriva, etc.) installs and boots automagically as soon as the install media is booted directly from Mac’s UEFI (do remember that Apple’s UEFI implementation started in 2006 does allow booting from an hybrid MBR or UEFI).

There’s a nice shell script to display drive’s boot partitions to check how things are set up:

Does the openSUSE install program give a partitioning choice to the user between MBR and GPT in the first stages of the install?

If the disk is already partitioned, it will continue to use the same partition type unless there is so little available space that it needs to delete everything.

If it is creating a new partition table, then it defaults to using GPT (which actually works fine on most BIOS computers). But you can change that in the expert partitioner.

Meh. Whatever. I’m glad you guys/gals all had an easy just-insert-the-disk-and-it’s-done time installing openSUSE (and/or other Linux distros) on older Intel based Mac laptops like the MacBook Pro. It was not my experience, that’s for sure.

Not so nice if you happen to be using NVME. :frowning:

absolutely recommend to install reFIND bootmanager.

And remember EFI install SUSE

EDIT: Remember you need a 2-4GB FAT EFI boot partition , theoretically 500MB should be enough, but smaller ones didn’t work for me

That’s because you are using reFIND, so you need the kernel and “initrd” files to be in the EFI partition. Using grub2 for booting, 256M is adequate.

" For Advanced Format 4K Native drives (4-KB-per-sector) drives, the minimum size is 260 MB, due to a limitation of the FAT32 file format. The minimum partition size of FAT32 drives is calculated as sector size (4KB) x 65527 = 256 MB." UEFI/GPT-based hard drive partitions | Microsoft Learn This is why all my ESPs are 320M, including my iMac, the extra so that I can store a few of my own goodies for convenience in potential rescue situations.

I put rEFInd on my iMac’s data partition, but I’m using Grub-efi anyway. After a while of working perfectly, rEFInd gave my 2007 iMac trouble that switching to Grub-efi solved.

This MBP model should just boots fine with grub2-x86_64-efi with openSUSE’s install media if booted through UEFI (hold down the option key while booting the MBP and select your install media on Apple’s UEFI bootloader). It then should let you select “GRUB2-EFI” in the installer and you have a partition table scheme that allows it.