installation of Upstart package on opensuse

Hi All,

I have tried to build “upstart-1.11.tar.gz” package on opensuse 12.3. when I run the following command:
./configure --prefix=/opt/upstart --sysconfdir=/etc

I got following error:

*checking pkg-config is at least version 0.22… yes
checking for nih-dbus-tool… no
checking for NIH… no
configure: error: Package requirements (libnih >= 1.0.2) were not met:

No package ‘libnih’ found*

*Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables NIH_CFLAGS
and NIH_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.*

As I know, Upstart is build on libnih, so it needs libnih library should be installed. But I didn’t get any tarball/rpm of libnih on opensuse12.3. The only rpm I found in opensuse12.1 repository. So I tried to install it:

*pc-a49000:~ # rpm -Uvh libnih-1.0.1-12.1.3.x86_64.rpm
error: Failed dependencies: is needed by libnih-1.0.1-12.1.3.x86_64
pc-a49000:~ # *

I think there is incompatibility on libc library between 12.1 & 12.3. That is logical.

But how can I found the libnih library for opensuse 12.3. Or there is alternate archive for upstart?


If Upstart is what I think it is (the Canonical Init system) you should absolutely not use it under any circumstance on openSUSE.

Examine systemd as it has replaced SysV Init system on SUSE: systemd - openSUSE

Helo first poster and welcome here.

Apart from the technnical help given here, I will introduce to a feature of the forum’s posting editor that we like you to use. Every time you want to post computer text, please do so between CODE tags (and not in red as you did above, which in any case is better then doing nothing :wink: ).

You get the CODE tags by clicking on the # button in the tool bar of the post editor. When this is about a command’s output, the best is to copy/paste in one sweep, the prompt, the command, the output and the next prompt. Then we can see everything: where you were, who you are, what you typed and what you got. Well, this is my standrad talk, but I see you already did a lot of this above. Thank you.

Systemd is dependency based Init system. The Upstart is event-based Init. So according to U, event-based Init isn’t supported in OpenSuse.Is Upstart supported in SLES 11.0?


No, it’s not supported under any SUSE release by the developers.

On 2013-12-03 07:46, elf firein wrote:

> Systemd is dependency based Init system. The Upstart is event-based
> Init.

Not really. Systemd delays starting services till they are really
needed, because something triggers it. That’s event based.

> Is Upstart supported in SLES 11.0?


All suse systems have used systemv previously, and not systemd. No plans
of using upstart. And no plans of supporting it either, this is at the
root of the entire system, it is impossible to support two. To do it
yourself means redesigning the entire distribution.

Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)