Installation of Tumbeweed from USB freezes

Hi everyone!

I have been trying to install tumbleweed on my machine but the installation keeps freezing while loading the kernel, the error I get is: “Kernel Panic, not syncing. Fatal exception in interrupt”.
The machine I am trying to install tumbleweed on is hp EliteBook 755 g5 with AMD Ryzen™ 7 PRO 2700U APU with Radeon™ Vega Graphics.
I am using openSUSE-Tumbleweed-DVD-x86_64-Snapshot20180831.
I tried loading older kernels but that did not help. Any idea would be appreciated.

You can try appending " nomodeset" to the kernel boot line. For legacy booting, that’s just the options field where you can type it in. For UEFI booting, hit ‘e’ on the boot menu. Then scroll down to the line that begins “linuxefi”. Hit the END key to get to the end of the line, and enter " nomodeset" (but without the quotes). Then CTRL-X to continue booting.

That gives you a different video driver. If your problem is due to the graphics driver, then this should get things going for you. If your problem is caused by something else, then this might not help.

I tried both your suggestions but they both resulted in the previous error.