Installation of 13.1 fails at graphical start

I just installed 13.1, and install worked. Afterwards, after one boot, it refuses to start the graphical interface. It seemed, per the Xorg logs, that it was due to Dell WMI buttons (dell_wmi), so I tried blacklisting it and that didn’t fix the problem. I tried starting in recovery mode but that gave me no clues: stopped at the same point. I saw some (WW) about falling back on old probing methods. It’s a Dell Inspiron 411Z. (See Slackware64 on Dell Inspiron 14z for specs and info as to the hardware.) I also have the Xorg logs.

I will upload as follows:

http://www.puresimplicity.net/~delahunt/messages.txt <- /var/log/messages
http://www.puresimplicity.net/~delahunt/log1.txt <- /var/log/Xorg.0.log
http://www.puresimplicity.net/~delahunt/log2.txt <- /var/log/Xorg.0.log.old

Have you tried clicking on hardware install, the opensuse and then the lowest of the opensuse modes as you start up the computer?

This works for me with opensuse 12.3 and then I can install the nvidia repository so I can download video files and stat Opensuse 12.3 normally.

It doesn’t work for Opensuse 13.1 because there is no nvidia opensuse 13.1 repository.

I will try it. I have intel video so the ati/nvidia driver thing shouldn’t be the problem…

OK, so “recovery mode” works with a resolution that is obviously lower than maximum (this is an LCD). I am applying the updates, and I will reboot and see if one happened to help.

If this relates to KDE then I’m having the same problem. Installation and first reboot into YaST went fine, normal reboots after that get stuck on KDE login screen (kdm?) after entering correct password.

The intel driver 2.99.905 as contained in 13.1 has bugs that can make X crash.
https://bugzilla.novell.com/show_bug.cgi?id=847762
https://bugzilla.novell.com/show_bug.cgi?id=847941

An update to 2.99.906 should fix that, an online update for 13.1 has already been prepared but is not in the update repo yet.
You can find test packages in that bug reports though.

OK, so it worked at first in recovery mode, I applied all updates using yast’s online update. Then I rebooted.

Then it didn’t work in normal or recovery. It stops at graphical system. Shells all work (control+alt+F5, etc).

I tried blacklisting everything that I thought would be problematic, to include uvcvideo (USB video). Nothing worked. Then I commented out all the blacklist comments I had made, and it wouldn’t work without blacklists either.

So basically the graphical system is out. I have an Intel HD Graphics 3000. I don’t know how to proceed from here.

Hm, the Xorg.logs you posted above don’t indicate a crash or any other error.

Maybe there’s something in /var/log/kdm.log (provided you are using kdm)?

Don’t use KDM. I’ll look for some other logs to include (I selected Xfce during install).

OK, so I use lightdm, and I uploaded the logs I found:

/var/log/lightdm/x-0.log -> http://www.puresimplicity.net/~delahunt/lightdm_x-0.log
/var/log/lightdm/x-0-greeter.log -> http://www.puresimplicity.net/~delahunt/lightdm_x-0-greeter.log
/var/log/lightdm/lightdm.log -> http://www.puresimplicity.net/~delahunt/lightdm_lightdm.log

Hm, the greeter cannot run because X is not running, and X terminates right after loading the GLX extension…

Could you try another display manager to see if it works then?
Edit /etc/sysconfig/displaymanger, set the “DISPLAYMANAGER” variable to something else. xdm should be available in any case, so it would be best to try this.

Well going to a shell and logging in as root, then running “startx” works, so I edited the file, let me see if XDM starts…

XDM works just fine. So then maybe the problem is lightdm trying to use GLX?

No idea. You could try others as well, of course.

But as I already wrote in comment #7, maybe updating the intel driver would help with lightdm as well. (although I didn’t see a crash in your logs)

Interesting stuff.

I myself am in the midst of an investigation on similar hardware.

When I “forklifted” my openSUSE 12.3 hard drives from failed hardware into a new system slightly more up to date than yours (i7-4700 using the HD 4600 GPU) I also have been running into a system that just stops at “Reached target Graphical Interface.” The machine doesn’t appear to be busy, it’s just waiting. I can click on any keystroke combination either dropping to init3 or rebooting and the machine executes the operation immediately without fail. I remember a year ago when I was troubleshooting nVidia GPU issues that hung at the same point, there was pause and interruption of something that was running.

If what you’re doing does not produce a desired result (you seem to have progressed further than I have getting <something> to work), I also found that the <latest> i3.1 Release Notes there are interesting options suggested.

IIRC, you’ll find
“nomodeset” is <not> exactly the same as “NO_KMS_in_initrd” unlike earlier posts in these forums. Try both settings.
There is an “intellegacy” driver that can run in User Mode.

I’ve also been doing some separate investigation, there is apparently an open source RPM build to install the GPU intended for Fedora but <maybe> might work? It’s on my list of things to test soon.

In the meantime, I also will be testing a new build as well as maybe some upgrades from 12.2>12.3>13.1 on my hardware and hope to post results.

TSU

I’m seeing this same issue running OpenSUSE 13.1 inside of VirtualBox (4.2.16 on Mac OS X) with lightdm and xfce. This uses vboxvideo rather than the intel video driver.

x-0.log states the X Server terminates after loading GLX.

x-0-greeter.log states that lightdm-gtk-greeter could not open the X display

Once I flip to a terminal (cntrl-alt-f5) I can start the X server or lightdm from the command line and everything works fine.

Not using KDM.

So there seems to be a general problem with LightDM.
See this bug report: Access Denied

Maybe you should add your findings there? (same username/password as here)

Good choice!

I had a flawless install with xfce, except EFI-boot didn’t work (a file in GRUB2 was missing, I didn’t look into details).
Gnome services running, updates smooth.