Installation of 11.1 x86_64 on usb thumb drive Read Only


I have been trying to install OpenSuse 11.1 on a USB thumb drive using the EXT3 file system. The installation has worked until the first boot where the filesystem on the thumb drive becomes read-only. Usually I would log in the system and change the file system back to read/write unfortunately when I try go log in from the console I get the error below:

“cannot remove /var/run/lastblks read-only file system”

and it bring me back to login prompt. So I can’t login and do anything to the system.

I have sucessfully installed Mandriva 2009.1 and Centos 5.3 on this partiular usb thumb drive on this particular machine so I don’t think it has anything to do with the hardware.

How are you installing it?

I’ve had success with unetbootin.

I’m installing it using the DVD that I created using the ISO that I downloaded. I’m not sure what I would accomplish by making the USB thumb drive that I want to install the OS to bootable with the dvd iso? I want to install opensuse on the usb thumb drive. I have accomplished that, but there is some kind of a problem with the installation because after first boot the file system on the usb thumb drive is read-only and then it doesn’t let me login the system to fix it. I have successfully booted off the dvd.

I still don’t fully understand what you’re doing…

Are you trying to have the system on the USB?

Or are you just trying to put the installer on the USB, so you can install from the USB to something else afterwards?

My only suggestions are a) use unetbootin, it’s generally easier. b) with 11.2, you can just byte copy onto a USB. It’s not out yet, but if you’re having problems, may be worth it c) Try different images. For example, I couldn’t get the normal 11.1 image to work on one drive through normal means. The unofficial KDE 3.5 ISO worked fine - and as I understand it, some at least of the Live image installs are persistent.