Installation Medium for USB NET install on old PC (no EFI)

Hi, my son has got annoyed by windows and wants to wipe out the hd of his old laptop installing openSUSE instead. I prepared an USB stick with the LEAP network installation but the laptop doesn’t recognize the USB stick. I had a look at the content and noticed that the USB stick contained only one directory “EFI”.
I suppose that this stick needs a modern UEFI bios to boot from.
So how can I create an installation USB for legacy systems which use the BIOS boot method?

Hi, welcome,

How did you create the stick?

The content of the USB stick is definitely not OK. It should have this if it was created properly


**knurphtlaptop:/mnt #** l
totaal 23
dr-xr-xr-x  6 root root 2048 29 okt  2015 **.**/
drwxr-xr-x 24 root root 4096 17 sep 07:45 **..**/
-r--r--r--  1 root root  133 29 okt  2015 ARCHIVES.gz
dr-xr-xr-x  3 root root 2048 29 okt  2015 **boot**/
-r--r--r--  1 root root  200 29 okt  2015 ChangeLog
-r--r--r--  1 root root 2682 29 okt  2015 content
-r--r--r--  1 root root  481 29 okt  2015 content.asc
-r--r--r--  1 root root  988 29 okt  2015 content.key
-r--r--r--  1 root root   98 29 okt  2015 directory.yast
dr-xr-xr-x  3 root root 2048 29 okt  2015 **EFI**/
-r--r--r--  1 root root  903 29 okt  2015 INDEX.gz
-r--r--r--  1 root root 1826 29 okt  2015 ls-lR.gz
dr-xr-xr-x  2 root root 2048 29 okt  2015 **media.1**/
dr-xr-xr-x  3 root root 2048 29 okt  2015 **suse**/

Hi,
first tried to “burn” openSUSE-Leap-42.1-NET-x86_64.iso with ImageWriter to the USB stick, but it didn’t boot.
Then I had a deeper look at “SDB:Live USB stick - openSUSE Wiki” and used the dd method.
I just tried this stick on an EFI enabled system, it boots well and did a installation media check successfully.

the opensuse iso needs to be written in dd mode
assuming all you have is windows use rufus in dd mode
https://rufus.akeo.ie/
https://github.com/pbatard/rufus/wiki/FAQ#opensuse-issues
download rufus
press alt+I to eneble dd mode
write the iso imgae to usb in dd mode re-try the install, you should note that the net installer doesn’t have wireless drivers so you’ll need wired access to download the needed packages

while I was typing this you replied, I’ve used the dd usb on non efi devices and it works fine

Oh, sorry, my mistake. Yes, it looks like you quoted (ahem, I used a command from the history with which I usually mount my backup hd partition on /dev/sdb1 :-/).
Now the dd version boots well on an EFI PC. Tomorrow (son is sleeping) I will try it on his old laptop.
May be ImageWriter didn’t do the job, or I used it in the wrong way.

Yes, thank you for the reply. My first try with ImageWriter didn’t work, I don’t know why, because I have overwritten the USB stick with the dd method

# dd if=./openSUSE-Leap-42.1-NET-x86_64.iso of=/dev/sdb bs=4M

. Now the stick works on an EFI PC.
Tomorrow I will try it on the legacy one, I will communicate the result :slight_smile:

Older hardware may not support USB boot or may need change in the BIOS setup

Yes, it seems a hardware or bios problem. At cold start the usb stick with the NET installation works. If I do a warm start (reboot) the usb stick is dead.
Ok, so it was an old hardware/bios problem.
Thanks to all helping me in isolating the problem.

you can burn the net iso do a cd, just keep in mind leap is x64 only, if you go with 13.2 the live kde iso can fit on those nonstandard cd’s (if you don’t have a dvd drive)
if that pc des not have an optical drive there are ways to boot from iso images that are on a fat file system, I’ve never done it but it sounds simple enough
http://www.howtogeek.com/196933/how-to-boot-linux-iso-images-directly-from-your-hard-drive/
if I remember correctly there use to be a windows executable that wrote a grub
I do believe unetbootin can be used to install opensuse from windows
https://unetbootin.github.io/
if you chose the disk option it will a temp boot code to hard drive and modify the windows boot meny with a new install linux command, this is usefull for pc’s without an optical drive and usb that don’t boot

ps. in my experience laptops that came with usb 3.0 had a single usb 2.0 drive the 3.0 can not be used to install anything as it needs extra driivers so use the usb 2.0 port, if your laptop has usb 3.0 the only way to detirmine which port is 2.0 is trial and error