Installation issue "Loading basic drivers"

Hi everyone,
Been trying to upgrade from 42.3 to Leap 15 from a CD-Rom.
Unfortunately the installation process stalls indefinitely at the step “Loading basic drivers”.
My laptop is six months old.
Any advice?

It is hard to guess the problem. The most likely cause is a video driver problem. And if that happens to be your problem, then try booting with “nomodeset” as a kernel parameter.

Check my blog post on booting the installer to see where to enter that kernel option.

Thanks, the nomodeset option fixed the problem and allowed the upgrade to complete.
However this was only the beginning of the difficulties (sigh) : the new OS refused to boot with strange error messages.

So I performed a new complete install instead of the upgrade. This worked, except that the KDE desktop responds in slow motion: dragging windows across the screen takes a few seconds; same for all commands such as launching an app or logging out which take a few seconds to show up on the desktop; btw, desktop effects don’t work.
I tried with and without the Mesa-dri-nouveau driver, but this makes no difference. Tried to change the compositor’s rendering backend from opengl to xrender, but again no difference.
The graphics card is a GEForce GTX 1050.

Any suggestions to help?


I think that you use nouveau driver.
Try to switch to nvidia driver.
Do you use xorg or wayland?

You can also try the kernel from this:

Thanks for the hint. It turned out that it wasn’t a driver issue, but you put me on the right track: it needed to disable the nomodeset option from the grub menu.

Looks good now.