installation hangs on Fujitsu Esprimo P900

Hi, it’s the first time that I get stuck with OpenSuse :frowning:
I’ve just downloaded OpenSuse 64 bit DVD 12.2 to install it on a Fujitsu Esprimo P900 E90+
The installation procedure stops just at the beginning (after the loading of linux kernel): the screen is in text mode and the last lines are:


>>> openSUSE installation program v4.0.7 (c) 1996-2012 SUSE Linux Products GmBH <<<
Starting udev... udevd[127]: RUN+="socket:..." support will be removed from future udev release....

I tried the DVD check procedure but it hangs at the same point with the same message.

I checked the DVD with ImgBrn and it found no errors.

Any hints?
Thank you,

max

did you verify your download before you burnt it to disc?
Instructions are on the Opensuse download page software.opensuse.org: Download openSUSE 12.2
The disc check function in imgburn is probably of little use in determining if there are errors in the image that you have burnt to disc.
Also, when burning the iso to disc you should burn at a pretty slow speed (4x) to ensure no errors.

Have you installed earlier versions of Opensuse on the same computer?

Same or similar thing happened to me on installation. Have seen some others say the same thing too.

Although it appears to be hung, it will eventually proceed (though it may bog down again in other spots too). Try again and just leave it – it may take upwards of 5 or more minutes before it resumes at points where it appears stuck.

Let us know

(First time I’d ever encountered this with openSUSE too … and made for the slowest install ever recorded in history! :stuck_out_tongue: )

Thank you farcusnz.
I checked the download with md5 and verified the DVD with ImgBrn.
max

Thank you: I’m going to try it.
max

imgbrn can only tell you if there are disc errors - it cannot verify the integrity of what you have burnt to disc.
I’d recommend borrowing another pc and running the opensuse disc check utility on that.
If it freezes up there also then you probably have a dud disc.

ImgBurn has an option to “Verify (disc) against Image File”. Shouldn’t I trust it?

Anyway I downloaded OpenSUSE 12.1 and it is installing with no problem.
The only difference that I spotted is that the starting screen had a different resolution (something like 1600x1400 with 12.2 and 1280x1024 with 12.1) and the booting sequence with scrolling messages is in graphic mode while in 12.2 it was in text mode. :\

max

For anybody interested: 12.1 installed with no problems.
max

… but
then I upgraded to 12.2 via zypper.
After restarting, boot hangs again after writing only:


Doing fast boot
Creating device nodes with udev

12.2 definitely seems to fail when executing **udev **on this computer.
The “Failsafe” version starts: is there something that I could search from there to understand where is the problem?

Thanks.

max

As a quick guess - do you have options for floppy disk controller in BIOS? If yes, can you try to disable it? It is known to cause similar problems.

Thank you arvidjaar, but I can’t see anything resembling an option for floppy disk.

Then I looked for logged messages during boot.
This is what system writes into /var/logs/message when it hangs:


Nov  8 14:51:40 linux-mztc kdm[958]: Cannot execute 'grub-set-default': not in $PATH.
Nov  8 14:51:45 linux-mztc polkitd(authority=local): Unregistered Authentication Agent for unix-session:/org/freedesktop/ConsoleKit/Session1 (system bus name :1.26, object path /org/kde/PolicyKit1/AuthenticationAgent, locale POSIX)
Nov  8 14:51:45 linux-mztc kernel: nepomukservices[4198]: segfault at 0 ip           (null) sp 00007fff221a0ca8 error 14 in nepomukservicestub[400000+7000]
Nov  8 14:51:46 linux-mztc systemd-logind[635]: Removed session 1.
Nov  8 14:51:46 linux-mztc rsyslogd: [origin software="rsyslogd" swVersion="5.10.1" x-pid="662" x-info="http://www.rsyslog.com"] exiting on signal 15.

At the moment I can’t recognize anything useful, but I’m going to study more.
Any help appreciated.
max

does the live CD boot for you?
and if yes, how about if you try an install from the live CD?

No, it hangs while in text mode after some scrolling: the last message is


Kernel panic - not syncing: Fatal exception in interrupt

The same result with all of the following combinations:

  • 12.2 live KDE 64 bit - launch live distribution
  • 12.2 live KDE 64 bit - check disk
  • 12.2 live GNOME 64 bit - launch live distribution
  • 12.2 live GNOME64 bit - check disk
  • 12.2 live KDE 32 bit - launch live distribution

max

I have the same problem with an HP Compaq nc6400. And with 12.3 is won’t even load the installation program. Both are 32 bit.
It says something about changing
udevd RUN+=“socket=” in /etc/udev/rules.d/71-multipath.rules:7.
Given that those files are off of the DVD, how do you propose to change it?

I guess the only way to resolve it is to install from the web.