Installation from Live-CD/-USB doesn't boot

Hi,

I’ve got an Asus W3N-Notebook (Centrino from early 2005). link

Because I couldn’t get the DVD to start the installation (might start another thread about that), I used the live CD. It boots fine from that and I started the installation.

My partition set up is as follows:

  • two primary partitions for Windows
  • an extended partition for Linux with three logical partitions: root, swap, home

After the reboot, however, the newly installed system usually (see below *) doesn’t boot up. Some of the last messages:

Starting udev... udevd[69]: unable to receive kernel netlink message: No buffer space available

[some stuff I didn't write down...]

Trying manual resume from /dev/disk/by-id/ata-HTS...]-part6

Resume device /dev/disk/by-id/ata-HTS...]-part6 not found (ignoring)

Waiting for device /dev/disk/by-id/ata-HTS...]-part5 to appear 

[after a while]

Could not find device /dev/disk/by-id/ata-HTS...]-part5

Want me to fall back to /dev/sda5 (Y|n)

On “n” it throws me to a shell.

-- exiting to /bin/sh
$ 

On “Y” it first tries …]-part5 again, then drops me to a shell because it fails again.

Because I didn’t trust my optical drive, in the end I tried the same thing from a USB flash drive, created after these instructions with unetbootin as explained in the comments. It’s the same situation, the error messages above are actually from the installation origining from the stick.

*: One strange thing: Last night, when I wanted to check my mail I accidently started Linux instead of Windows, and this one time the boot succeeded and I landed in a running system. I have no idea what could have been any different. After that it has never worked again so far.

Anybody got an idea? Your help would be immensely appreciated!

Just to make it clear for me:

in linux speak:
/dev/sda1 is windows 1
/dev/sda2 is windows 2
/dev/sda3 is extended partition (invisible)
/dev/sda4 is / (linux root partition)
/dev/sda5 is swap
/dev/sda6 is /home

If this is right, you should repair your grub installation, as is tries to boot from the home partition…

And, when you manage to boot sucessfully and try to repair grub using YAST, make sure, that MBR is checked in the YAST bootloader options. Otherwise you won’t even see the booting screen again.

Anyway, some more informations would be helpful!

Thanks for your reply!

in linux speak:
/dev/sda1 is windows 1
/dev/sda2 is windows 2
/dev/sda3 is extended partition (invisible)
/dev/sda4 is / (linux root partition)
/dev/sda5 is swap
/dev/sda6 is /home

If this is right, you should repair your grub installation, as is tries to boot from the home partition…

I also don’t understand the messages I get. The partitions are exactly laid out like that.

But are you sure that it is grub’s fault? To me these messages seem to come from the starting Linux installation. There are also many, many more lines before those I’ve posted.

Unfortunately I have no idea how to obtain a full log. From the shell in which I end up I can do almost nothing, under /dev I get no entries for hard or flash disks: I’ve got no place to store the file.

Anyway, some more informations would be helpful!
I’d love to provide you with what I can. What would you like to know?

Well, the first step is done:

Your grub setup has written some wrong information into the bootloader. Although grub starts successfully, the items in the menu lead to the wrong destination.

I presume, that the entry in your /boot/grub/menu.lst is

root (hd0,5)
kernel ... root=/dev/disk/by-id/ata-HTS...]-part6 resume=/dev/sda5 ...
initrd ...

As you agreed with my opinion about your partitions, the correct entry should look like this:

root (hd0,3)
kernel … root=/dev/disk/by-id/ata-HTS…]-part4 resume=/dev/sda4

Please verify this carefully! In some cases the swap partition is the first, root the second and home the third entry in the partition table. Sometimes /dev/sda4 does not exist, so you could end up with /dev/sda3 extended partition followed by /dev/sda5 for the first linux partition, /dev/sda6 for the second and /dev/sda7 for the third.

So you have several options (worst last):

  1. edit the bootloader at startup
  2. repair the bootloader from the installation dvd (further instruction see here: GRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader.
  3. install linux once again from the scratch >:(

As your bootloader starts perfectly, you should be able to succeed with the first choice:
When your boot screen appears, hit the [ESC] key to enter the text modus. There you can edit both lines of the menu entry (press [e], all is explained on screen) as mentioned above.

Then your system should start and you may want to correct the grub entry in /boot/grub/menu.lst with YAST and write it back to the bootloader (remember to make sure, that the MBR option is checked! Otherwise you will end up with needing to look at the 2. choice, swerdna’s solution :\ )

Good luck!

Dear Vetti,

thank you very much for your help!

In the mean time I tried to boot again and landed in that dreaded shell again. But this time I looked around a bit more. In / I found a file mkinitrd.conf and looked at it. At that stage it said something like (from memory):

-d resume=/dev/sda5

I changed that line to /dev/sda4, the location of my root partition, and called /init, a script I found there as well. Lo and behold, everything started up fine this time!

I presume, that the entry in your /boot/grub/menu.lst is
Code:


root (hd0,5)
kernel ... root=/dev/disk/by-id/ata-HTS...]-part6 resume=/dev/sda5 ...
initrd ...

In my /boot/grub/menu.lst it says:

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.1
    root (hd0,4)
    kernel /boot/vmlinuz-2.6.27.7-9-default root=/dev/disk/by-id/ata-HTS541060G9AT00_MPB310X5G0PL5B-part5 resume=/dev/disk/by-id/ata-HTS541060G9AT00_MPB310X5G0PL5B-part6 splash=silent showopts
    initrd /boot/initrd-2.6.27.7-9-default

So you’re right, that part is messed up! So I’ll change both parts to …-part4 and see if it works out fine.

I should maybe read a bit about how the boot process in (SuSE-)Linux works, it’s all a big mystery for me right now (what exactly is getting “resumed”?). I’d never have thought to find the issue in grub’s configuration.

Please verify this carefully! In some cases the swap partition is the first, root the second and home the third entry in the partition table. Sometimes /dev/sda4 does not exist, so you could end up with /dev/sda3 extended partition followed by /dev/sda5 for the first linux partition, /dev/sda6 for the second and /dev/sda7 for the third.
No, it’s indeed as you said. I edited the partitions myself with parted and also viewed the layout numerous times from various Linux live cds and also now from the now running system on the hard disk.

Best regards and thanks again!

OK, I was happy too early. It didn’t work. And I couldn’t reproduce the start-up that went fine this afternoon.

By calling /init a couple of times (failing) in the shell in which I end up every time I could at least get some partition device files to appear. Alas, I couldn’t mount them. But I noticed some strange thing: Apparently that one time there was no sda3, only sda4, sda5, sda6 and sda7. Is this supposed to change?

I really don’t know what to do. Experimenting with the boot options takes time and apparently doesn’t provide consistent results.

I couldn’t get the installation DVD to start up at all, after I press [install] it always stalls/freezes in an early stage. I think I can’t use its repair function. And I’ve already tried reinstalling from the live-CD/-stick, it didn’t end up differently.

OK, either I messed up before or things changed during my various installation attempts, reformats and repartitionings. It’s indeed and constantly sda1 & sda2 for Windows here, then sda4 containing sda5, sda6 & sda7 for Windows.

However, after almost one week of frustation I’ve given up on openSUSE for now and returned to Kubuntu. Their KDE 4.1 desktop is not as nice as the backport-enhanced KDE in SUSE, but KDE 4.2 is about to be released anyway. The Ubuntu-install took maybe half an hour and worked flawlessly out of the box… Maybe I’ll give openSUSE 11.2 a shot.

As far as I can detect, what you did, you have changed the grub entry and wrote back again. Did you do that with grub shell only or did you use yast as well?

Especially the second line:
kernel … root=/dev/…-part5 resume=/…-part6
looks strange. This indicates, that resuming tried to boot from an other partition. Which could not work, of course. It should have looked like …-part4 resume=/dev/sda4.
And, of course the first line should have looked like
root (hd0,3)

Nevertheless, when rewriting the partition table, i have seen in some cases, that the first entry after the extendend partition skipped one number. To me this happened with ubuntu as well. Moreover, the UUID changed and mounting from /etc/fstab failed (which might have happened to your system as well after reorganization of the partition table). So, take care!

Anyway, the method of system configuration via yast is my way of choice, to get a stable system running. So, if you run into trouble with ubuntu, don’t give up! Come back and we will tame the beast, until it will obey to all yasted orders. No need to grub or gparted mess around any more.

cu!

Hello,

i have the same laptop (asus W3N) and exactly the same problem. I have already submitted a bug report:

https://bugzilla.novell.com/show_bug.cgi?id=457125

But so far there is no solution. Maybe you should also post some informations of your problem there.