installation freezing after loading kernel

Trying to install Opensuse 11.2 (64bit) on a new machine isn’t working well.
After loading the linux kernel, the green screen with the progress bar
appears, and the mouse and keyboard turn off (at least, the leds go out and
there’s no response) The progress bar never moves. Esc key doesn’t work
either. I’ve tried safe mode install and other options, but the same result
follows.
It’s going onto a Tyan S2912 with AMD 2347HE. The hard drive is a Western
Digital SATA drive I bought today. There’s 4GB of RAM, and the DVD drive is
a Toshiba USB unit. I don’t know what else to say about it.
If it helps, I’ve been running Pelican HPC (live) without a hard-drive and
got tired of setting the network configuration and installing a couple of
programs with every boot. (Which is why I bought the hard drive today). I
want to install Opensuse 11.2, but I’ve tried Debian (no luck on detecting
the hard-drive) and Windows 7 (installed fine, but there are no drivers for
the embedded video).
Any help would be appreciated. Thanks.
-tom

I can’t remember whether it’s “splash=silent” or “nosplash.” Try these at the boot screen: as soon as the boot screen appears, just start typing, then press enter. This should turn off the splash screen to let you see where the hang is occurring.

It’s got to be very early in the boot, possibly during the primary kernel load and init. You may need to try a different kernel (and one quick way to do that is to download a live CD for, say, Opensuse 11.1 or an older version of Ubuntu, for example).

Pelican HPC uses kernel 2.6.30, according to a quick Web search, while Opensuse 11.2 uses 2.6.31. That’s why an older kernel might work. Give it a try.

Well, without the splash screen, it shows that it hangs up at “starting udev
…” at 2.28 seconds.
I’ve been googling this for a long time and can find nothing other than the
users with this problem have SATA drives.
I’ll keep at it and post here if I can find a udev fix that works. I’ll keep
checking too in case someone already knows how to fix it.
Thanks.
-tom

smpoole7 wrote:

>
> tmillic;2121242 Wrote:
>> Trying to install Opensuse 11.2 (64bit) on a new machine isn’t working
>> well.
>> After loading the linux kernel, the green screen with the progress bar
>> appears, and the mouse and keyboard turn off (at least, the leds go out
>> and
>> there’s no response) The progress bar never moves. Esc key doesn’t work
>> either. I’ve tried safe mode install and other options, but the same
>> result
>> follows.
>>
>
> I can’t remember whether it’s “splash=silent” or “nosplash.” Try these
> at the boot screen: as soon as the boot screen appears, just start
> typing, then press enter. This should turn off the splash screen to let
> you see where the hang is occurring.
>
> It’s got to be very early in the boot, possibly during the primary
> kernel load and init. You may need to try a different kernel (and one
> quick way to do that is to download a live CD for, say, Opensuse 11.1 or
> an older version of Ubuntu, for example).
>
> Pelican HPC uses kernel 2.6.30, according to a quick Web search, while
> Opensuse 11.2 uses 2.6.31. That’s why an older kernel might work. Give
> it a try.
>
>

Hi!
Try to check the installation media before loading the kernel.- there is an option for that in the boot menu.
Good luck.

What about BIOS storage settings ? … might also be called “I/O” or “IDE” settings depending on BIOS brand an release .
Can you play with different modes like “legacy”, “sata”, “ahci”, “raid”, something else? If so, try “sata” first, then “ahci”, finally “legacy”. It might be a wrong advice, but I’ve seen mainboards booting only in sata mode while others required ahci. You could also try to disable ahci at boot. Also take a closer look at USB BIOS settings. Are you using a USB hub or is the DVD drive directly pluged into a USB port?

After trying a number of things, I disabled “ACPIMCFG Table”. I have no idea
what that is, which is why I tried it after the other options. It worked
though. I’m a little annoyed with the motherboard manufacturer at this
point, and very pleased that I’ll be able to run Opensuse on the machine.
Thanks!
-tom

please try again wrote:

>
> tmillic;2121242 Wrote:
>> I’ve tried safe mode install and other options, but the same result
>> follows. It’s going onto a Tyan S2912 with AMD 2347HE. The hard drive is
>> a Western Digital SATA drive I bought today. There’s 4GB of RAM, and the
>> DVD drive isa Toshiba USB unit. I don’t know what else to say about it.
>>
>
> What about BIOS storage settings ? … might also be called “I/O” or
> “IDE” settings depending on BIOS brand an release .
> Can you play with different modes like “legacy”, “sata”, “ahci”,
> “raid”, something else? If so, try “sata” first, then “ahci”, finally
> “legacy”. It might be a wrong advice, but I’ve seen mainboards booting
> only in sata mode while others required ahci. You could also try to
> disable ahci at boot. Also take a closer look at USB BIOS settings. Are
> you using a USB hub or is the DVD drive directly pluged into a USB port?
>
>

The APCIMCFG table has to do with whether PCI cards are memory mapped or IO mapped. Some BIOS’ have problems using the newer memory mapping. Glad you were able to get it working.