Installation Freeze - Tumbleweed & Leap

Hi all,

I’ve been unable to install both Tumbleweed & Leap on my Macbook Pro.

Process :

  • tried both NET installs & DVD
  • booting from USB
  • Choose install from the initial menu
  • Press Esc during install to show boot message
  • Last message that I see is “Found a Linux console terminal on /dev/console”
  • Then a blank screen with a non-blinking cursor top left

I’ve been doing some searching, and tried adding “nomodeset” to the install options, without success.

The Macbook Pro currently has Fedora installed, and the iso’s work fine if run in Gnome Boxes.

If any more information is needed, please ask.
Any help would be much appreciated.

Thanks

If you’re inserting your install media as burned optical disks ie DVD in your DVDROM,

Then the problem is either you’ve downloaded corrupted files or burned badly

  • Do a checksum to verify integrity or
  • Download using a “better” torrent client which will automatically checksum every piece of the file and check the file again once it’s fully downloaded and put together (ordinary http and ftp downloads don’t do this)
    Most DVD burning can do a disk check afterwards. It can take 3 times longer than the actual burn but if it’s necessary…

or
You haven’t configured your machine UEFI/BIOS to boot to the media.

At the point you’re describing, it can’t be anything else (that I can think of ).

TSU

As mentioned above, I’m booting off a USB. (But I’ve also tried from a DVD).

I get the same problem with multiple iso’s - NET install, DVD, Tumbleweed, Leap, and all of them work as virtual desktops - so corrupted files would seem unlikely.

The checksums are all ok.

It does start to boot from the USB, the problem is part way through.

The point at which it freezes is just before it goes from text to a graphical environment, so I think that it is a graphics / graphics card issue of some sort … but I’m not sure how to investigate further.

Thanks.

My problem seems similar to someone else’s :

https://forums.opensuse.org/showthread.php/510517-Network-install-boots-to-blank-screen-with-cursor-at-bottom-and-does-nothing-on-Macbook