Installation error on Tumbleweed 20170317 (might help developers)

I downloaded this iso “openSUSE-Tumbleweed-DVD-x86_64-Snapshot20170317-Media” of Tumbleweed last Sunday, and burned it to a DVD and tried to install it today. After the installation was almost over (all the packages had been installed) I get this error
Then it said “Installing boot loader” or something like that, and I rebooted, and the installation was broken.

I have a 1TB hard drive with 2 partitions for Windows 8.1 (one that’s a few MBs for Windows’ boot files, and another for the Windows installation that’s about 500GB). During the Tumbleweed installation, I created manually two partitions. A 2GB partition for the swap, and everything else for the root folder ‘/’ (about 598 GB).

I’ve done this installation several times (never with Tumbleweed) and the above worked every time. As a matter of fact, the partition that I was installing Tumbleweed on, had an older installation of OpenSUSE already in it. The only thing that I did different this time, was that the partitions were using Btrfs, instead of ext4.

I didn’t know i could run any commands on the installer, so I haven’t saved up any more info than that, and I will re-try the installation with the new snapshot of Tumbleweed, so I don’t really need any help/support anywhere at the moment. Just thought this might help the developers.

Edit: Forgot to mention that I couldn’t get WiFi during the installation, so I didn’t set-up the networking. All the packages that were installed, were in the DVD.