Installation DVD freezes after loading Initrd


I’m trying to install 12.3 on a laptop (windows 8 already installed and working great apart from the UI which sucks) and it is freezing after loading the initrd (I put an echo statement after the initrd load line to check this). I’ve tried adding nomodeset to the kernel parameters and blacklisting nouveau. But it is still failing to get any further and I’ve left it for a good hour just to make sure. I also get an error message just before booting into grub, I’m at work and can’t remember the exact message, but it’s something similar to “Can not load gltgfx”

The laptop has the following spec:

The Novatech Elite N1535

Intel i7 3630QM Processor
Seagate Momentus XT 750GB Hybrid SSD
NVIDIA GT 650M GDDR3 2GB Graphics
Intel HM76 Chipset (built in Gfx)

I’m suspecting that it is to do with the hybrid gfx, but am clueless on how to progress.

If you can not get the kernel to load, you are just dead. I have done an install before, used the kernel load option 3 to stop the Desktop from loading and then upgraded the kernel to 3.8, but you can not just be dead and get this to work. If you can get YaST to run and can get online, you can get a newer kernel, all from terminal. If we can assume this is not an Optimus dual graphic laptop, you should be able to get a GT650 to work. I have a 550 on one PC and a 660 Ti on another, all under openSUSE. I tried a nVIDIA 9500 card and could only install openSUSE in Text mode, but then the Dsktop did come up. I then promptly upgraded to kerenl 3.8.

Thank You,