Installation does not see my hard disk at all?

Hello,
recently I bought new laptop for schoolwork etc. and I wanted to start trying out Linux and since we use OpenSUSE Leap 15 in school I decided to choose it for me aswell, but I still wanted to keep Windows 10 running aswell, so dual-boot is i think only option for me.

So I downloaded OpenSUSE Leap 15 iso file, created a bootable USB and unallocated around 150 GB of my disk for it. I started digging into the installation and when I came across Partioning page, and chose “Expert Partioner” option I noticed, that in “Hard Disks” there are only 2 devices (types: “usb 0x090c UFD…[USB FLASH DRIVE NAME]” and “DOS32”) both sized 14.73 GB, so obviously that is the Bootable USB, so it doesn’t see Hard Disk inside at all :’(. Does anybody have solution for it? Can I make somehow the installation make see my actual Hard Disk which is inside(and on which is Windows 10 installed aswell)?

Hi, welcome

Have you tried booting from a Leap 15 live image?
What is the laptop brand / model?
Can you post screenshots on paste.opensuse.org and share the links here?

Thanks for a really fast answer.

The laptop is Lenovo Yoga 520-14IKBR(Soem of the specs: Processor: Intel Core i7 8550U Kaby Lake Refresh, 8 GB RAM, GPU: Intel UHD Graphics 620, Disk: 512GB SSD(According to BIOS it is Samsung MZVLW512HMJP-000L2)).
I just tried the live image and after some time of loading with Leap logo, the computer is stuck on screen with flashing underscore and nothing happens.

Attaching screenshots(Sorry for bad quality, images taken just by a phone):
http://paste.opensuse.org/12885258 - After choosing “Desktop with GNOME” I get to this screen
http://paste.opensuse.org/10220165 - After clicking “Expert Partioner”, other sections like “RAID”, “Volume Management”, “NFS” and “btrfs” are empty

How did you create the install medium?

This shows suggested partitioning in conflict with your wish to multiboot with existing Windows, so you need to reject the suggestion by selecting Expert Partitioner. Hopefully Expert will find the HD in addition to the SDD. If it doesn’t, try Ctrl-Alt-F2, then execute

# fdisk -l

and/or

# blkid

to see if the kernel picked up the HD after YaST partitioner. I might also try

# partprobe

before returning to YaST (Alt-F7). At this point likely you’d need to go back to the step before partitioning. This has never happened to me, so I’m only suggesting things I might try. If I didn’t find a solution soon, I’d check to see if TW produces the same failure. If yes, I’d next try installing 42.3 minimal, then online upgading using zypper to 15.0, and report a bug.

After reading Won't detect disk partitions - Install/Boot/Login - openSUSE Forums I’m wondering if maybe Lenovo put some strange MBR code on the HD that creates the same problem as Smart Boot Manager (SBM)?

How is SSD connected - SATA or NVMe? Post output of “lspci -nn” from any live Linux.

Thank you all for suggestions, just found a solution with my friend. The problem was in SATA Mode, I had to change it in BIOS from Intel RST Premium(according to searched data it is RAID) to AHCI and reinstall whole windows(which was fortunately almost completly clean). Then the installation was finally able to recognize my HD.

One more time thank you for your time, I hope you have a nice rest of the day, bye.