Installation crapped on me

Yesterday I downloaded the 11.1 dvd, and decided to do an upgrade from my otherwise somewhat functioning 11.0 install. I had gotten most of my stuff working but the install was behaving weird.

Attempted an upgrade, which ended up … not functioning so well, and spitting error messages on me when upgrading and later when running.

So, naturally, I decided to do a full install instead, and that I did a couple of hours ago.

In my computer, I have 3 SATA-disks, one IDE-disk (the one I run opensuse from), 1 DVD-ROM and 1 DVD-writer, 1 external 120gb USB-drive with one NTFS-partition, and one fresh 300gb external USB-drive.

One of my SATA-disks is an 80gb disk with the only purpose of running WinXP from, all my data was stored on the two other disks, one 250gb with two NTFS partitions, and one 300gb with one NTFS partition.

When I logged in the first time, all my SATA-disks were mounted except the Windows-drive. In the installation-process, the installer recognised the drive as NTFS, but the partition itself was marked as no filesystem, or unknown filesystem. Didn’t even reflect on that at first though. I wasn’t able to mount it or anything. So I attempted to boot into Windows instead, only to be met by “GRUB” and nothing else.

Is there a way for me to recover the partition without repartitioning? I have all my passwords and data on it (I did backup some, more on that later), and was simply keeping it to be on the safe-side before doing the final transition to linux.

I attempted to run ntfsfix, but get a “Volume is corrupt, you should run chkdsk”

Second problem, the 300gb external harddrive had never been used, so when I was running 11.0 i partitioned the full disk as ext3, and moved some of my crucial data from the windows-install and 11.0 install to it. Now, it isn’t even detected. It’s nowhere to be found. It just stands there with it’s pretty glowing lights, connected to the computer and all, but is nowhere to be found for mounting. Not the disk itself, not the ext3 partition, nothing.

How do I make linux detect it again? With some of the stuff I’ve stored there, the windows-disk wouldn’t be as crucial anylonger and I could probably simply repartition it as ext3.

My transition-plan seems to have simply abandoned me and left me alone.

Can anyone help me? :’(

How courageous of you!

I set aside a small boot partition and use LVM to permit manegeable testing, with a new release on the real hardware. If it’s just applications you’re interested in, then Virtual Box installs suffice, and reduce risk yet further.

I think you’re talking about the 80GB XP disk…

Hard bitten sysadmins would probably go as far as disconnecting power on pure NTFS disks with important data, and then fix up things like GRUB and the mount points post-install.

This defensive mindset, and distrust of shiny new software to do automatically such things is a learned response to traumatic experiences.

I think you’re going to have to do what you’re told. Last time I had a corrupt NTFS filesystem to deal with (XP only machine), the Live CD found an issue, and gave me the chkdsk option to run, which I then did from M$'s ghastly recovery boot option (I think Vista’s made a huge stride forward here, though I don’t make a habit of using it).

So do the chkdsk thang and scan for bad blocks, and let it try to repair itself.

Don’t panic!

You’ve done a whole shed load of stuff at once, but I’m sure the data’s there (unless you’re really unlucky and had a silently corrupting PATA driver). You can probably simplify the system a bit, and fix the IDE disk up, and use the Live CD or installer to get the data off that drive later on, if it remains an issue.

If you’ve lost partition tables then Live CD, with gpart, is a life saver. I’ve learned to make records of partition tables with sfdisk(8), so they can be restored, as some disks (drivers) seem to enjoy corrupting them occasionally.

Never lost any data that way yet though, the main danger is in hasty attempts to fix things, that are badly thought through however.

So go slow and methodical, be ultra defensive and decide which problem is your priority, what you need to do to sort it, and the simplest configuration of hardware, if the machine seems unhappy.

I’ve seen some bug reports, where PATA and SATA are mixed together. In some cases, libata/pata_xxx doesn’t work as well as using the old IDE/ATA drivers and /dev/hdX devices.

Well, chkdsk didn’t fix the problem. I stayed up all night last night (til around 6am) testing various programs, bootdisks and what not, and none of that fixed the problem either. A lot of them seemed to find the lost partition-info, but none was able to actually restore it. The disk is untouched besides the partition-info getting wiped, so I figured I’d try and at least get as much as possible of my most crucial data back, and again tried various apps and bootdisks and omg-i-cant-believe-so-much-crap-exists. A couple claimed success in finding the files, but gave me no option to restore it.

10 minutes ago I started “photorec”, and lo and behold. It seems to be able to find pretty much everything. I’ll just cross my fingers and hope it’ll do what I want it to.

I’ve given up on being able to boot into Windows again, and frankly that was the original plan when installing openSUSE on a spare 2.5" disk I had lying around :smiley:

I didn’t. I relaxed for a while. Then disconnected the drive again (I don’t remember how many times I did that before), rebooted the machine and connected it again. There it was. Fully functional. No data gone. Except I apparently hadn’t stored the data on it that I thought I had stored. But that’s ok. Every single piece of crucial data (password-files, customer-information etc.) is going to be copied to usb-sticks for safekeeping from now on.

Thank you for your reply, it was very enjoyable and helped me to calm down a bit :slight_smile:

Good job!

If you used Testdisk (the parent program for photorec) and it repaired/rebuilt the partition table and/or restored the boot sector (it’s a great tool), then it is probably bootable now. You can try chainloading to it from the grub menu; just be sure that the bios boot device sequence agrees with what is in /boot/grub/ You don’t need to edit the grub menu.lst to try the chainloading, you can do it from the grub menu by breaking out into the shell (Escape, then “c” key) - the syntax is:

rootnoverify (hd<x><y>)
chainloader +1

where <x> is the grub disk number and <y> the grub partition number.

I started TestDisk, discovered it 15 min. ago, ran it and managed to repair bootsector as well as partition information.

The disk is finally possible to use. I can look my clients in the eyes (not literally, this is after all the internet) again, with all their information still intact :smiley:

Oh Happy Days!

Thanks for the tip!

Happy to oblige :slight_smile:

Just a little fwiw tech note re Testdisk: It does actually try to reconstruct the partition table, a formidable task. But for the boot sector, it is just restoring from the backup copy at the end of the partition which NTFS creates when it formats, i.e., that sector can be restored by other tools, too. The XP recovery tool however actually rebuilds the sector.