Installation can not find any hard disk


I am trying to install OpenSuse 11.0 and during the installation can not find any hard disk. I had the same problem with 10.3 version BUT OpenSuse 10.2 installs and works fine. Windows XP is also on the same machine with no problems.
Has something changed after 10.2. I am really desperate and looking forward to use the new OpenSuse and I would appreciate if you could help me.
When I was trying to install 10.3, I also tried Fedora 8 and I had the same problem: it could not find the hard disk to install.

Any help is much appreciated.

The problem may be that the kernel module required to access your disk drive controller, is not being loaded by the installation program. Most of the time this is figured out by the installer, but not always.

If you have ever installed Windows 2000/XP/Vista, you may have seen this before. It’s where you hit the F6 key to tell the install that you have a driver to load, and then you provide a floppy with the driver on it. For example, this may be required if installing to a SATA hard drive. So, what you are encountering is nothing new as far as installing a new OS.

In the openSUSE install on the first menu, there is an F key that takes you to a long list of different types of drivers, which you can ask to be loaded. The challenge is to figure out which driver you need . . .

In Windows, use Device Manager or run msinfo32 to get information on your disk controller. If there is not enough identifying info there, download and install the free SiSoft Sandra application; Sandra will report in detail all the hardware component on your machine. From there you can google to find the linux kernel driver needed. Be sure you are finding the driver for the current kernel; sometimes there is a new replacement with a different name than the previously used driver for a device.

Alternatively, try booting from a live CD. Live CD’s (especially the one from Knoppix) often load a large number of drivers to handle whatever machine it is running on (while an installation will choose only those actually needed for the installed machine). Verify you can access the drive by mounting it from a command line. Then as root use the #lsmod command to list all the loaded kernel modules. Using #lsmod and googling a bit you will be able to identify the disk controller modules that match up to your hardware.


thanks for your detailed reply. I tried as much as I could but am still stuck. Here is what I did:

I am using the KDE Live CD, I checked in windows and my disk is a (Western Digital) WDC WD2500SB-01KBC0

I think the kernel for this OpenSUSE distribution is:

While I am using the Live installation CD none of the F buttons in the beginning offers to load drivers. So, I have no idea how to load and find the drivers. Using OpenSuse 11.0 with the Live CD I click on Hardware information and I do not see any disks. Typing df at the command window (using Live CD) gives me:
Filesystem 1K-blocks Used Available Use% Mounted on
udev 517480 60 517420 1% /dev

Do you think I can find the solution to this if I look back to my already installed 10.2 OpenSUSE? Any other suggestions?

I am having the same problem with the same drive. using an Asus mb single core 2600. Have tried a number of different things and no luck. Have compiled kernels trying to get it to work properly and it does not help. Have a feeling it has something to do with the bios. Let me know how you make out and I will do the same.

ve3ixi Dave

I too am having the same exact problems. I had this problem with 10.3 as well but it eventually installed after rebooting the DVD like 20 times.

Since it has proven to be unreliable in my system, I uninstalled it and am running Ubuntu. I have been running it and other distros with no problems.

I want to get back to Suse, but this seems to a problem for more than a few users including myself. The installer just will not see the disks

System is a follows:

Abit AB9-Pro Intel E2180 Dual Core
Intel ICH8 2 + 4 Port SATA Disk controller
Raid is disabled in bios /etc
1 500gb WD WDC50000AAKS Sata drive installed on port #1
Vista ultimate installed on primary partition
25 Gb partition (primary/unformatted) for suse install
4GB DDR800
2 Samsung SH-S182M IDE DVDRW Drives

Any info would be helpful.

I didn’t realize you were using the Live CD, I thought it was the installation DVD. Unfortunately, I don’t have an openSUSE Live CD from which to take a look at its process.

With Knoppix at least, you would not see a drive with the df command unless you mount it first. You will see the partitions detected in /etc/fstab, however.

If you have (or can do) a 10.2 installation, you would be able to determine what kernel modules it is using. With the 10.3 and 11.0 installation, you can hit the Escape key immediately after the installation has begun, to drop the graphical screen down to text. After initializing the processing hardware, the install kernel will attempt to detect the disk controllers and then load the corresponding kernel modules. Perhaps you can do this with 10.2, too.

So you’re having the same problem with the 11.0 installer? Are you using the installation dvd (not the live cd)? Have you hit Escape after starting the install and looked at the kernel log? Is the kernel detecting the disk controllers and loading the necessary kernel modules?

I should have stated that, yes I am using the full DVD (x64). I had the exact problem with 10.3

I have yet to check the kernel log, I will check and post my errors.


Have you seen this? - Fedora 7 (Intel P965) no Sata Hdd: Cannot install

This may also be of interest:

Serial ATA (SATA) Linux hardware/driver status report

As explained, there is a known issue with ICH8 and with your Abit mobo in particular. There are several tricks in the Fedora post, using kernel boot parameters and how the hardware is installed vis-a-vis the JMicron controller also on your board. The Fedora post is a year old, so I would keep googling to see what the status is with the most current kernel and drivers.


The above indicates a specific hardware problem. Besides trying the above 10.2 installation test or the Knoppix test, you might want to find out what disk controller is in your system and do some research on it. In fact, what would be even better would be to install Sandra as I suggested before, which will give you the motherboard, chipset, and controller information. Then google for linux experiences, starting with opensuse, on your motherboard. Usually there is a solution. I should add that at least with the regular installation dvd (can’t say if this is possible with the live CD), you can use a “safe mode” to install which turns off several features in the kernel which are those most frequently a problem (i.e., turns off acpi, apci, and lapci).

Thanks very much again for your useful reply. Just to say here that while I tried only with the Live CD for 11.0, I used all options (network/Live CD/DVD) for installing 10.3 previously with no luck (10.2 is fine).

I used the DVD for 10.2 now to see the info for the driver. I clicked before I start 10.2 installation: “System Information” → “Hard Disks or CD-ROMS”.
Then I got:
/dev/hdc (disk, dev 22:0-22:63)
Model:“WDC WD2500SB-01KBC0”
Geometry(Logical): …

I noticed that before the installation of 10.2 F5 says driver, then has the option of yes/no/file. Assuming that I will get at some point to that if I use the DVD of 11.0 what am I suppose to pick from these options or what to type at that time?

Live CD gives me access to Yast and then System->Kernel settings. I tried things there with no luck again.

I think I am getting closer to it. Anything to add on my latest observations?
Thanks again.

Ok, My problem has been resolved (thanks mingus725!) After reading the post for the fedora 7 I questioned my bios settings for AHCI mode with the drives connected to the ICH8 SATA ports.

If you have the ICH8 or JMicron controller and DO NOT use raid. Make sure that this setting is turned to AHCI. By default it is set to IDE. When suse loads the drivers to this controller it gets stuck trying to poll the device and eventually fails.

I quickly changed to AHCI, rebooted and Bingo! Suse is installing right now. WOOO HOOO :slight_smile:

Thanks for that link

ok, update… it installed fine with it ahci enabled. Went to reboot, system cannot find system disk, won’t boot from dvd using the oot system option.

Re-enabled IDE setting in bios… works, boots the hd. Gets to loading. Again does not see the hd. Also the keyboard (usb) takes forever to activate…

what a pain. Still trying to figure this out, I don’t get why ubuntu and others can do this just fine… I know there is a driver issue, just trying to get to the bottom of it


Not that this helps all that much, but I think the reason it worked before but doesn’t now is that the driver had to be changed for other reasons, such as the new implementation of ahci. The driver site I linked above may explain this (or maybe I saw it elsewhere; my eyes are crossed now). I also seem to recall in that Fedora forum discussion of a sequence to set up (dvd, ide, sata) to get linux installed in several steps. It’s a kluge, but maybe the only way. Good luck.