Installation Bugs? relating to Grub2 MBR, keyboard layout, and date-time - Tumbleweed

I have installed Tumbleweed for the first time. During installation I asked to install grub2 to MBR and an error occured. It told me I would find details in the log but I am not sure what I am searching for.

Although I set my time to London and System clock to UTC I seemed to end up with UTC+2. I checked in the Bios and the system clock was correct.

Although I set my keyboard to british it appeared to be set to US. I had to change it to US and back to british in Yast before it worked properly. (British shift-2 is " not @)

I cannot ssh connect to Tumbleweed with Putty from Windows. I can connect to Debian with Putty, and from Debian to Tumbleweed. I can connect to Opensuse 13.1 and 13.2 I am fairly sure although haven’t tried it recently from Putty.

Maybe I should report these as bugs?

Is this an EFI BIOS/UEFI?? Did you boot to legacy mode to use legacy booting? Are there other OS? what boot method used for them mixing EFI and Legacy is a very bad idea.

There are at least 3 times first is hardware time the clock on the MB. Then there is the system time that is for all system functions and next is each user can have a time set. Don’t confuse them.

Installation logs should be in /var/log/YaST2, main log being y2log but others may provide additional information.

Although I set my time to London and System clock to UTC I seemed to end up with UTC+2. I checked in the Bios and the system clock was correct.

“Correct” as in “matches wall time”? Please explain what is “correct” time in this case for you.

Although I set my keyboard to british it appeared to be set to US.

Appeared where? On text mode VT, in DM, after logging in in GUI, somewhere else?

I cannot ssh connect to Tumbleweed with Putty from Windows.
May be it is your firewall setup.

Maybe I should report these as bugs?

With the amount of information you provided so far? This will be waste of time and bandwidth.

This is not UEFI. It is an old computer. There is also Windows XP installed. I installed XP first with its own boot loader, then added Tumbleweed afterward.

I found the log for yast, and looked with zless, but did not know what to search for in the log.

I have added numbers to the quote, so

  1. It was correct in that it matched UTC, and so matched my assertion in the installation that the system clock was set to UTC. My current time zone is British Summer Time which is GMT+1/UTC+1

  2. I was logged into the gui probably with xterm. Unfortunately as I have now fixed it I cannot recreate it. I don’t seem to have any other terminal programmes installed.

  3. It is not the firewall as I allowed ssh during the installation, and also I can connect from other systems like debian. Today I installed opensuse 42 in a VM and I am able to connect with that. I am not able to connect with SmartTTY. It gives more information, saying LIBSSH2_ERROR_KEY_EXCHANGE_FAILURE. I have checked that libssh2 is installed.

  4. Sorry about that. The questions people would ask just didn’t occur to me.

I forgot to address the second point. During the installation I opted to create a non admin user, and then I was prompted for root user password. I have not yet created any other users or altered the timezone of the non-root user. I selected Europe London as my timezone. The system clock would have been set to UTC during installation because I have set Windows XP to Cassablanca because that stops it from changing the system clock. (Cassablanca used to use GMT all the year around when XP was made). I also opted to sync with NTP during the installation. So that’s all I did, no other change.

“it” you mean RTC in BIOS? So where do you see UTC+2?

  1. Unfortunately as I have now fixed it

Telling how you fixed it is helpful with respect to other users who now have something to search for.


It is quite possible that your terminal program is too old and does not understand key format used by TW.

Users are users system is system and hardware is hardware. Each and every user has their own settings. This is a multi-user OS. The user offsets are from system

All users are non administrative, But they may have the same password as root. But that give no special powers

Yes I went into the bios/cmos settings on the computer at/before boot time and looked at the time and it was set to UTC. I saw the UTC+2 when I booted the system up and typed ‘date’ (as non admin, but I will bet a heap of cash it would have been the same for root).

I fixed it simply by using yast -> date and time and changing it using the option to change the time manually.

What I would have expected is that during the installation I would specify the timezone, which is London UK Europe, and then specify to sync with NTP and then when I eventually boot the installed system and type date, it would display the current local time for my timezone, which is currently, because it is summer and we have daylight saving time, UTC+1.

OK so ssh has changed the format it uses. I will have to try other teminal programs or use linux in a VM.

OK but during the installation there is a screen to specify a user, and an option to specify if this user is an admin user. I always say no to that. And then the next screen prompts me for a password for the root user. So if I do nothing else other than install and boot the system, what would you expect the date command to display for the root user and for the other user created during installation?

Not really it just sets root and the first user to use the same password it does not give the user any root powers. This is not Windows where lines are blurred. And root is just another user but with god powers. So root is not system

My suggestion is that you read that more carefull next time you install. I doubt the words “admin user” are used. That is not a Unix/Linux term at all.

Yes, I have seen this in the past. My guess is that when you change timezone current time is not adjusted according to new timezone, so it stores wrong time as result. I never had time - pun unintended - nor real incentive to reproduce it on purpose, it was easier to just do as you did - correct time after installation. NTP may not work always, it may refuse to correct to large time offset.

Admin user is an english term for someone who administrates, i.e. a system administrator.

You will see from this screen shot that the phrase used is “use this password for system administrator”. Just because Microsoft used the same phrase it doesn’t mean they own it and it cannot be used in its original sense.

OK I misunderstood what it was doing there maybe. I thought that if I checked that box then the username would be the admin user. I had this experience on Ubuntu where the root user was not called root and I didn’t like it at all.

Anyway, I think all this is rather an over-complication of a simple problem of the time being wrong for the only non-root user of the system whose account was created during installation. Perhaps it just doesn’t matter enough to report it as a bug.

Ubuntu is different. By default it does not use root but uses sudo to raise the user to root status. sudo works differently on openSUSE. Though you can still use it it has different default settings and you enter the root password not a user’s. Though a user’s password and roots can be the same. Root can be considered to be the administrator.

On Ubinto root user is still called root. What Ubuntu does by default is blocking direct login as root and forcing you to use su or sudo when you need to obtain superuser privileges.

When you think that “system administrator” is the same as “admin user”, you will have a lot of surprises when using computers where even “A” is different from “a”.rotfl!