Installation ati 64 bit driver failed - checksum incorrect

when adding the www2.ati.com/suse/11.2 repo to yast and installing the fglrxg01 I get this errormessage:

Fehler: INVALID:Paket ati-fglrxG01-kmp-desktop-8.593_2.6.31.5_0.1-21.1 wurde anscheinend während des Transfers beschädigt. Wollen Sie es erneut abrufen?

(…checksum incorrect)

Suse asks me to install it anyway but then decides to not let me install it, only leaves skip, cancel and retry…

when doing skip, suse also managed to fcuk up Grub and removes all the entries for suse…

Installing the driver doing like ATI Proprietary Driver Install Guide | openSuSE 11.2 vanilla - openSUSE Forums

fails miserably too.

the free radeon driver on my FirePro V7750 on the Dell 6400 still has artefact all over screen, I hardly can type.

Good boy, this linux installing is still quite frustrating…

Any good advice on the problems, or should I try Linux maybe in a year again?

It doesn’t give such a warning without good reason. Just retry the download.
If it should still fail, your internet connection is probably iffy. Disconnect from the internet, wait a short while, connect again and then try it again.

Sorry I did not mention, that I already checked and doublechecked the internet-connection (cable and wireless, also connected directly to the router in my company). I can install from every other repository (Suse, packman…) too, but i’m not able to download and install without checksum error the 64bit driver from www2.ati.com/suse/11.2… I assume that the repo from ati is out of synch with yast?!

I have the same problem …and only with the ati drivers (i have installed all the updates and multimedia …and a couple more) and never had that problem with anything else.
I was going to post as well …but since you did already i’ll just add my voice here.

Following the guide here
ATI drivers - openSUSE

I managed to install them (with sources,and downloading the drivers from their site).

Had a bit of troubles at first because the screen was not of the correct size and had to re-initialize the xorg.conf in safe mode (was bigger than my screen so a lot of the desktop was outside of it)and then resize it from the control panel.
But now is all well :slight_smile:

Hi,

The 32 bit ati driver (x11-video-fglrxG02-8.681-28.1.i586.rpm) fails its checksum too. I’ve downloaded it using two different networks/ISPs and PCs, so I’m sure it is the file at fault. Is there a way to notify the ATI driver developers?

Richard

I’m not sure whether these packages are from ati.
the package-provider (Anbieter) is “obs://build.suse.de/home:sndirsch:drivers”
maybe someone can use this to notify the package-provider

Hi,
The 64 bit ati driver (ati-fglrxG02-kmp-default with version 8.681_2.6.27.39_0.2-26.1) fails its checksum too on my OpenSuse 11.1 system. :frowning:
I run the update through the official ATI repository…

Fabrice

Another unhappy bunny - I know it worked a few days ago - but reinstalled to repartition, but now ATI repository broke :frowning:

Despite of trying to find a solution for the checksum failure of the ATI repo, I tried to make it manually with the driver and it succeeded :stuck_out_tongue:

Here is what I have done yesterday:

Uninstall the current drivers installed from repository:
rpm -e ati-fglrxG02-kmp-default-8.661_2.6.27.37_0.1-21.2.x86_64 x11-video-fglrxG02-8.681-28.1.x86_64

Download the current drivers (version 10.1) from ATI web site: ati-driver-installer-10-1-x86.x86_64.run

Generate the rpm for my system, openSuse 11.1 64 bits:
sh ./ati-driver-installer-10-1-x86.x86_64.run --buildpkg SuSE/SUSE111-AMD64

Install the new rpm:
rpm -Uhv fglrx64_7_4_0_SUSE111-8.69-1.x86_64.rpm

Run the configuration of SAX:
sax2 -r -m 0=fglrx

Restart the whole system and pray

Of course, for all theses commands, I was logged as root into the runlevel 3.

I’ve done this and now my mouse pointer’s gone awol :frowning:

I just had the same thing happen. I noticed that when I went to install the RPM, it gave the error:

package kernel-source needs to be instlaled by YaST2 first

This was odd, because I knew that it was installed. However, it turns out that when I ran that zypper command, it installed from the OSS repo, not the update repo, so my computer had the kernel 2.6.31.12-0.1.1 but source 2.6.31.5.0.1.1, so it wouldn’t compile.

To fix this, I loaded the software manager (it’s tricky with no pointer but stuff will still highlight where the pointer should be, and you can use the “tab” key to switch fields) then did an update to the latest version of kernel-source from the update repo (it took a few minutes cause there was around 200MB to download.

After doing that, I could go back to the command line and issue the command

sudo rpm -Uvh --replacepkgs fglrx_some_numbers_and_stuff.rpm

After a reboot, now I have smooth graphics, dual-displays, and emerald theme manager despite my dual 1680x1050 displays (in the previous versions this wasn’t possible.)

So in other words, I’m super stoked!! rotfl!

Hmm - could have been that I guess. Anyway, reinstalled this morning. ATI repository still shot, so downloaded and reinstalled the driver, having ensured that the kernel headers etc matched the running kernel. Had to run sax -r -m 0=flgrx (aticonfig --initial resulted in black screen) but I have the ATI driver installed and running again with compiz etc. Hope someone fixes the repo before too many people hit this

Thanks for all help offered
Paul

Hmm, that’s really weird, I didn’t have to mess with my xorg.conf after getting it installed. I don’t know if it makes a difference or not, but my 11.2 install was a repo upgrade from 11.1, so I’d already configured it prior to the upgrade though; not sure if yours was a clean install or an upgrade.

I wonder if maybe the config was missing like the

    InputDevice    "Mouse[1]" "CorePointer"
    InputDevice    "Mouse[3]" "SendCoreEvents"

and

Section “InputDevice”
Identifier “Mouse[1]”
Driver “synaptics”
Option “Buttons” “5”
Option “Device” “/dev/input/mice”
Option “Emulate3Buttons” “on”
Option “HorizScrollDelta” “0”
Option “InputFashion” “Mouse”
Option “Name” “Synaptics;Touchpad”
Option “Protocol” “explorerps/2”
Option “SHMConfig” “on”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

Section “InputDevice”
Identifier “Mouse[3]”
Driver “mouse”
Option “Buttons” “5”
Option “Device” “/dev/input/mice”
Option “EmulateWheel” “on”
Option “EmulateWheelButton” “2”
Option “InputFashion” “Mouse”
Option “Name” “IBM;TPPS/2 TrackPoint”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

parts of the config then? Either way, glad it’s working for you! :slight_smile:

I too am experiencing the checksum issue. First let me state that I have just enough knowledge to be dangerous. That out of the way I am running Open SuSE 11.2 on an HP dv7 with an ATI Radeon M4650.

When I follow fmarchon23’s instructions I receive a build failed error and cannot proceed to the rpm step. Where do I find an error report or log to find out why the build fails?

A follow up to my previous post. I continued to research the issue and found the following link:

ATI Proprietary Driver Install Guide | openSuSE 11.2 vanilla - openSUSE Forums

It appears that the same issue is addressed here as well. Is this any different than the discussion here?

Same issue here with checksum. Also a build error with the driver downloaded directly from ATI, it won’t generate an RPM, though have not tried the one just released, as I can’t download it yet due to bandwidth limitations. Specific error from log “Package build failed! [Error] Generate Package - error generating package : SuSE/SUSE112-AMD64”. And I think I have all the dev files installed. I have a couple older drivers from the last couple months, same thing. Fresh install DVD 64bit, fresh /home, all updates prior to attempt. I’ve installed the driver manually on a few other distros on this same hardware (sidux, Kubuntu, for example), never had quite this problem before, might try a direct install I guess. First attempt at Opensuse sinc 06, and that one had the repository issue/wouldn’t install anything. Might stick with Mandriva, happy with that, though I like aspects of this better, besides the problems…

Ok, did a reinstall, did not update, and got the driver installed manually. RPM generation and everything worked. Guess I’ll update later. 3d, all KDE effects are working, cube, transparency, very smooth.

Another “problem” though, Dell Studio 1555, I have the temperature monitor plasmoid up (KDE 4), and two sensors are about 10 degrees C warmer than on any other distro (69 and 68 now), on idle. My laptop cooling fan is on higher than idle. Usually this is the behavior when running the open source drivers, when I install the proprietary ones, the temp goes down. Suspending compositing does not help. When I reboot into Mandriva, or …7…, the fan slows down to near silent, and temp reflects 10 lower. Guess I’ll have to check into this, or forget it. Opensuse is not liking me well I guess. Using last month’s driver, not the one released a couple days ago.

If I wanted to install the driver manually I could use Debian, Gentoo or build my own distro. Yast should work to install the proprietary driver; this checksum error has been occurring for some time. Does anybody give a rat’s behind about this? This needs to be addressed.

I’ve been using Linux for 10 years, but this is my first taste of openSUSE or its predecessors. I’ve used Red Hat, Fedora, Debian and am fed up after 3.5 years with Ubuntu. So I try openSUSE only to find issues that I’ve not had to deal with for a couple of years on Ubuntu.

This is disgraceful that the driver and the catalyst control center in the repository fails checksum. It seems nobody with the proper security credentials is doing a thing to fix it.

This is leaving a really bad taste in my mouth. I may have to go rant about this on linsux.org.>:)

Ignore this…I’m apparently not thinking properly today