Installation 13.1 parallel zu Win XP nicht erfolgreich - "Failed to access msr (msr 300)"

OK, danke.
Also es wird der “r128” Treiber benutzt (was ja eigtl der richtige Treiber für diese Karte ist).
Fehler seh ich da keinen, aber scheinbar friert er kurz nach Aktivierung der EXA Grafikbeschleuningung ein.

Außerdem hab ich grade bei mir festgestellt, dass der Failsafe-Modus bei einer frischen 13.1 Installation (zumindest wenn von LiveCD installiert) gar nicht funktioniert! Die Datei /etc/X11/xorg.conf.install fehlt nämlich.
Deswegen hat das wahrscheinlich nichts gebracht.

Editier bitte mal die Datei /etc/X11/xorg.conf.d/50-device.conf (z.B. mit “nano /etc/X11/xorg.conf.d/50-device.conf”) und füge folgendes am Ende ein:

Section "Device"
  Identifier "Default Device"
  Driver "fbdev"
EndSection


Dann sollte der “fbdev” Treiber anstelle des “r128” Treibers verwendet werden, der dann hoffentlich ein Bild anzeigt (wenn auch vielleicht nur in einer niedrigen Auflösung, aber das könnten wir dann ja noch ändern)
Bringt das was?

PS: Die Sache mit dem nicht-funktionierenden Failsafe-Modus ist einen Bugreport wert, denke ich. Das werd aber ich machen, nachdem ich nochmal eine Installation probiert habe.

Kenne mich mit Konsolenbefehlen nicht so gut aus. Kann diese log-Datei vielleicht auch auf eine Windows-Partition verschieben und dann hochladen, wenn mir jemand den Weg erklärt.
Oder vielleicht mit yast nach einem Grafikkartentreiber für ATI Rage Fury Pro/Xpert 2000 Pro suchen (Wie?) …

Ja, würde gehen, ist aber nicht mehr notwendig.
Das Video ist deutlich genug, danke für die Mühe… :wink:

Oder vielleicht mit yast nach einem Grafikkartentreiber für ATI Rage Fury Pro/Xpert 2000 Pro suchen (Wie?) …

Den Treiber hast du installiert, und es gibt keinen anderen.

Wird da nicht bei 03.062 versucht der fglrx zu laden?

Hm?
Der ist ja nicht installiert. Sh. Meldungen

(WW) Warning, couldn't open module fglrx
...
(EE) Failed to load module "fglrx" (module does not exist, 0)

Das System verwendet den r128 Treiber.

Von “rpm -qi xf86-video-r128”:

r128 is an Xorg driver for ATI Rage 128 video cards.

Und der Failsafe-Modus geht ja auch nicht, das haben wir ja schon probiert.

Ja, wird versucht.
Bei ATI Karten wird eben von Xorg versucht folgende Treiber (in dieser Reihenfolge) zu laden:
fglrx, ati, modesetting, fbdev, vesa.

Aber das Laden von fglrx schlägt fehl, weil er eben nicht installiert ist, sh. mein voriger Post.
“ati” lädt dann den korrekten “r128” Treiber für diese Karte, für neuere würde er den “radeon” Treiber laden.

Dann sollte der “fbdev” Treiber anstelle des “r128” Treibers verwendet werden, der dann hoffentlich ein Bild anzeigt (wenn auch vielleicht nur in einer niedrigen Auflösung, aber das könnten wir dann ja noch ändern)
Bringt das was?

Nein. Siehe
https://www.dropbox.com/s/l26xizvrxem3aq7/VID_20140405_150944.mp4

War das ein normaler Boot, nicht “Failsafe”?
Was hast du denn da beim 2. Mal eingegeben? “init 5;”?
“init 5” wäre richtig.

Probier’s mal mit “startx”, geht das?

Ansonsten bitte nochmal das /var/log/Xorg.0.log.

Und überprüfe bitte, dass du das richtige in /etc/X11/xorg.conf.d/50-device.conf geschrieben hast. Es sollte genau folgendermaßen ausschauen:


Section "Device"
  Identifier "Default Device"
  Driver "fbdev"
EndSection

Du kannst auch mal “vesa” anstelle von “fbdev” probieren. Irgendein Treiber muss ja gehen, wenn die grafische Installation geklappt hat.

thanks :slight_smile:
it works with “fbdev”. i just corrected “End Section” to “EndSection” and it works. “startx” reportet that there was an error in /etc/X11/xorg.conf.d/50-device.conf (i wrote “End Section”.

Kann ich die Grafik noch durch einen besseren Treiber verbessern?

Zuerst mal, freut mich dass jetzt zumindest der Grafikmodus geht! :slight_smile:

Naja, der einzige “bessere” Treiber für deine Grafikkarte ist eben der “r128”, aber der funktioniert ja nicht.
Evtl. könnte man den durch gewisse Optionen zum Laufen bekommen.

Falls du meinst, ob eine höhere Auflösung möglich ist, dann ja.
Die Auflösung für den fbdev Treiber kannst du in YaST->System->Bootloader einstellen. Enfach auf “Bearbeiten” klicken und den gewünschten “VGA-Modus” auswählen (der sollte dann im Grafikmodus übernommen werden, glaube ich).

Bevor wir jetzt aber mit den Treiberoptionen des r128 Treibers herumexperimentieren, würde ich vorschlagen, die Datei /etc/X11/xorg.conf.install anzulegen damit du notfalls den “Failsafe” Modus booten kannst, falls der normale Modus nicht funktioniert.
Sie könnte z.B. folgenden Inhalt haben:


Section "Screen"
 Identifier "fbdev"
 Device "fbdev"
EndSection


Section "Device"
 Identifier "fbdev"
 Driver "fbdev"
EndSection

(normalerweise enthält sie mehr, aber in diesem Fall ist das ausreichend, da wir ja wissen, dass der fbdev Treiber funktioniert)
Hinweis: die Datei kannst du nur als root anlegen/bearbeiten, wenn du also als normaler Benutzer eingeloggt bist, starte den Text-Editor mit sudo bzw. kdesu (unter KDE, welchen Desktop benutzt du eigtl.?)

sudo nano /etc/X11/xorg.conf.install
kdesu kwrite /etc/X11/xorg.conf.install

Wenn du das gemacht hast und ausprobiert hast, dass der “Failsafe” Modus dann auch funktioniert, melde dich und wir können versuchen, den “r128” Treiber zum Laufen zu bekommen…

:wink:
Nutze KDE. Nach Aufruf von

kdesu kwrite /etc/X11/xorg.conf.install

öffnet sich die Datei in “kwrite” mit folgendem Inhalt:

Section "Device"
  Identifier "vboxvideo"
  Driver  "vboxvideo"
EndSection

Section "Screen"
  Identifier "vboxvideo"
  Device "vboxvideo"
EndSection


Section "Device"
  Identifier "vmware"
  Driver  "vmware"
EndSection

Section "Screen"
  Identifier "vmware"
  Device "vmware"
EndSection


Section "Device"
  Identifier "modesetting"
  Driver  "modesetting"
EndSection
Section "Screen"
  Identifier "modesetting"
  Device "modesetting"
EndSection


Section "Device"
  Identifier "fbdev"
  Driver  "fbdev"
EndSection
Section "Screen"
  Identifier "fbdev"
  Device "fbdev"
EndSection


Section "Device"
  Identifier "vesa"
  Driver  "vesa"
EndSection

Section "Screen"
  Identifier "vesa"
  Device "vesa"
EndSection


Section "ServerLayout"
  Identifier "Layout"
  Screen  "vboxvideo"
  Screen  "vmware"
  Screen  "modesetting"
  Screen  "fbdev"
  Screen  "vesa"
EndSection

Ist die Datei bereits genügend konfiguriert?

Ja, das ist die Standarddatei. Entweder fehlt die Datei dann nur bei Installation von der LiveCD, oder ich habe sie versehentlich irgendwann seit November auf diesem Rechner gelöscht…:expressionless:

Jedenfalls hat der “Failsafe” Modus ja nicht funktioniert, richtig?
Also probier vielleicht trotzdem mal alles außer fbdev rauszunehmen (vesa kann auch drinbleiben), sodass das übrigbleibt:


Section "Device"
  Identifier "fbdev"
  Driver  "fbdev"
EndSection
Section "Screen"
  Identifier "fbdev"
  Device "fbdev"
EndSection


Section "Device"
  Identifier "vesa"
  Driver  "vesa"
EndSection

Section "Screen"
  Identifier "vesa"
  Device "vesa"
EndSection


Section "ServerLayout"
  Identifier "Layout"
  Screen  "fbdev"
  Screen  "vesa"
EndSection

Wie gesagt, Sinn der Sache ist es, den “Failsafe” Modus zum Laufen zu bekommen, damit du im Notfall nicht wieder im Textmodus herumhantieren musst. :wink:

Jedenfalls hat der “Failsafe” Modus ja nicht funktioniert, richtig?

Richtig, konnte damit keine grafische Oberfläche starten.

OK, habe die Datei soweit vorbereitet. Die “überflüssigen” Einträge habe ich mit"'#" in Kommentare verwandelt.

… und ausprobiert. Kann mich mit “Failsafe” im Grafikmodus anmelden.:slight_smile:

Gut, dann kannst du Änderungen im Grafikmodus zurücknehmen, falls der normale Boot nicht klappt. :wink:

OK. Dann schauen wir mal, ob wir den “r128” Treiber zum Laufen bekommen.
Öffne die Datei /etc/X11/xorg.conf.d/50-device.conf im Texteditor (“kdesu kwrite” z.B., du kannst entweder den Dateinamen wie vorher auf der Kommandezeile angeben oder auch einfach auf “Datei öffnen” klicken).
Ändere dann das “fbdev” in “r128”.

Damit alleine wirds wohl nicht gehen, aber probiere trotzdem mal zu booten.

Wenns nicht geht, füge noch eine Zeile hinzu, sodass es so aussieht:

Section "Device"
  Identifier "Default Device"
  Driver "r128"
  Option "NoAccel" "true"
EndSection

Ach ja, und du kannst jetzt natürlich DISPLAYMANAGER in /etc/sysconfig/displaymanager wieder auf “kdm” zurückstellen, falls du das noch nicht getan hast… :wink:

Ändere dann das “fbdev” in “r128”.

Damit alleine wirds wohl nicht gehen, aber probiere trotzdem mal zu booten.

Funktioniert nicht.

Wenns nicht geht, füge noch eine Zeile hinzu, sodass es so aussieht:
Code:
Section “Device”
Identifier “Default Device”
Driver “r128”
Option “NoAccel” “true”
EndSection

Geht dann auch nicht. Ich kann dann nur den Konsolenmodus starten und auch “startx” führt mich nicht zum grafischen System, sondern zeigt Textmeldungen wie

Segmentation fault at address 0xc
server error
unable to connect to X server: connection refused

Ach ja, und du kannst jetzt natürlich DISPLAYMANAGER in /etc/sysconfig/displaymanager wieder auf “kdm” zurückstellen, falls du das noch nicht getan hast… :wink:

Ist getan :wink:

Tja, die Segmentation fault selber sagt leider auch nicht viel aus. Es wäre evtl. der Backtrace interessant der dazu führte.

Kannst du das bitte nochmal provozieren, dann Neustart in den “Failsafe” Modus und dann die Datei /var/log/Xorg.0.log.old posten? (die enthält das Log vom vorherigen Start)
Du lädtst sie aber besser auf http://susepaste.org hoch und postest einen Link.

Wenn der r128 Treiber allerdings nicht mal mit “NoAccel” (also ohne jegliche Hardwarebeschleunigung) funktioniert, sehe ich leider schwarz.
Dann wirst du wahrscheinlich mit fbdev vorlieb nehmen müssen.

Du könntest probieren, auf die neueste Version vom Treiber und Xorg upzudaten. Vielleicht ist der Fehler da behoben.
Aber bevor ich dir erkläre wie das geht, würde ich doch lieber das Log sehen…

PS: Schaut fast wie dieser Bug aus:
https://bugs.freedesktop.org/show_bug.cgi?id=72974

http://susepaste.org/80149866

Das ist tatsächlich exakt der gleiche Absturz wie in dem Bugreport.

Dort wird die Frage gestellt, ob es hilft, das r128 Kernel Modul zu laden bevor man X startet.
Könntest du das vielleicht mal probieren?

D.h. Booten in den Textmodus (Runlevel 3, durch Eintippen von “3” im Bootmenü), dann als root anmelden, und folgendes ausführen:

modprobe r128

Danach Xorg mit “startx” starten.
Geht’s dann, oder fliegst du trotzdem zurück in den Textmodus?