Installation 11.2


I had 11.0 running.
I have upgraded to 11.2.

After the installation, the KDE environment is not boting as the default, but runtime level 5 boot instead.
I have checked my installation and ensured to have KDE4 installed.

Please advise how to have KDE boot.


So is it the graphical login manager that does not appear? What happens if you run “startx” after login?

The GUI log-in did not loaded up.

At the command prompt, after typing: startx, several error messages:

Failed to load /usr/lib/xorg/modules/drivers/
Failed to load module “fglrx” (loader failed, 7)
No driver available
Fatal server error:
No server found

Please consult the X.Org at X.Org Wiki - Home for help


How did you upgrade?
Have you tried failsafe boot.

You should reinstall the ATI driver.
Until then, you can change the Device in /etc/X11/xorg.conf to “vesa” to get X started.

Normal Upgrade …
Failsafe: Froze

Further more about the error from

You get an error message like:

(EE) No devices detected.
Fatal server error:
no screens foundIt is very likely that your xorg.conf file doesn’t contain the correct driver(s) for the chipset(s) in your system or that your chipset isn’t supported by any of the drivers.
You can check for the detected devices in the log file (in most cases /var/log/Xorg.0.log) by looking for lines like:
(–) PCI:*(1:0:0) Neomagic Corporation NM2200 [MagicGraph 256AV] rev 32, Mem @ 0xfd000000/24, 0xfe800000/22, 0xfec00000/20
In this example the active video device (the one with the *) is a Neomagic NM2200 video chip. In order to get this chipset to work you’d have to use the neomagic driver.
If you are using a distribution you should rerun its configuration tool. If there is no such tool, or if it keeps configuring your Xserver wrong you may want to try xorgcfg, the graphical tool shipped with Xorg. You can also let the server generate a config file: as root just run X -configure.
Please note: If you appear to use the correct driver and you still keep getting this message it is very likely that your chipset isn’t supported (yet). In this case you may try the vesa driver or - if this doesn’t work - the vga driver. However both are entirely unaccellerated.

Login to level 3
become su and do

sax2 -r -m 0=vesa


should give you a basic GUI till you get ATI driver installed

On failsafe (desktop) the GUI login loaded but looked horrible.


Now just do your ATI
ATI - openSUSE

hahha …
This is from ATI - openSuse:
At this time, there is no XvMC support for any ATI cards, making them poor choices for HDTV.

However when I ran:
sax2 -r -m 0=ait

the configuration seems OK.
Re-boot into runtime level 5 (default) the screen looks OK.

Looks like Xorg/openSuse might need to re-consider the option not to support ATI cards.

Thanks for the help people.


ATI with 11.2 has been a pain but unless you installed via the ATI repository when a kernel is upgraded you need to reinstall the video. It has always been as such. Now though if you install the driver via repository or one click the driver will reconnect with new kernel. But ATI support could be a lot better.