Install without usb

Hello, is there a way to install OpenSUSE directly from the hard drive?

I found grml-rescue but it seems that it might be only for installing Debian-based distros.
I tried it and grub finds it, but it only leads me to a screen that says “Press any key to continue…” which leads me right back to grub.

unetbootin only offers / as the target drive, and I worry that it would damage my system.

I’m currently on Manjaro, and I have multiple physical disks that I can partition in any way.

I just need a way to install without usb because dd, cat and so on always kills all my flash drives after only a few tries, and my only flash drive is dead because I did that.

Check out this link, I’ve used this method, but using the Arch wiki as my reference. This looks like it’s a straight forward reference for openSUSE. The author has a link to a reference for setting up a btrfs system for Tumbleweed.


Thank you, but unless I am missing something this does not seem to be what I am looking for…

My problem is that I cannot get to the installation at all currently. I need my UEFI to somehow get me there without USB.

I tried to extract the files into a partition, but trying to boot from it leads me to a glitchy command prompt where I cannot write anything.
Using cat file.iso > /dev/nvme0n1p1 seemed to do the same thing.

Is this what you’re after?

I’m not sure if it would have helped, but I was able to solve the problem, thank you.

In my UEFI, I have a disk BBS preference setting, which is similar to boot priority but separate. I needed to set it to the disk I copied the installer on, because setting boot priority alone was not enough to boot into it properly.

Once booted, can you show the output of the following (as root user);

efibootmgr -v

Hello, it says : EFI variables are not supported on this system.

I wonder why you are asking? Though I was surprised to see that.

I’m not sure whether you will find this helpful:

This was for installing 32-bit Tumbleweed, but the same method works with Leap.

In this case, I used a USB flash drive. But a partition on the hard drive should work just as well. I unpacked the DVD iso to the partition. Direct copying of the iso won’t work here, you need the files. After that, I setup grub2 for booting via UEFI. I installed grub2 in the EFI partition.

Try /dev/nvme0n1 instead. See also

Thank you, I did that yesterday and it worked but I was not certain if this had made any difference. :slight_smile: So I didn’t speak about it. Doing that and changing the BSS priority along with boot priority worked for me yesterday. I wrote that I had been able to install it, but I don’t see a way to edit my first post or the title.

But basically, I was able to install openSUSE successfully. Thank you everyone.

Because of your UEFI reference, so your booting in Legacy mode, not UEFI?

For posterity (and searching the archives):

menuentry "Install openSUSE 15.3 via HTTP" {
	search --no-floppy --label --set=root *filesystemlabel*
	linuxefi /s153/linux showopts install= hostname=*myhost* ifcfg=*="192.168.nnn.nnn/24,,,**" XVideo=1440x900 
	initrdefi /s153/initrd

Add the above, adjusted as appropriate to your own needs according to linuxrc, to /boot/grub[2]*/custom.cfg* on your Manjaro installation. Fetch linux]( and initrd]( from mirrors and put them where Grub can find them. Boot Manjaro’s Grub, select Install openSUSE 15.3 via HTTP. Pretty simple really, much easier than locating a reliable USB stick to burn to. It’s how I install the vast majority of the time. The networking entries are optional. My own, similar to above, result in static IP configuration ready to go when installation is complete. XVidieo=1440x900 makes text and icons in the GUI installer easier on my eyes.