Install without burning: can grub launch *.iso?

Hello !
I run a mandriva 2008 spring distro, and I’d like to give opensuse a try.

here are some facts:
-I’ve downloaded the dvd *.iso.
-My hard drive is partitionned into 3 partitions: 1 for Mandriva (/dev/hda1), 1 for the /home in mandriva (/dev/hda6), and one for Opensuse (/dev/hda7)
-I own a 2GB flash Key

What I want to do:
I’d like to install Opensuse without burning any cd or dvd. The iso is located on the /home partition (/dev/hda6).

I tried with a 9.3 mini-install cd I had, but I don’t know what setting to give to the install.

I’m trying to srtup my grub sothat it could launch the iso.

Here is waht my grub look like:

timeout 3
color black/cyan yellow/cyan
gfxmenu (hd0,0)/boot/gfxmenu
default 3

title linux
kernel (hd0,0)/boot/vmlinuz BOOT_IMAGE=linux root=UUID=481d191d-195c-4ff9-9199-1f226bfb5b49 splash=silent vga=788
initrd (hd0,0)/boot/initrd.img

title Installation Suse v11
  root (hd0,5)
  kernel /home/splitsch/Bureau/opensuse/boot/i386/loader/linux splash=silent showopts
  initrd /home/splitsch/Bureau/opensuse/boot/i386/loader/initrd  

When I boot on “Installation Suse 11”, it says “error 15- no kernel found on /home/splitsch/Bureau/opensuse/boot/i386/loader/linux”

Can anyone help me with this ?

Thanks :slight_smile:


Ok, I fixed it :slight_smile:

I had to mention, in grub, this line
/splitsch/Bureau/opensuse/boot/i386/loader/ et not this one:
/home/splitsch/Bureau/opensuse/boot/i386/loader/ , since /home/ is the way mandriva mount this disk, not grub nor the bios or anything.

It works :slight_smile:


thanks for updating us with your solution!

No problem.

Here is a complete tutorial in French.

Installer opensuse 11 sans gravure, en passant par Grub

Ce tutorial permet d’installer opensuse en bottant sur le média d’installation directement depuis grub.
==>grub boot sur l’iso (ou presque)

= I put this explanation in french, in case some french dude do some searches in french in those forum.

Bye !