Install VirtualBox

Hi All,

Trying to setup Virtualbox on OpenSUSE 12.1 amd64 Acer Aspire 5100 notebook, and keep getting these errors:

run /etc/init.d/vboxdrv setup

Install DKMS package ???

any suggestions?


Welcome to the forums; however there is a virtualisation forum for such queries. Perhaps a moderator will move this post for you.

This thread will be closed for 10 minutes at which time I will move it to the Virtulization forum. Please wait…

This thread has now been moved, you may begin your posting.

Thank You,

Just open up YaST / Software / Software Management, search dkms (using lower case) and place a check by the package and allow it to be installed. I have found that VirtualBox will still install without DKMS, but it always throws an error message before it does if you have not installed this package and update your kernel. I did a search on openSUSE 11.4 and 12.1 and it is there in both openSUSE versions. You can run the terminal command: **sudo /etc/init.d/vboxdrv setup, **to reinstall the VirtualBox kernel modules after any kernel update.

Thank You,

You’ll need to enable the packman repo to install DKMS. Open Yast/Software repositoris/ click add button select Community repos and then select the packman repo.

Or you can just download it from the link it installs all whatsoever is required

and download the extension pack if you want usb 2.0 support

as it is the latest it includes the bug fixes as the earlier versions have certain bugs
Given in the package of 11.4 and 12.1 the virtualbox is having certain bugs as i have my personal experience.

and moreover these are the .rpm packages easy to install :wink:

Hi everybody.
My problem is like that. I am useing suse 12.1 and I installed on system virtualbox 4.1.8 . I open the program
So far there is no problem but when I run the virtual system on the virtualbox not open and say to me ;

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. 
Please reinstall the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. If it is available in your distribution, you should install the DKMS package first. 
This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

and I run this comand " /etc/init.d/vboxdrv setup " after say to me

baba@linux-pe7j:~> sudo /etc/init.d/vboxdrv setup
root's password:
Stopping VirtualBox kernel modules                                                             done
Uninstalling old VirtualBox DKMS kernel modules                                                done
Trying to register the VirtualBox kernel modules using DKMSError! echo
Your kernel headers for kernel 3.1.6-2-default cannot be found at
/lib/modules/3.1.6-2-default/build or /lib/modules/3.1.6-2-default/source.
  (Failed, trying without DKMS)
Recompiling VirtualBox kernel modules                                                          failed
  (Look at /var/log/vbox-install.log to find out what went wrong)

I’m trying this command with DKMS and without DKMS but result is always the same.
I install virtualbox form open suse repositories the result is same and I install from does not change the result in the same.
I was able to use this app. a few weeks ago. when I upgrade my system then virtualbox does not work any more.
What can I do? Help me please.

No. You should install the Oracle repo and install VirtualBox with zypper. But you should install the kernel sources and compiler first!

Or install vmscripts and run VBoxExtensionPack … and basically, to install Oracle VirtualBox, including everything needed to compile the kernel module, and the ExtensionPack for the latest version, install vmscipts and run:

vboxlive --install

I guess it’s the easiest and fastest way. DKMS is another story. This version doesn’t use DKMS at all. You can safely ignore the error message while installing/deinstalling and updating the kernel module.

Installing the rpm is easy, but it will bring you nowhere if you don’t have the sources to compile the module (speaking about the Oracle version) … and of course, the kernel sources you install must match the version of the running kernel - a common mistake that can be avoided with vboxlive.

And don’t forget to search for DKMS in YaST / Software / Software Management and when found install it to eliminate yet another error you see when compiling the VirtualBox drivers.

Thank You,

I have done every thing suggested on this post and still VirtualBox is not working. Any more suggestions? I will appreciate it.

You can open up a terminal session and run this command and post the results:

rpm --query --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} -> %{VENDOR}
' VirtualBox-4.1 VirtualBox-4.0 dkms virtualbox

On my PC I get the following responce:

VirtualBox-4.1-4.1.8_75467_openSUSE114-1-x86_64 -> Oracle Corporation
package VirtualBox-4.0 is not installed
dkms- ->
package virtualbox is not installed

Two are there and two are not, but the two that are are the ones I am using. Also, in all of this stuff, its not clear if you installed the kernel source files. I normally suggest you do the following:

Open YaST / Software / Software Management - Select the View Button on the top left and pick Patterns. Now, you will see several Patterns listed and you want to select:


[X] Base Development
[X] Linux Kernel Development
[X] C/C++ Development

Then Press the Accept button on the bottom right and allow these applications to install. You can tell me if you have done this or not.

Thank You,

On 02/02/2012 11:36 PM, jdmcdaniel3 wrote:
>> I have done every thing suggested on this post and still VirtualBox is
>> not working. Any more suggestions? I will appreciate it.

what a mess…as far as i can tell there are three different users
with some kind of install VM trouble–each of those have posted exactly
once (there are NO answers being given to any of the helper questions)…

and, there are answers and advice from five helpers (giving sometimes
conflicting advice)…

three needing and five giving in only 12 post!

this thread is a perfect example where the two thread hijackers should
have been told to begin their own thread to describe their situation
and ask their question…

Read what Distro Watch writes:

Thank you for replaying. Here is the result of running that command you suggested

rpm --query --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} → %{VENDOR}
’ VirtualBox-4.1 VirtualBox-4.0 dkms virtualbox
VirtualBox-4.1-4.1.8_75467_openSUSE114-1-x86_64 → Oracle Corporation
VirtualBox-4.0-4.0.10_72479_openSUSE114-1-x86_64 → Oracle Corporation
dkms- → PackMan :: Startseite
virtualbox-4.1.4-3.2.3-x86_64 → openSUSE

I also tried YaST / Software / Software Management but I didnt see a View Botton on the top left to pick Patterns
I appreciate all advices Thank you

  1. So, if you are using GNOME, YaST does not work exactly the same way and you need to serach on patterns, and check the three patterns that I mentioned in the first message list shown.

Base Development, Linux Kernel Development, C/C++ Development

  1. Now as for the packages you have installed, you have installed everything, even though you only need two as I showed in my list. You ONLY need these two and should uninstall the other two:

Keep These installed (ONLY).

VirtualBox-4.1-4.1.8_75467_openSUSE114-1-x86_64 -> Oracle Corporation
dkms- ->

Thank You,

Hi James,

It looks like modautocompile is obsolete now. You shouldn’t need it anymore if you’re using dkms with the Oracle version. It was not available at the time as I wrote this script. Notice that it is in packman. AFAIK SuSE customers (german banks) didn’t want it. I read that in the forum (don’t know if it is true).

So, can you tell us how dkms works and with what, besides VirtualBox, does it work with? I can say that until recently, I had not noticed the error message from the VirtualBox startup script saying dkms was missing. Anything more you can add would be of great help.

Thank You,

Well, I never installed it on openSUSE. I still don’t have it. It is certainly not required for VirtualBox. I can not tell you more than the dkms man page. Is is used by default on other distros, such as Fedora, and I never had to recompile the VirtualBox kernel module manually (or use modautocompile) there. Here’s the output of dkms status under Fedora (15) with 2 kernel installed:

# dkms status
vboxhost, 4.1.8,, x86_64: installed
vboxhost, 4.1.8,, x86_64: installed

I don’t know if VirtualBox gets added automatically under openSUSE.