Install Virtualbox using latest stable kernel

I have been using the latest stable linux kernel on OpenSUSE 13.2 from the repository
http://download.opensuse.org/repositories/Kernel:/stable/standard/

This requires me to get Virtualbox compiled against this kernel from the repository
http://download.opensuse.org/repositories/Virtualization/Kernel_stable_standard/

However this repository for Virtualbox is built against OpenSUSE Tumbleweed (I think it was, or Factory). To get around this is have installed only the virtualbox kernel modules from this repository while getting the virtualbox application from the 13.2 repository
http://download.opensuse.org/repositories/Virtualization/openSUSE_13.2/

This is no longer viable. Up until now these two repositories have had the same version of Virtualbox, but no longer. The kernel stable virtualbox repository is stuck with 5.0.18, while the other virtualbox repository now has 5.1.4.

I haven’t updated Virtualbox to 5.1.4, but am no longer able to start the VM.


Kernel driver not installed (rc=-1908)


The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing


'/sbin/rcvboxdrv setup'


as root. If it is available in your distribution, you should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.


where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT. 

Packages installed, including the kernel modules for the latest stable kernel:
virtualbox
virtualbox-qt
virtualbox-guest-kmp-default
virtualbox-host-kmp-default

Oracle Virtualbox have their own OpenSUSE repository, so perhaps I should use that one instead? However if I use their Virtualbox repository for OpenSUSE 13.2, is it precompiled for the standard kernel or can I use it with the latest stable kernel?
http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2/
It is only one package for Virtualbox: VirtualBox-5.1-5.1.2_108956_openSUSE132-1.x86_64.rpm

Oracle Virtualbox has NO PRE-built kernel modules: it just asks the system to build modules for the running kernel (whatever version you might be running).
To do that you need a build environment installed, namely kernel-devel, kernel-default-devel with version matching your running kernel, plus gcc, make and maybe other stuff (make sure to have “install recommended packages” set in Yast-software before installing).

Thanx. I will give that a go. I would probably be required to rebuild virtualbox everytime I update my kernel, but at least I would keep Virtualbox stable and working.

If you install the dkms package the system will take care of the updates, just a longer boot delay after a kernel update…

This thread belongs in the Virtualization sub-forum – one of the admins may well move it.

If you look there you will find that this has been a regular question for many years and answered at length many times.

In short if you want to use a newer kernel either:
get the kernel-default and virtualbox-host-kmp-default packages from Tumbleweed
or:
use the kernel-default and kernek-default-devel from Kernel:/stable/standard
and VirtualBox – the openSUSE-13.2 version from *download.virtualbox.org/virtualbox *
e.g. http://download.virtualbox.org/virtualbox/5.0.26/VirtualBox-5.0-5.0.26_108824_openSUSE132-1.x86_64.rpm

You probably want the Extension Pack, Guest Additions and User Manual from the same place. As root use “rpm -Uvh VirtualBox*rpm” to install and build the kernel module.

I personally find dkms a waste of time with this.

Here is kernel:stable running and Virtualbox from the Oracle-Repo:

zypper se -si virtualbox
Daten des Repositories laden ...
Installierte Pakete lesen ...

S | Name           | Typ   | Version                    | Arch   | Repository                              
--+----------------+-------+----------------------------+--------+-----------------------------------------
i | VirtualBox-5.1 | Paket | 5.1.2_108956_openSUSE132-1 | x86_64 | VirtualBox for openSUSE 13.2 / Leap 42.1
uname -a
Linux linux64 4.7.0-5.g31abf6f-default #1 SMP PREEMPT Mon Aug 1 07:57:32 UTC 2016 (31abf6f) x86_64 x86_64 x86_64 GNU/Linux
lsb-release -idr
Distributor ID: openSUSE project
Description:    openSUSE 13.2 (Harlequin) (x86_64)
Release:        13.2

Tried to install Virtualbox 5.1 from Oracle Virtualbox 13.2 repository
http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2/

Retrieving repository ‘Virtualbox’ metadata ----------------------------------------------------------------------------------------]
File ‘repomd.xml’ from repository ‘Virtualbox’ is signed with an unknown key ‘54422A4B98AB5139’. Continue? [yes/no] (no): yes

Package Virtualbox-5.1 is broken. Integrity check has failed.

Error: INVALID:VirtualBox-5.1-5.1.2_108956_openSUSE132-1.x86_64 (Virtualbox): Signature verification failed [4-Signatures public key is not available]Header V4 DSA/SHA1 Signature, key ID 98ab5139: NOKEY
Header SHA1 digest: OK (9d5b986766421c105f6e684dc94db486a7801a7c)
MD5 digest: OK (a011f13ac41a7519fe73657474d23044)
V4 DSA/SHA1 Signature, key ID 98ab5139: NOKEY

I am getting the same problem trying to install the RPM manually, downloaded from http://download.virtualbox.org/virtualbox/5.1.2/


user@mintaka:~/Downloads> sudo zypper install VirtualBox-5.1-5.1.2_108956_openSUSE132-1.x86_64.rpm 
Loading repository data...
Reading installed packages...
Resolving package dependencies...


The following 3 NEW packages are going to be installed:
  libQt5OpenGL5 libQt5PrintSupport5 VirtualBox-5.1


3 new packages to install.
Overall download size: 61.7 MiB. Already cached: 379.7 KiB  After the operation, additional 142.6 MiB will be used.
Continue? [y/n/? shows all options] (y): y
In cache libQt5OpenGL5-5.4.2-22.3.x86_64.rpm                                                      (1/3), 167.2 KiB (445.8 KiB unpacked)
In cache libQt5PrintSupport5-5.4.2-22.3.x86_64.rpm                                                (2/3), 212.5 KiB (614.2 KiB unpacked)
Retrieving package VirtualBox-5.1-5.1.2_108956_openSUSE132-1.x86_64                               (3/3),  61.7 MiB (141.6 MiB unpacked)
VirtualBox-5.1-5.1.2_108956_openSUSE132-1.x86_64.rpm:
    Header V4 DSA/SHA1 Signature, key ID 98ab5139: NOKEY
    V4 DSA/SHA1 Signature, key ID 98ab5139: NOKEY


VirtualBox-5.1-5.1.2_108956_openSUSE132-1.x86_64 (Plain RPM files cache): Signature verification failed [4-Signatures public key is not available]
Abort, retry, ignore? [a/r/i] (a): a

Ignore it by typing i.

Well, when a Wise Penguin says so. Though it feels a bit suspect when you get such messages during install.

That was a WisePenguin short answer. The long answer is: “The VBox package is signed, but the Oracle repo isn’t”.
So, if you really don’t want to see those warnings, you should do something similar to what is described here thanks to nrickert:
https://nwrickert2.wordpress.com/2016/06/05/using-flash-from-adobe-repo/#more-1393

That does not work in this case.

The repository is broken. It lists, but does not contain the 5.1.2 rpm. Even if another version is chosen (easier when using YaST) the integrity check fails despite several download attempts.

If the VirtualBox rpm is downloaded from the version directory – e.g. http://download.virtualbox.org/virtualbox/5.1.2/VirtualBox-5.1-5.1.2_108956_openSUSE132-1.x86_64.rpm the downloaded file(s) can be checked against http://download.virtualbox.org/virtualbox/5.1.2/MD5SUMS or http://download.virtualbox.org/virtualbox/5.1.2/SHA256SUMS. When the downloaded rpm is installed (via zypper or rpm) it is necessary to ignore the lack of a signature (–no-gpg-checks or –nosignature respectively).

The repository is broken. It lists, but does not contain the 5.1.2 rpm.

Does work here:

zypper in -f VirtualBox-5.1-5.1.2_108956_openSUSE132-1
Daten des Repositories laden ...
Installierte Pakete lesen ...
Installation von 'VirtualBox-5.1-5.1.2_108956_openSUSE132-1.x86_64' aus Repository 'VirtualBox for openSUSE 13.2 / Leap 42.1' wird erzwungen.
Paketabhängigkeiten auflösen ...

Das folgende Paket wird erneut installiert:
  VirtualBox-5.1

1 zu installierendes Paket.
Gesamtgröße des Downloads: 61,7 MiB. Bereits zwischengespeichert: 0 B  Kein
zusätzlicher Speicherplatz wird nach dieser Operation belegt oder freigegeben.
Fortfahren? [j/n/? zeigt alle Optionen] (j): j
Paket VirtualBox-5.1-5.1.2_108956_openSUSE132-1.x86_64 wird abgerufen
                                            (1/1),  61,7 MiB (141,6 MiB entpackt)
Abruf: VirtualBox-5.1-5.1.2_108956_openSUSE132-1.x86_64.rpm[fertig (672,8 KiB/s)]
Test auf Dateikonflikte: ................................................[fertig]
(1/1) Installation von: VirtualBox-5.1-5.1.2_108956_openSUSE132-1 .......[fertig]
Zusätzliche rpm-Ausgabe:

Creating group 'vboxusers'. VM users must be member of that group!

This is what I see in Index of http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2/x86_64


Index of /virtualbox/rpm/opensuse/13.2/x86_64
      Name                                                                  Last modified      Size
      [Parent Directory](http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2/)
      [VirtualBox-4.3-4.3.28_100309_openSUSE132-1.x86_64.rpm](http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2/x86_64/VirtualBox-4.3-4.3.28_100309_openSUSE132-1.x86_64.rpm)                 18-Jun-2015 14:12  63M
      [VirtualBox-4.3-4.3.30_101610_openSUSE132-1.x86_64.rpm](http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2/x86_64/VirtualBox-4.3-4.3.30_101610_openSUSE132-1.x86_64.rpm)                 10-Jul-2015 15:23  59M
      [VirtualBox-4.3-4.3.32_103443_openSUSE132-1.x86_64.rpm](http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2/x86_64/VirtualBox-4.3-4.3.32_103443_openSUSE132-1.x86_64.rpm)                 15-Oct-2015 16:31  59M
      [VirtualBox-4.3-4.3.34_104062_openSUSE132-1.x86_64.rpm](http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2/x86_64/VirtualBox-4.3-4.3.34_104062_openSUSE132-1.x86_64.rpm)                 11-Nov-2015 10:28  59M
      [VirtualBox-4.3-4.3.36_105129_openSUSE132-1.x86_64.rpm](http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2/x86_64/VirtualBox-4.3-4.3.36_105129_openSUSE132-1.x86_64.rpm)                 20-Jan-2016  9:14  59M
      [VirtualBox-4.3-4.3.38_106717_openSUSE132-1.x86_64.rpm](http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2/x86_64/VirtualBox-4.3-4.3.38_106717_openSUSE132-1.x86_64.rpm)                 20-Apr-2016 11:46  58M
      [VirtualBox-5.0-5.0.10_104061_openSUSE132-1.x86_64.rpm](http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2/x86_64/VirtualBox-5.0-5.0.10_104061_openSUSE132-1.x86_64.rpm)                 10-Nov-2015 20:21  62M
      [VirtualBox-5.0-5.0.12_104815_openSUSE132-1.x86_64.rpm](http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2/x86_64/VirtualBox-5.0-5.0.12_104815_openSUSE132-1.x86_64.rpm)                 18-Dec-2015 20:18  62M
      [VirtualBox-5.0-5.0.14_105127_openSUSE132-1.x86_64.rpm](http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2/x86_64/VirtualBox-5.0-5.0.14_105127_openSUSE132-1.x86_64.rpm)                 19-Jan-2016 20:04  62M
      [VirtualBox-5.0-5.0.16_105871_openSUSE132-1.x86_64.rpm](http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2/x86_64/VirtualBox-5.0-5.0.16_105871_openSUSE132-1.x86_64.rpm)                 04-Mar-2016 19:19  63M
      [VirtualBox-5.0-5.0.18_106667_openSUSE132-1.x86_64.rpm](http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2/x86_64/VirtualBox-5.0-5.0.18_106667_openSUSE132-1.x86_64.rpm)                 18-Apr-2016 19:24  61M
      [VirtualBox-5.0-5.0.20_106931_openSUSE132-1.x86_64.rpm](http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2/x86_64/VirtualBox-5.0-5.0.20_106931_openSUSE132-1.x86_64.rpm)                 28-Apr-2016 19:06  60M
      [VirtualBox-5.0-5.0.22_108108_openSUSE132-1.x86_64.rpm](http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2/x86_64/VirtualBox-5.0-5.0.22_108108_openSUSE132-1.x86_64.rpm)                 16-Jun-2016 17:45  61M
      [VirtualBox-5.0-5.0.24_108355_openSUSE132-1.x86_64.rpm](http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2/x86_64/VirtualBox-5.0-5.0.24_108355_openSUSE132-1.x86_64.rpm)                 28-Jun-2016 20:18  61M
      [VirtualBox-5.0-5.0.26_108824_openSUSE132-1.x86_64.rpm](http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2/x86_64/VirtualBox-5.0-5.0.26_108824_openSUSE132-1.x86_64.rpm)                 18-Jul-2016 17:10  61M
      [VirtualBox-5.0-5.0.4_102546_openSUSE132-1.x86_64.rpm](http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2/x86_64/VirtualBox-5.0-5.0.4_102546_openSUSE132-1.x86_64.rpm)                  08-Sep-2015 11:50  61M
      [VirtualBox-5.0-5.0.6_103037_openSUSE132-1.x86_64.rpm](http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2/x86_64/VirtualBox-5.0-5.0.6_103037_openSUSE132-1.x86_64.rpm)                  02-Oct-2015 16:30  61M
      [VirtualBox-5.0-5.0.8_103449_openSUSE132-1.x86_64.rpm](http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2/x86_64/VirtualBox-5.0-5.0.8_103449_openSUSE132-1.x86_64.rpm)                  15-Oct-2015 20:04  61M
      [VirtualBox-5.1-5.1.0_108711_openSUSE132-1.x86_64.rpm](http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2/x86_64/VirtualBox-5.1-5.1.0_108711_openSUSE132-1.x86_64.rpm)                  12-Jul-2016 19:07  61M
download.virtualbox.org

However:

valeria:~ # zypper lr -d
...
 4 | VirtualBox-13.2           | VirtualBox-13.2                    | Yes     | ( p) Yes  | Yes     |   99     | rpm-md | http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2                                |        
 ...

valeria:/repos/virtualBox/5.1.2 # zypper in -f VirtualBox-5.1
Loading repository data...
Reading installed packages...
Forcing installation of 'VirtualBox-5.1-5.1.2_108956_openSUSE132-1.x86_64' from repository 'VirtualBox-13.2'.
Resolving package dependencies...

The following package is going to be reinstalled:
  VirtualBox-5.1

1 package to reinstall.
Overall download size: 61.7 MiB. Already cached: 0 B  No additional space will be used or
freed after the operation.
Continue? [y/n/? shows all options] (y): 
Retrieving package VirtualBox-5.1-5.1.2_108956_openSUSE132-1.x86_64
                                                        (1/1),  61.7 MiB (141.6 MiB unpacked)
Retrieving: VirtualBox-5.1-5.1.2_108956_openSUSE132-1.x86_64.rpm ........[done (957.7 KiB/s)]
Checking for file conflicts: ..........................................................[done]
(1/1) Installing: VirtualBox-5.1-5.1.2_108956_openSUSE132-1 ...........................[done]
Additional rpm output:

Creating group 'vboxusers'. VM users must be member of that group!


does indeed now install VirtualBox-5.1-5.1.2_108956_openSUSE132-1. I do not know why it did not work before when I tried to install from the repository with curses YaST2. And I do not understand where it is getting the 5.1.2 rpm from.

BTW I added the VBox PGP key with:

rayh@valeria:/repos/virtualBox/5.1.2 > wget -Nc https://www.virtualbox.org/download/oracle_vbox.asc
rayh@valeria:/repos/virtualBox/5.1.2 > sudo rpm --import oracle_vbox.asc