Install stuck at watch icon

I am in the process of installing OpenSuse 11.4 x64 on my HP TX1220 with Nvidia Go graphics. First part went fine, but after first reboot, I get the green splash screen, then black screen with white cursor that turns into a watch icon after a few seconds. I let it sit there for over an hour and nothing else happened. I can move the cursor with my mouse or touchpad, but that is it. I used the same install media (USB drive) to install to my desktop yesterday without a hitch. The only thing I have done different is I do not have a live ethernet connection. I have retried the install twice with the same result. Any ideas?

Switch to another tty via Ctrl + Alt + Fn (not sure which Fn, I suppose F1, try a bit), you should see some messages there (hopefully).

No response, tried CTRL+ALT+F1-F12. No response with CTRL+ALT+DEL or CTRL+ALT+BACKSPACE either, I have to power down manually to reboot at the moment.
It may be stuck on loading X, because my Caps lock or Num lock do not light up when pressed. Tried with USB keyboard also. Keyboard worked during install.

Rebooted and selected fallback kernel, and it is continuing the install, will post back if it finishes successfully. Thanks for the quick response though!

Yes, that worked! Strange, never had to do that before…

Does it now work not booting from failsafe?

Negative, it finished the install on the failsafe kernel, not the regular one, not an ideal situation. I remembered that a few releases back I had to give the boot option acpi=off to even get it to start the install. I tried that and was able to install, but got “no network running” at the network activation part. I continued the install and booted into my new desktop and everything seemed to work, but after about 20 minutes, I lost my network connection and have not been able to bring it back up. Ran out of time so will have to troubleshoot more this afternoon. It is weird because the live DVD works great!?

There is no “live” DVD there are live CD’s with KDE or gnome the desktop.

You using WiFi or a wired connection for the net? If WiFi what chip?

Oops, I was referring to the live Gnome CD, I had just burnt it to a DVD because that is all I had at the moment. I used the x64 install DVD for the install and checked it before I started.

I am using wired connection, but it has the NVIDIA ethernet adapter, and Broadcom 4312 wireless.
I just made a network install CD and will try it when I get home.

Net install worked, I still had to give the acpi=off boot option during install though. First boot went to black screen, rebooted into runlevel 3, ran yast2 to get all additional updates, install wireless stuff, and nvidia drivers. Added nomodeset to kernel options and all is well. Just updated to Gnome3 and love it.