Install redmine?

openSUSE 12.3, standard release, fully updated using standard repos
# mysql --version
mysql  Ver 15.1 Distrib 5.5.29-MariaDB, for Linux (x86_64) using readline 5.1
# ruby --version
ruby 2.0.0p0 (2013-02-24 revision 39474) [x86_64-linux]

Running into numerous issues installing, current issue is with imagemagick which is required to display gantt charts.

Issues installing redmine:
Investigated openSUSE rpms,.found only obs and factory builds. None installed without issue, primarily failing due to missing internationalism packages,
rubygem-i18n=0.4.2 required, but that rpm also requires

After that, I considered the likelihood of chasing down packages a potentially big problem, so I instead decided to try the Ruby Gems way (redmine is a ruby on rails project)

Downloaded source from

Unpacked, followed the included INSTALL file

cp config/database.yml-example config/database.yml
bundle install --without development test rmagick

error returned

An error occurred while installing mysql2 (0.3.11), and Bundler cannot continue.
Make sure that `gem install mysql2 -v '0.3.11'` succeeds before bundling.

So, ran the following which completed successfully

gem install mysql2 -v '0.3.11

And then the re-ran the above “bundle instal” command without error.

Installing imagemagick
Then I took a closer look at what imagemack was and could not find imagemagick installed on my system despite initially believing that ruby gems should have installed. So, I then went about installing imagemagick separately. Since it’s not in the openSUSE repos, and according to the instructions to install from source it’s likely important to configure imagemack properly, I decided to install from source.

I downloaded. imagemagick from here

Following the instructions on this page
Installing RMagick 2 on Linux and FreeBSD

  • Made sure all delegate libraries were installed (only Freetype app itself needed to be installed, libraries were already installed_

Extracted imagemagick archive
Modified the ./configure command as described to run on a single line

# ./configure --disable-static --with-modules --without-perl --without-magick-plus-plus --with-quantum-depth=8 --with-gs-font-dir=$FONTS

The script fails with the following

checking for libltdl... 
checking ltdl.h usability... no
checking ltdl.h presence... no
checking for ltdl.h... no
checking for lt_dlinit in -lltdl... no
checking if libltdl package is complete... no
configure: error: in `/home/tony/Downloads/ImageMagick-6.8.5-10':
configure: error: libltdl is required for modules build

So, ran

# zypper se libltdl
S | Name     | Type    | Version       | Arch   | Repository       
i | libltdl3 | package | 1.5.26-23.1.1 | x86_64 | openSUSE-12.3-Oss
v | libltdl3 | package | 1.5.26-23.1.1 | i586   | openSUSE-12.3-Oss

After further searching and research, ltdl.h apparently is no longer in Fedora/openSUSE libltdl packages. Surprisingly I seem to have ltdl.h in a package I have installed called openmpi-devel. Interestingly, the file is invisible to “what provides” but can be found using YAST with the “list files” option. I had thought the commands should be nearly interchangeable, but this is an example where they return different results.
The file location:


Surprised that ltdl.h was not working despite its location, I nevertheless created a symbolic link where I thought the library ordinarily might be found

# ln -s /usr/lib64/mpi/gcc/openmpi/include/openmpi/opal/libltdl/ltdl.h /usr/lib64/ltdl.h

But, when I re-ran ./configure (as described above), the same error exists.

So, I find myself stuck. I opened up and looked at the “configure” script but the code evaluating ltdl.h is too complex for me and I’m not sure even if I was able to decipher the meaning whether it would help me understand why the ltdl.h I have installed isn’t working.

Bottom Line:
If anyone knows a recipe for installing Imagemagick properly and redmine more generally (fully functional), would like to know what you might advise.


Minor addendum:
The openmpi package comes from oss

Information for package openmpi-devel:

Repository: openSUSE-12.3-Oss
Name: openmpi-devel
Version: 1.6-3.1.2
Arch: x86_64
Vendor: openSUSE
Installed: Yes
Status: up-to-date
Installed Size: 8.9 MiB
Summary: A powerful implementaion of MPI

What prevents you from installing Imagemagick from main repos ?

For some reason I overlooked this simple solution.

I found ImageMagick from the rpms already installed (again, not sure why I didn’t find before, maybe camel case?).
Since there is no “configure” file, I wonder what is configured (maybe enable everything?).
Added the ImageMagick devel package.
Re-ran the “bundle install” command installing from source, since that gives me better error reporting than installing an rpm.
Installed that plus the rubygem package supporting mysql2 connections.
At this point the “bundle install” worked fine.
But, just for good measure I ran the redmine rpm from scm
Found the i18n multi-language file missing again but this time I found the required file at

At this point it looks like redmine is installed without generating errors, but when I tried to open a web browser to localhost, I found my apache2 service down, but that’s another problem that will need fixing that I’d hope is not related to redmine.

Thread closed for now, and hope some of this info might be useful if someone else runs into similar issues getting redmine installed.


Seems my problem with Apache is a well known one (people should be complaining soon if not already).

If your Apache2 is running fine, you probably won’t want to update or re-install for awhile. If you somehow suck this problem into your system, you might be SOL for awhile unless you have a way to restore your system to an earlier configuration.
Discussion about the latest development version of SUSE Linux. ()

Consequence is that this might be a show-stopper, the entire apache2 service crashes because without a working uid.conf the service isn’t configured with a security context.

For those of us who have re-installed or updated very recently, I wonder if I’m SOL for now. Don’t know how long I can wait for a fix.
For now, I guess I’ll experiment maybe inserting some blank spaces in my uid.conf file.


Just an FYI on this off-topic but important issue regarding the Apache service failing to run due to being unable to read uid.conf properly, Note this is a separate issue likely to affect many and not related to any redmine specific problem.

If anyone experiences this, you can force install the original packages in the Install DVD.

An example procedure follows on my system

# List repos so I can specify repo by number instead of typing out entire repo name
zypper lr
# In my case, I have mounted my DVD ISO as the 27th repo in my list
27 | openSUSE-DVD-iso                  | openSUSE-DVD-iso                                 | Yes     | No   
# Force re-install apache2 from the DVD
zypper --no-remote in -f --from 27 apache2
# Restoring old binaries makes major changes to the systemd Unit, so reloading module(s) is required
systemctl --system daemon-reload
# Start/restart the service
systemctl restart apache2.service 
# Verify the apache service is now running
systemctl status apache2.service 

And, of course open a web browser pointing to localhost (testing from the same machine)