Install problems with 12.3

Hi all,

This is my first post here.
I have been racking my brain on this and decided to see what folks in the forum think.

Here’s the situation: I have an asus s400ca ultrabook I want to install opensuse 12.3 on. I tried doing a dual boot with windows 8 with secure boot and uefi turned off. I followed the directions at this link:Dual-Boot openSUSE 12.3 And Windows » TweakHound . The live usb install foes through with no problem. When it starts to boot, there is nothing. No reference to opensuse at all. So I removed windows 8 entirely. I went through the live setup on usb again with the same result. I think there is a partition setting i’m missing or a boot setting I am missing in the setup.

Any thoughts?

Thanks.

That was probably a mistake.

Here’s the situation:

  • If your hard drive is GPT partitioned, then you need to install Windows in UEFI mode, and it will be best to also install opensuse in UEFI mode.
  • If your hard drive uses traditional MSDOS/FDISK partitioning, then Windows will have to be installed in legacy BIOS mode (UEFI permanently disabled.

It looks as if you had Windows installed in UEFI mode, so your disk must be GPT partitioned for that to have worked (Windows is fussy about that).

If Windows is in UEFI mode, then I don’t think EasyBCD is going to be able to boot opensuse.

You can install opensuse 12.3 in UEFI mode. Here is my guide: Dual boot opensuse 12.3 and Windows 8 on a UEFI box

Thanks.

That gave me some clues. One, i was using the 32 bit instead of 64 bit. I re-enabled UEFI and secure boot in the bios. After fiddling with the right combination of boot loader,lvn configurations and such, grub2-ei worked. Installed and rebooted. After the reboot, i got an error the that the security key was invalid. I went in, disabled uefi and secure boot, rebooted and behold: I have an openuse 12.3 kde desktop on my ultrabook. AWESOME.

Thanks again for your article and pointers.

Cheers.

Secure boot turned off at least until you get updated. but don’t turn EFI off.

You need to explicitly enable Secure Boot during installation (in bootloader properties), in this case it installs special bootloader which is “officially” signed.

Actually it should be able to detect whether secure boot is enabled or disabled in firmware by checking EFI variables … anyone care to open bug report? :slight_smile:

It was enabled on my 13.1M1 install.

Perhaps I should start another install, this time with secure-boot disabled, and see whether it is still checked in that case.

Another option, which I used to force install and working GRUB2:

Disable UEFI

Boot from the LiveCD, and remove the GPT:


dd if=/dev/zero of=/dev/sda count=100000

Next start the installer, create partitioning and install. By default a “traditional” partitioning will be created. Perform the install as before.
**
Mind: I only write this suggestion since you already removed Windows 8. This should never be done when a dual boot is the goal. **