Install problem openSUSE 11

Tried two complete installations (no other OS on HD): Gnome and XFCE. Both have problem with X server:

fatal server error:
no screens found
(WW) xf86CloseConsole: KDSETMODE failed: bad file descriptor
(WW) xf86CloseConsole: VT_GETMODE failed: bad file descriptor

Everything else works fine at boot level 3.

Installation was the x86_64 version from DVD. MD5 checksum OK.

I had previously 10.3 installation and was getting strange errors from an application: Application would not run if output was redirected to a file; worked OK without redirection. Author of application could not reproduce and was sure it was not his program. I was going to try 11 to see if problem persisted.

Maybe I have incompatible hardware? Motherboard is ASUS L1N64-SLI WS/B with 8GB ram and opteron 2350’s. I liked openSUSE 10.3 as I was able to get my wireless USB adapter working (hopeless with Fedora or Ubuntu).

Thanks for any suggestions, Skippy

PS Is there any possibility that installing the Nvidia driver for my graphics cards would help at this point?

boot to level 3 as root

sax2 -r

Definitely. You can install it from the nvidia repo at the command line using zypper. Or download the installation script from nvidia’s site and compile it; that requires the kernel-source, headers, gcc, and make. If the card is new, or given that you have SLI, check the nvidia site to make sure you don’t need the very newest driver which is only available using the script.

Also, take a look (as root) at /var/log/Xorg.0.log for the problem. But again given you have an nvidia card with SLI I would just go to that driver first.

Alternatively, you could also try the “vesa”, “vesafb”, and “fbdev” drivers. The latter 2 are framebuffer drivers. You won’t get a final solution, but maybe a gui which would help isolate the problem to the driver. I find it easiest to just modify the Device Section of /etc/X11/xorg.conf from the command line, replacing the driver name.

sax: no X-server running
sax: will start own server if needed

…several hundred lines of output…

ending with:

died at /usr/share/sax/init.p1 line 653

which contains:

if (ServerLines<3) {die Sresult;}

Skippy

I have downloaded the proper driver to a DVD on another computer.
I have been looking for hours, even tried to read the man page for mount (yikes!), but I don’t know how to mount a CD-ROM/DVD from the level 3 command line.

Skippy

PS the computer I am trying to install openSUSE11 on does not yet have a working network interface.

Hi
Quick way is to install the ivman service for auto mounting;


sudo zypper in ivman
sudo /sbin/chkconfig ivman on
sudo /etc/init.d/ivman start

To mount manually, check dmesg for the dev reference, then for example
it’s /dev/sr0;


mkdir /tmp/cdrom
sudo mount -t iso9660 /dev/sr0 /tmp/cdrom


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.18-0.2-default
up 6:07, 2 users, load average: 0.26, 0.14, 0.15
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.82

I looked at all 824 lines of output from dmesg. With my limited emacs skills I couldn’t find anything.

ivman seems to work, it creates a directory /media/Personal Data, Dec 03, 2008. It’s in blue so I know it is a directory but cd says no it isn’t. I double checked spelling and capitalization. Tried spaces and underbars. The name “Personal Data…” was generated by the cd burner that made the disc. If I don’t figure it out I will try to remake cd with a different name.

Skippy

I remade my driver disk with a name linux could read. Tried the install instruction:

sh NVIDIA-Linux-x86_64-180.06-pkg2.run

The Nvidia installer complains that it cannot find: /lib/modules/2.6.25.5-1.1-default/build/include/linux/kernel.h and suggests I use the --kernel-source-path option. So I find the only occurance of kernel.h is in /usr/include/linux. Tried the command:

sh NVIDIA-Linux-x86_64-180.06-pkg2.run --kernel-source-path=/usr/include/linux

and get the same message as without the option. Looked through Nvidia driver install information and can’t find anything. Not sure if this is an OS problem, Nvidia problem or skippy problem.

skippy

I’m having the same problem (another thread) with sax2 crashing, using SuSE 11.0 live disk. The default driver works (I’m using it right now.) Executing sax2 -r yields the same failure. This is perplexing as I used the same disk to install my laptop months ago, and it works fine.

BTW I just executed sax2 -r on the laptop. The command performs correctly, i.e., it opens the Sax2 window with the various options to set.

@skippy -

Are you positive you have all the kernel-source, headers, gcc, and make dependencies satisfied. Matching versions?

Unless you’ve found on the nvidia site that your card is only supported by the newer driver in the install script, I strongly advise using the driver from the nvidia repository. It will be kept current with kernel versions, automatically updating with any kernel update. Whereas when you compile, you have to recompile with any kernel update.

Also, I didn’t notice you indicating which version of openSUSE you are installing. fwiw while testing 11.1 I noticed there was a kernel update to a newer version while the kernel sources were not yet updated. I caught this when trying to compile from the same nvidia script on one of my test machines; of course the compile failed.

That it works on one machine is no guarantee of working on another. To get help on the current install, you need to provide the graphics device model (also post the output of the lspci command, run as root), the monitor if applicable, the laptop if applicable, and anything you’ve done so far with it.

Also, let me suggest starting your own thread. Coming into an in-process thread can not only get confusing to everyone posting, but more importantly with a fresh thread you get greater immediate visibility specific to your problem, and hence the chances of more/better assistance.

version 11.0

According to Nvidia this specific driver has been tested for use with Cuda 2.1 on openSUSE 11.

When I installed OS, I checked the boxes for kernel development, and program development, gcc &ct. No packages over internet or updating as I do not yet have access.

Willing to reinstall from scratch, any specific suggestions? Packages to include, exclude? Which GUI is less likely to cause problems. I don’t need anything fancy, just don’t want to run a text mode browser.

Skippy

My motherboard is also ASUS L1N64-SLI WS/B, my graphic card is 7300 GTS. I used the package 177.82 from Nvidia and the compilation of the kernel module did finish. However, when I tried ‘sax2 -r’, the machine suddenly rebooted and X-server cannot start on reboot.

It appears that openSUSE detected the ethernet card, but the network interface just won’t work. I suspect that the drivers are malfunctioning for the gigabyte NIC. One suggestion is to buy a cheap PCI NIC and get connected first, then tried downloading it from Nvidia repository.

Another thing: if I turn my monitor off while booting openSUSE, the X server will be up, but with a limited resolution of 1024x768.

I guess Skippy and I are on the same boat. I have spent a lot time on this, so gurus please please help!

@skippy -

Sorry you had a problem getting the driver working. I’ve compiled it many times, in every release going back to the beginning, without a hitch (except when I missed something myself, like the sources/kernel match I ref’d earlier).

When you reinstall, go into the Packages section and click on Details. You can search individually, or view all packages categorized by Patterns or Package Groups. IIRC you want gcc, gcc-c++, and make; all in Base Development. The kernel-sources, which are in Kernel Development. And for good measure the linux-kernel-headers package; not sure which Pattern. Also install nano, comes in handy if editing the X server control file is necessary later.

But let me re-emphasize that, unless the nvidia site shows that your card is only supported by the driver version compiled as opposed to what is in the nvidia repository, go with the repo version. Since you won’t have a net connection yet, still install the packages above just in case. The installer will probably choose the “nv” driver or “vesa” driver, one of those usually works until you can add the nvidia repository and install the proprietary driver. This also can be done with zypper from the command line in runlevel 3.

As far as a Desktop Environment or Window Manager (the latter being a subset of the former), there is no effect relative to the card/driver working - they all use the X server, it’s X running that matters. If you want compositing special effects, Gnome uses Compiz, KDE 3.5 also can (can be a bit of a headache to set up though), KDE 4 can but does much better with its own native kwin. Re KDE, 3.5 is very stable; the 4.0 on the 11.0 install is immature and you would want to plan to upgrade to 4.1.3 for 11.0 thereafter, or go to 11.1 when it’s available soon (it’s in RC1 right now). There is also Xfce which is a lightweight DE, and then WM’s like fvwm, fluxbox, WindowMaker, icewm, lxde, and openbox; all on the DVD, look in Package Groups/Other Desktops.

My only other thought is that if your card and board are SLI and that can be temporarily disabled, you might check into that. I have no experience with SLI, so take this with a large grain of salt. Mine is just a generalized comment re the extra steps that can be required for fancy setups. Sometimes its better to get the basics working and then add the enhancement. I don’t know if this applies to SLI, but again might be worth a bit of googling.

All I can think of. Good luck.

By the way, as an aside I assume you guys are using ECC Registered ram with this board; came across that as a requirement in the specs.

@skippy -

Came across a post of yours on the nvidia forum re the ram - looks like you’ve got that nailed down, so disregard my last post.

I’m gonna have to build a monster something like this for myself.

I would suggest that if possible at first at least, disable SLI to get the X server working. The command to initialize the nvidia driver is:

sax2 -r -m 0=nvidia

Remember that the driver should be installed with X not running, so do it booting into runlevel 3, switch to root, do the above command, exit root, and do “startx” to start the server. The logfile is at /var/log/Xorg.0.log and will report any errors as well as functions enabled and resolutions supported. Always check /etc/xorg.conf for the actual configuration. There are times it must be changed manually because sax may not have a profile or the correct profile for a particular card/setup (the above command tells sax to use the nvidia profile); recently a user with a new 9xxx series card needed to do this because apparently the card was not yet in the profile - as a result, that user’s modes (resolutions) were not right. Another possible reason for a resolution problem is that the monitor properties are not correctly read by the graphics card (sax gets monitor info from the card’s reading of the monitor’s EDID; there are number of reasons graphics side but most often monitor side for which this can happen). So be sure that xorg.conf monitor’s dimensions are correct or your resolutions can be thrown off.

If you google re that board and your NIC, you’ll find posts abt getting it working - I saw a thread with @skippy posting, he apparently figured it out and actually had more success with it in openSUSE than other distros. So he is probably ahead of us for this particular question.

WOOHOO!

zypper install kernel-source
sh NVIVIA-Linux-x86_64-180.06-pkg2.run

Said OK for Nvidia to configure X. All is well. Thanks to everyone here for the assistance and suggestions.

Skippy

PS I’m sure I’ll be back when I hit my next brick wall.

Well, it’s a WooHoo to you for hanging in until resolved. :slight_smile:

Well, almost all is well.

Every time I boot to level 5, I get a box popping up “PackageKit Error - A problem that we were not expecting has occured. Please report this bug with the error description. Error description: repo-oss: Valid metadata was not found at specified URL(s).”

Unit has NO internet or network configurations yet. Everything so far functions properly.

??? skippy