install opensuse: troubles with graphic card configuration on Radeon HD 8850M

Hello all,

I installed OpenSuse 13.1 in dual boot on my Samsung ATIV Book 6 pre-installed with Windows 8 (with graphic card: Radeon HD 8850M) with a usb key (ultrabook, no dvd reader atm). I am having trouble with the graphic card drivers.

just fyi, I am very new to the linux world, i have tried for a month and a half to install Ubuntu with graphic proprietary drivers on my previous macbook pro, gave up, sold it, got this new laptop, tried once again ubuntu, could not even get the live cd working and finally I managed to get Open Suse installed, and this time I intend to finish it :)! However I have several issues still unsolved, and after many unsuccessful searches I decided to ask for your help here.

**[size=2]Currents issues I am stuck with:

resolution is stuck to 800*600
[/size]**
I had to set nomodeset in the boot load configuration both to start the live cd and to start the installed os afterwards.

I tried to install the proprietary driver fglrx following every different procedure indicated in http://en.opensuse.org/SDB:AMD_fglrx but once installed, I could not load the gui anymore. And I am too uneasy with the zipper command to restore the default graphic drivers (seemed easier with apt-get in ubuntu, would you have a tutorial to share to restore default headers/drivers through command line once we messed it all?), so every time I had to install once again with the live cd to restore my os.

**I would like at least to use the radeon driver as described in http://en.opensuse.org/SDB:Radeon but “modprobe radeon” returns "FATAL: Error inserting radeon (/lib/modules/3.11.6-4-desktop/kernel/drivers/gpu/drm/radeon/radeon.ko) : Invalid argument). Any hint/procedure on installing the radeon driver from scratch?

I figured out that I could get a normal resolution if I went through samsung boot loader first. How to get it permanently fixed?
**I went through the following procedure:press F10 when laptop starts to choose the partition to boot on
choose opensuse
choose opensuse in grub2 (the grub2 UI appears in a higher resolution than if I let the laptop boot normally and go through grub2)
and Voila! resolution is correct but once i restart, i lose it.

Brightness is too low and keyboard fn keys do not work
while volume and touchpad-enable keys work. but not brightness or keyboard backlight.
I tried the the commands xrandr and xbacklight but nothing happens, as advised in http://stackoverflow.com/questions/6625836/how-to-change-the-monitor-brightness-on-linux
any hint?

Thankfully,
Jeremie

I would suggest you install the proprietary fglrx driver.
To do that just use the 1-click install here:
http://en.opensuse.org/SDB:AMD_fglrx#Procedure_for_one-click-install

As i said, I unfortunately tried the 1-click procedure, the yast, the zipper command-line and the script from the german fellow. Concerning the last one, problem was that running his script failed because my card was not compatible. The driver that include my graphic card is the 13.9 driver and he wrote no script for this particular one. I tried running the amd driver bash script directly but it also failed.
What logs might be helpful for your guidance? I would also rather like to know how to rollback any driver install before starting it once again if you know it :)…?

Ok I found https://forums.opensuse.org/showthread.php/431092-Restoring-default-graphics-drivers
i am going to retry installing proprietary drivers and use sax2 -m 0=vesa to restore default drivers

i would have edited my post if i could, I found the solution for the resolution: specify the resolution to use in the grub configuration file.
http://askubuntu.com/questions/54067/how-do-i-safely-change-grub2-screen-resolution

nothing found otherwise concerning brightness and it’s hurting my eyes :(!
I used this tutorial http://tr.opensuse.org/SDB:Using_the_Extra_Keys_on_the_Keyboard to assign the variables XF86MonBrightnessUp (and others for keyboard) on available keyboard keys but once again nothing happens.

Sorry, I overlooked that.

Concerning the last one, problem was that running his script failed because my card was not compatible. The driver that include my graphic card is the 13.9 driver and he wrote no script for this particular one. I tried running the amd driver bash script directly but it also failed.

The 13.9 driver DOES NOT WORK on openSUSE 13.1.
You need at least the latest version, 13.12.
And yes, this does support your card, as it supports all cards from HD5000 up.

Did you get any errors when you installed it?

How did it fail? Did you get to text mode, or did the screen stay blank?

Can you boot again with the fglrx driver? Then reboot to Recovery Mode “Advanced Options” in YaST, and upload the file /var/log/Xorg.0.log to http://susepaste.org and post a link. This should give a clue why it didn’t work.

If you need to install the driver again, just enter YaST->Software Management, search for fglrx and install the package there.

Don’t. Sax2 is not available any more.
Just uninstall the fglrx driver and you should use the default drivers again.

If you installed the driver using the RPMs, just enter YaST->Software Management, search for fglrx and uninstall the package.

sax2 is long gone and no longer works right. You are using old instructions

[QUOTE=jeremie_charlet;2619462[b]]I had to set nomodeset in the boot load configuration both to start the live cd and to start the installed os afterwards …

I would like at least to use the radeon driver as described in http://en.opensuse.org/SDB:Radeon but “modprobe radeon” returns "FATAL: Error inserting radeon (/lib/modules/3.11.6-4-desktop/kernel/drivers/gpu/drm/radeon/radeon.ko) : Invalid argument). Any hint/procedure on installing the radeon driver from scratch?[/QUOTE]if you’re using nomodeset, then you will NOT be able to use the radeon kernel driver, as it works via KMS (which is the opposite of UMS, and which functionally gets invoked by the “nomodeset” boot option)

…though, I for one admire that they’re actively searching for a solution themselves :slight_smile:

Thank you for your answers :).

So wolfi I installed fglrx with Yast,
reboot,
edited grub conf and removed the nomodeset option as per Tyler comment
> black screen, nothing happens. I tried again without splash and quiet options but I don’t see anything, logs disappear quickly

When i reboot with nomodeset, the GUI fails to start but I still get access to the console. I am going to try to uninstall the driver to get back my GUI.

I however could get access to the log files using the live usb (I tried for a while to send to me the log file by mail through command line, but since no account was configured yet, I could not do it. What an enriching experience :wink: )
Here is the Xorg log when I booted with fglrx installed and without nomodeset option: http://susepaste.org/88126850

edition time expired for the above message, so here is my update: removing the drivers indeed restored the default graphic drivers and I could get the GUI back.

Why go through all this extra work, when you could simply run a VM?

run a vm within windows you mean? Because I don’t want any of this slow, unstable windows os, full of gadget features I don’t need ;). I would have bought an os free laptop If I didn’t get this bargain for this laptop. Besides my work often involves working on Linux based servers, so all I learn here might help. And it’ s rather fun when it s not frustrating!

So you have a hybrid system? (intel and AMD graphics)

According to your Xorg.0.log you seem to have the same problem as here:
https://www.kubuntuforums.net/showthread.php?59858-Proprietary-ATI-Drivers-version-12-8

Unfortunately there’s no solution there.

Have a look in your BIOS settings if you can disable the intel graphics. Then the fglrx driver should just work.

Maybe try to add “nomodeset” to the boot options (with the fglrx driver installed), that should disable the intel driver and may work then (or not).

PS: I already mentioned it, but just in case: to reinstall the fglrx driver just enter YaST->Software Management, search for “fglrx” and install the package there.

huh looks bad, no option is dedicated to graphics in my BIOS settings, and I already tried to boot with nomodeset but it failed. I will try to get something out of your link.

[update] and I indeed have an intel processor with an amd radeon graphic card

The processor does not matter.
But apparently you have two graphics cards, an intel and a radeon.
You may want to verify that with “/sbin/lspci”.

Unfortunately I have absolute no experience with those hybrid systems.
I just happen to know that the proprietary nvidia driver does not work at all in such a case, you need a solution called “Bumblebee” there.
I think the fglrx does actually support this though, and in your Xorg.0.log I see it (fglrx) recognizing the intel chip and trying to load the intel driver. But obviously it doesn’t work on your system for whatever reason.

A wild guess: Try to uninstall “xf86-video-intel”, so the intel driver cannot be loaded. But I have no idea how the fglrx driver will react to that then.
Or maybe even try to blacklist the intel kernel module (i915? “lspci -nnk” should tell), creating a file in /etc/modprobe.d/ with the content:

blacklist i915

or whatever your intel chip uses.

That’s not a surprise*. fglrx drivers don’t use KMS. The intel and radeon OSS driver stacks use a KMS codepath. The OSS kernel drivers are contained in the initrd. Removing nomodeset allowed the OSS kernel drivers to load at boot. Later, once X started, xorg tries to load the fglrx stack, and fails.

  • and note that my original comment was in relation only to the OSS radeon driver (although it applies equally to the intel driver … which we didn’t know about (i.e that one was also present) at the time of writing).

When i reboot with nomodeset, the GUI fails to start but I still get access to the console. I am going to try to uninstall the driver to get back my GUI.
Well, the fglrx should work in a hybrid system, but I don’t use such (nor, truthfully, am I really interested in the blobs). You could post the xorg log for when this occurs and we could look at it to see if it was something simple. As wolf mentioned, you might have to do some modprobe configuration, as I don’t know how they (catalyst/fglrx) are handling the config under a hybrid/powerxpress system … let alone power mgmt etc.

An alternative, and OSS solution, would be to upgrade to kernel 3.13 and the upgrade your xorg/mesa stack too. Under such configuration, 3.13 introduced run time power mgmt for powerxpress systems … what is your usage scenario? If you’re looking to use the AMD adapter to play games, then you’d get better 3D performance with the fglrx/blob, though you might be content with what the OSS can (as of very recently) now achieve for your adapter.

Indeed, how weird, why should be there 2 graphic cards? The intel is embedded in the motherboard?

linux-40vc:/home/jeremie # /sbin/lspci | egrep ‘Radeon|Graphic|Display’
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Venus XT [Radeon HD 8870M]

Ok wolfi, I am going to try to uninstall the intel driver and/or blacklist it in modprobe.

Wow, lots of complex information, i had to make some research about kms, kernel, initrd, to understand it a little bit :). Found an interesting graphic here btw http://en.wikipedia.org/wiki/Mode_setting, is the radeon OSS related to the libDrm-radeon described in the graphic (outside kernel therefore)?

I would like to play games, this is why i am looking first at proprietary drivers, but if I can’t manage it, oss will be fine for my everyday usage. I just discovered that If I plugged my laptop the brightness was up, and this is fine for using it, I started installing applications and play with it. I still have to fix that brightness keys issue.

Another issue I got: It seems that my wireless connection is inconsistent. For example, whenever yast tries to access a repo, it often prompts me to check my connection, and I just have to choose the restart option to get it work. Is it a common issue? Can it be fixed? I googled it and found a comment about it in http://www.zdnet.com/opensuse-13-1-hands-on-some-more-thoughts-7000023541/

Please open a new thread for this problem, in the wireless forum.
Is it a common issue? Well, I don’t have that problem. But it may be common for your particular wireless device.

Regarding the graphics issue:
I had another look at your X log, and it seems the intel driver actually fails to start:

    25.263] (II) fglrx: intel VGA device detected, load intel driver.
    25.263] (II) LoadModule: "intel"
    25.263] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
    25.264] (II) Module intel: vendor="X.Org Foundation"
    25.264]    compiled for 1.14.3.901, module version = 2.99.906
    25.264]    Module class: X.Org Video Driver
    25.264]    ABI class: X.Org Video Driver, version 14.1
    25.265] (II) fglrx(0): pEnt->device->identifier=0x2537ff0
    25.265] (II) intel(1): pEnt->device->identifier=(nil)
    25.265] (EE) Screen 1 deleted because of no matching config section.
    25.265] (II) UnloadModule: "intel"

So maybe that’s the reason why it doesn’t work? (disabling/uninstalling intel wouldn’t help then either of course)
According to the log, you have an /etc/X11/xorg.conf. That may prevent the loading of the intel driver, so try to remove it (renaming it should be sufficient).
Maybe it works then? (Be sure to remove all blacklisting you manually did and nomodeset)