Install Opensuse On a machine with an Nvidia card. Black screen of death

I just finished what was an unnecessarily difficult install. I’ll put a list of my troubles at the bottom.

The thing that I’ve encountered almost every time I install on a machine with an nvidia card is that it boots partway and then yo get a blank monitor. No way to switch to a VT. If you google enough you will find hints, but here it is:
NOMODESET
You must pres e (for edit) on the grub2 line for the kernel you intend to load. Go down to the line with all the kernel parms, most likely the last words in that line are: “splash=silent quiet showopts”. Press the end key to get to the end of that line and enter “nomodeset”.
This probably isn’t required if you’re using the nouveau driver, but the installer didn’t install that anyway so I can’t say.

How I did this install:
-configure the bios to boo a vga monitor and hook one up (I luckily have an old one and my board has a vga connector)
-boot and install opensuse as per usual
-now add the nvidia repos and install the nvidia drivers.
-if you have access to yast, use it to add the “nomodeset” parm to your kernel parameters. If you can’t figure out how to do that, don’t worry you can add it by hand and then use yast later.
-configure the bios to use the nvidia card and connect your (presumably hi-def) monitor
-reboot
-at the grub prompt press “E” and make add the nomodeset kernel parm then press f10.
-if you don’t have any luck and need to use “startx” to debug, you can enter “nomodeset init 3” to stop before starting the X server

Hopefully this gets you a working X system.
-if it performs dreadfully (jerky movement of windows, generally unacceptable performance) go to the settings panel ->display and monitor → composter and set the rendering backend to XRender. the opengl ones suck… inexplicably.

Some other things I learned:
-radeon cards are not supported much better than nvidia. I originially bought an ati pro wx2100. After a LOT of agony I contacted them and they said that they the amdgpu driver didn’t support “pro” cards. I grovelled at my computer supply store and they swaped me a geforce 1030
-I also bought a $680cdn dollar Samsung nvme because my motherboard (intel server board) advertised it had an M.2 slot. Well it had a “short” slot that wouldn’t accomodate the 4cm nvme card. So I had to buy a pcie card to add my nvme. THEN I found (from about a hundred attempts) that absolutely no way can you boot off the nvme. At least not linux on with this bios. So I bought a 250mb ssd and put my root partition there. I will subsequently reconfigure things so that my performance critical items are on the nvme.
-the thing that Fedora and Centos would do that Opensuse would nto was allow me to have my root folder on one drive and the /boot… stuff on another. There is no way to get that into the partition tool during install (IMHO)

Its no-one’s fault, but the memory I ordered for this mb was of the correct spec, but wouldnt’ work. I had to replace it with some cheaper memory to get it to boot.

The world of PC and the parts they are made of has made no progress in the 10 years since I built a machine.

Sorry for the rant. but it may help someone out.

Responding to various in your post…

You may have mentioned, but it’s worth repeating that YaST has a bootloader module where you can set numerous boot options fairly easily.
Don’t overlook it.

Regarding setting up a boot partition on a separate disk…
I haven’t actually looked into it but would be surprised if it couldn’t be set up using the Partitioner during Install. I seem to remember it’s not difficult to set up a separate boot partition, so I would think it’s hardly an issue to do that on a different disk.

Regarding your issues with NVME,
You’d probably benefit from the following I posted today, it might not be an obvious resource for setting up GPUs because it’s more likely found if you’re looking to resolve ffmpeg support, but it’s an excellent resource for more generally setting up hardware GPU acceleration no matter what GPU is installed

https://forums.opensuse.org/showthread.php/533300-Where-to-get-FFmpeg-with-NVENC?p=2882928#post2882928

TSU

This is not a request for help, so moving this thread to chitchat.

Thread closed for move.

Thread moved and re-opened.

Them/they who? The wx2100 was released over a year ago and surely must be supported via upstream kernel and X drivers long before now.

I also bought a $680cdn dollar Samsung nvme because my motherboard (intel server board) advertised it had an M.2 slot. Well it had a “short” slot that wouldn’t accomodate the 4cm nvme card. So I had to buy a pcie card to add my nvme. THEN I found (from about a hundred attempts) that absolutely no way can you boot off the nvme. At least not linux on with this bios.
What chipset does your motherboard have? The limitation may have nothing to due with your BIOS.

the thing that Fedora and Centos would do that Opensuse would nto was allow me to have my root folder on one drive and the /boot… stuff on another. There is no way to get that into the partition tool during install (IMHO)
I’ve never had any such trouble with an openSUSE partitioner.

I really don’t understand your issues but I’ll give a few hints
the opensuse disk partitioner is extremely powerful but might not be as user friendly as others you can use gparted to partition your drives before instalation (I use legacy mbr with only 2 partitions root and home I don’t use swap)
https://gparted.org/
I’ve never had an issue with nvidia graphic cards during install so I can’t comment there you can always select vesa during install
as far as I can tell you’re installing in uefi mode did you disable safe boot in bios otherwise the installer will have issues writing to the /boot partition
again I’m not quite sure but in mbr mode I can install the boot loader where ever I usually put it in the mbr and in the /root partition I don’t think this is possible in uefi mode
if you want to put the boot loader somewhere else reformat your hdd from gpt to mbr disable uefi and install in mbr but do not do this if you have windows in uefi mode do not mix boot modes

I’ve used Nvidia grfx cards exclusively since 3DFX folded. Never once have I had an issue with them in any linux install, regardless of driver used.