Install openSuse from second partition?


I was trying to install openSUSE 11.2 64 bits from the second partition of my 8GB USB pendrive.

Why? I want a dual data / emergency install pendrive without mixing my data with the install system.

As most people use MS Windows, and it’s only able to mount the first partition of USB removable drives (without installing an alternative USB disk driver), I need the first partition to be the data partition for normal pendrive use.

Ok, I must say I’ve accomplished this with Ubuntu before without major problems.

Well, as of now, I’ve copied the ISO image contents to that second partition, installed Grub4DOS in the MBR with its corresponding custom menu.lst file, and made bootable the second partition.

When booting my system from the pendrive, the kernel was loaded without problems, but the boot process stopped with a message indicating that there was no device with MBRID = 0x8c71ad6e.

Ok, I ran fdisk from Linux and diskpart from Windows, and find the MBRID for my PenDrive is 0xed196ecb.

I’ve modified the /boot/grub/mbrid file with the actual pendrive MBRID, but the system refuses to boot with the same error (and with the correct MBRID).

Is it possible that the install system is only able (is hardcoded) to boot only from the first partition?

Thanks in advance.

Well, I’ve started the entire process again, and I no longer have any problems with the mbrid.

Now, the boot process stops at the following point:

Loading KIWI CD Boot-System...
Creating device nodes with udev, size=0x3e62e0]
Boot logging started on /dev/char/../tty1(/dev/console) at Thu May  6 2010
Boot-Logging enabled on /dev/tty3
    0.785244] kernel logging enabled on: /dev/tty4
    0.788733] Waiting for USB device scan to complete.....
    3.452988] Mounting hybrid live boot drive...
**    3.502312] Couldn't find Live image configuration file**
    3.503101] rebootException: error consoles at Alt-F3/F4
    3.504090] rebootException: reboot in 120 sec...

This is the time when it really seems it doesn’t find configuration file because it’s located in the second partition.

Am I right, or there’s any solution to this problem?

I’ve been researching a little and finally confirmed it’s hardcoded in the KIWI Image System of openSUSE.

I extracted the initrd image of the liveCD and found that it’s hardcoded in the CDMount function inside the /include file.

 		# search for hybrid device
 		Echo -n "Mounting hybrid live boot drive..."

		**cddev=$(ddn $biosBootDevice 1)**

I suppose a simple patch could be written and submitted to the KIWI project, but I believe I don’t have enough knowledge to detect the partitions on a given device.

There’s a much easier way: Create a Live USB-stick from a LiveCD of your openSUSE version that you know to run on your machine, there’s HOWTO’s on this. Once the system is booted from it, you can access it to repair whatever’s gone wrong. HOWTO’s on this as well.