Install opensuse 12.2 on macmini usb keyboard dont work.


I have been running opensuse on my macmini with no problem.
Now I thought of doing a fresh install and not using zypper to run 12.2
I started the install dvd and come to boot option 1. Legacy (isolinux) 2. UEFI (elilo)
But my usb keyboard don’t work… so i cant continue…

How do I get my usb keyboard to work?
And dont answer to set legacy mode in bios… mac don’t have an ordinary bios like other pc’s.

So I know nothing about mac mini. What architectures does this box support? Is there a choice for either 32-bit or 64-bit installation? Did you try a Live CD for installation?

I have an old Opteron (AMD x86-64) PC that will not run the OpenSUSE 12.2 32-bit KDE Live installation due to keyboard (and mouse) lock-up. Symptom sounds just like yours although my hardware is at the other end of the technology advancement spectrum.

AMD Opteron supports either 32-bit or 64-bit installation. So I tried the 64-bit installation. That worked. Keyboard and mouse are fine.

I am still debating the advisability of installing 64-bit OpenSUSE 12.2 on top of established X86 32-bit application base.

What seems obvious is that the 64-bit kernel uses different (and more robust) option settings when it is compiled.

I have x86-64 before, but when i run a command in terminal on OS X it says i have a 32-bit EFI. I download 32-bit and try that and see how it goes… I post here later.

Now I used 32-bit opensuse 12.2 and it works! :stuck_out_tongue: