Install openSUSE 11.1 onto Acer 1410 or 1810


I couldn’t find a thread on installing openSUSE 11.1 onto an Acer Aspire 1410 (Acer Timeline 1810T) on these forums (or the net in general) so I thought I’d start one since I’m about to do just that. There’s a very good section on installing on the Acer Aspire One, but the 1410/1810T is different enough to perhaps warrant another document/thread?

  1. The 1410 comes pre-installed with Vista. I don’t plan to boot into that, even for a first time. I would like to preserve the Restore partition in case I sell the machine to someone else that wants Vista/7. (I’m guessing that getting money back isn’t a feasible thing.) Anyway, will the partition appear as something recognizable that I can easily avoid formatting during the partition process? Also, is there special Restore software that I should back-up outside of the Restore partition? (Having never had Windows or a laptop before, Restore partitions are completely foreign to me, i.e. how they operate.)

  2. I plan to install using a USB pen drive with these instructions:

SuSE install from USB drive - openSUSE

Any potential gotchas to watch out for, especially for the 1410/1810T?

  1. Any broken things after the install that I need to fix with openSUSE 11.1? (I saw that Ubuntu users needed to install a patch to fix the wired ethernet port:

Acer Aspire 1410 [Linux Laptop Wiki]


There doesn’t seem to be anything specifically here: HCL/Laptops/Acer - openSUSE

I can tell you though OEM recovery and OS partitions can easily be messed up. Personally I just erased all mine and I have currently re-installed Vista for some testing I am doing with Grub. (You can actually re-install Vista if you can get your hands on a Full Install DVD, regardless of the fact that you are OEM - This what I did) One advantage of this is you loose all the crap-ware too.

What you need to keep in mind is where Grub gets placed. Normally the ideal location is the MBR but if you do this it could ruin your chances of using the current install of Vista or the recovery. But it depends a little on the partition setup.

By default SUSE will at install, probably not put Grub on the MBR but to the extended partition it creates during install and it will switch the boot flag to that partition too. You can read about this iin more detail here:
All About Grub - openSUSE

Only component, that looks “problematic” with 11.1 is -surprisingly- the wired ethernet card.

But: - results for atl1c

Sad to admit, but my 10 year old dual-PII 350Mhz desktop running SUSE 10.1 and USB 2.0 controller card took about four hours to transfer the openSUSE 11.1 DVD iso (from hard drive) to a SanDisk Cruzer 8 GB USB pen drive… ugh…

After the long wait, I was able to boot with the USB drive into an initial text mode to select the install medium, which was of course, the USB drive listed as a VFAT hard drive underneath the two listings for the Vista Recovery partition (I think) and the main Vista install. Since I put the DVD iso in the top root directory, I specified “/” as the source and I was on my way. The install seemed to correctly identify the resolution of the machine as the graphical install was sharp. I went through the motions of install but then abandoned since I wanted to think more about partitioning, perhaps doing /, /boot, swap and /home, as with my desktop.

caf4926: Thanks for your tips. I’m not interested in Vista myself, but perhaps another user later on might. Is Windows “authenticity” tied to a keycode that I can find on the machine? (for a later install?) (Since this machine is eligible for 7, I wonder if I would get physical media or just a code to download it?)

Akoellh: For the wired atl1c driver, do I just download what appears to be the “main” package, without all the extensions in the name? I see many packages from the search result… (Thanks for providing the build!)

Is Windows “authenticity” tied to a keycode that I can find on the machine? (for a later install?) (Since this machine is eligible for 7, I wonder if I would get physical media or just a code to download it?)

For me. I used the Vista Product Key from the machine. Then did online validation, you have to completely re-do validation (make a note of it) because for me the install media was different. The product key just makes the install select the correct product from the DVD, for me, Vista Business.

As for win7, I have no idea what ‘pig in a poke’ deal they will be offering there.

I booted Vista once on my Acer eMachine to copy the manual which is on the Vista partition; then I told openSUSE to overwrite everything except the recovery partition.

I’ve had no problems with the hardware and the only thing which didn’t work with Linux on my previous Acer (from five years ago) was the wireless.

I made another attempt at making a bootable USB pen drive partition, but this time on a Corsair Flash Voyager 8 GB USB pen drive. It only took 20 minutes to copy the openSUSE 11.1 DVD iso this time! Much better! :slight_smile:

The 1410 has two partitions from the factory:

12 GB, ntfs, PQSERVICE (which I’m guessing is the Vista Restore partition)
221 GB, ntfs, ACER (which is the Vista install)

I decided to go with this configuration for the partitioning:

12 GB, ntfs, PQSERVICE (keep the Vista Restore)
100 MB, ext3, /boot
4 GB, swap, swap
20 GB, ext3, /
20 GB, ext3, /usr
194 GB, ext3, /home

The install took about 20 minutes as well…

Every reboot is a new adventure! Argh!

1st install: Everything installed fine, though auto-detection of the display went back to 800x600 (which I corrected in the 2nd install). First order of business was to get wi-fi up and install patches. Wi-fi worked and found my network. The patches required a restart midway through, which is where things went awry. I couldn’t get back in. I saw a segfault in the console followed by a few “respawing too fast” errors (which halted boot). I did a little research but gave up and decided to do a 2nd install…

2nd install: Installation went fine. I set the monitor to LCD with 1366x768. I did a restart and it didn’t come back up to runlevel 5. Rebooted and things were fine. Each successive reboot brings a new problem: doesn’t get to runlevel 5, makes it to runlevel 5 but display is blank, boots up with no sound and wi-fi, bunch of new errors that makes the filesystem read-only, etc…

I’ll continue to poke around and see if I can get anything concrete going. I know I haven’t reported enough for anyone else to help me debug, but the problems are seriously changing from boot to boot…

Still on 2nd install…

3rd reboot got me back up to runlevel 5 with sound and wi-fi, which is huge for getting the updated patches. I started the patching process again and this time I noted the rookie mistake I made: Instead of restarting, I only needed to logout/re-login for the Package Manager patches to take effect. That was probably the root of my problems with the 1st install and the cause of the weird system states after the 1st install.

The system is busily patching the system now… Hopefully with all the patches, everything will be more stable…

Choosing the correct kmp-package for your installation - openSUSE Forums

Needless-to-say, it’s been a long frustrating weekend… but everything seems to work pretty well now! :slight_smile:

The key thing that seems to be the root of the problem is AHCI being set as the SATA default in the BIOS instead of IDE. Once I set the BIOS to SATA IDE, the random hard drive errors on boot went away. (Found out about this from message of people having trouble installing on other Acer laptops, like the 3810.)

So, for installing on the Acer 1410/1810T, I would recommend this:

Base Install

  1. Install openSUSE 11.1 on a USB pen drive with these instructions: SuSE install from USB drive - openSUSE
  2. Insert the USB pen drive
  3. Stop the boot process and set the BIOS SATA to IDE (from the default AHCI)
  4. Install openSUSE 11.1 with the USB pen drive, doing the standard install with Automatic Configuration
  5. Before the Automatic Configuration, the system needs to reboot. Let it. You’ll end up booting into the beginning of the USB pen drive install again. At this point, you need to reboot and set the BIOS to reboot from the Hard Drive.
  6. When the system comes up again, you’ll be into the Automatic Configuration.
  7. Finish the install.

Update to Most Current

  1. After the system comes up again, the resolution will be 800x600. Go into YaST->Hardware->Graphics Card and Monitor and set the Display 1 Monitor to -->LCD and select 1366x768(WXGA). Test and Accept. Log out and log back in to get the new resolution.
  2. The wired ethernet will not work, but wi-fi should. Connect to a wi-fi site.
  3. Use YaST to do an Software->Online Update. The first time will update the Package Manager and a few programs. It’ll be quick. Afterward, log out and log back in. (No need to reboot.) Do the YaST Software->Online Update again to really update the system.

Getting Wired Ethernet to Work

  1. Install the wired ethernet driver:
    (Note: the one click install seems to be tied to an older version, but clicking on the i586 rpm version works. For now, use atl1c-kmp-pae-2.6.31_2.6.27.29_0.1-1.2.)

Boot time: about 38 seconds

Fn Volume Up/Down - works
Fn Screen Brightness Up/Down - doesn’t work

Fn F1 Power manager - doesn’t bring up one, Window’s thing
Fn F2 System Property - doesn’t bring up system info, Window’s thing
Fn F3 Bluetooth - not available on 1410, not tested
Fn F4 Sleep - works, wakes up with keyboard press
Fn F5 Display toggle - doesn’t work (someone with Ubuntu reported that this works on that distro)
Fn F6 Screen blank - works
Fn F7 Touchpad toggle - works
Fn F8 Speaker toggle - works

Closing the laptop puts it into sleep mode.

Much thanks to caf4926 and Akoellh!

Good to know you made some headway.:wink:

Oops, this should read:

Fn Screen Brightness Up/Down - doesn’t work (someone with Ubuntu reported that this works on that distro)

Fn F5 Display toggle - doesn’t work

Also, for a fully working system with media codecs…

Restricted Formats/11.1 - openSUSE-Community

After the one click install, reboot and YaST->Software->Online Update to install some patches, especially the one for flash.

Reboot and you’re good to go…

Okay, some more notes…

  1. YaST->Hardware->Sound, then select the options button (bottom right) to set PulseAudio. Select it and turn PulseAudio on. (After turning on PulseAudio, sometimes the sound has a bit of a crackle, especially when login in.)

The system has sound with ALSA and OSS already, but an application like Skype wants PulseAudio, or at least I haven’t found a way to hear Skype audio without PulseAudio. (The Skype website says PulseAudio is optional, but there doesn’t appear to be a way to switch it from PulseAudio to something else.)

  1. Amarok defaults to using Gstreamer, but that doesn’t seem to work. Xine with ALSA or OSS output works.

  2. When shutting down the 1410, all the text messages that normally scroll up are displayed on one line at the very top and scroll horizontally. The screen also flashes. Basically, the shutdown process messages are unreadable.

  3. Can’t seem to get the Mic working. The 1410 has a built-in mic next the camera, a dedicated mic port and a shared mic/headphones port. Kmix has Front and Internal mics listed. I’ve tried both selections and boosted the mic to hear it from the internal speakers. I just hear static. arecord doesn’t seem to record anything either. The Skype’s sound test doesn’t record anything. What are good settings for Mic/Capture, etc.?

  4. Camera works with Skype test.

I suggest you start a new post with Sound Problem in the title and that info. In the mean time I can tell you Xine is 1st choice
SDB:AudioTroubleshooting - openSUSE

I can not help with Skype. I never use it.

But I can possibly help with your basic mic functionality. To test your Mic, please read this: Microphone - openSUSE

In particular, note the specific’s of the arecord command that you should use for basic mic recording functionality:

arecord -vv -fdat foo.wav

where foo.wav is an arbitrary name (give it any name you want). You should see an ascii volume bar indicating if the mic is recording.

Also, please set up your mixer EXACTLY how you think it should be setup so that your mic will record. Then with your pc connected to the internet run the following script (being certain to select the upload/share option if asked):
/usr/sbin/alsa-info.shthe script can be run as a regular user, except if it asks to update, in which case so that the update can be copied to /usr/sbin you will need to run it once as user root so that the update gets copied to /usr/sbin (a regular user does not have permissions to copy to /usr/sbin). When the script successfully completes it will give you a URL. Please post that URL here. Just the URL.

/sbin/lspci -nnk |grep -A2 -i net

caf4926: I followed the link you gave and the debugging with KMix in combination with KRecord really helped. Seeing the mic feedback visually with KRecord made it easy to tell which mic was active:

Front Mic maps to the mic next to the camera on the 1410.

Int Mic maps to the dedicated microphone port and the shared microphone/headphone port.



Master - max and on
PCM - max
Front - max and on
Front Mic - min and off
Front Mic Boost - first marker up
Beep - min and off
Digital - min


Front Mic Boost - first marker up and on
Capture - max and on
Digital - mid and on


Headphone - on
IEC958 - on
IEC958 Default PCM - off
IEC958 - on

Input Source

Front Mic - for mic next to camera
Int Mic - for mic input ports

In short, mic input works with the default openSUSE 11.1 install on the Acer 1410/1810T.

Skype, which only allows selection of PulseAudio for sound and mic only works for sound. The mic with PulseAudio doesn’t seem to work. Perhaps I need a different version of Skype that allows other sounds systems other than PulseAudio.

oldpro: Thanks for popping in to help me again with audio. I kinda gave up on my desktop with openSUSE 11.1 with the sound problem but will try again with 11.2.

Akoellh: Thanks!

Once you have an established mic configuration that works in your mixer, you could consider saving that somewhere.

For example, my wife runs WinXP as a virtual box client under openSUSE-11.1 on our family laptop. She uses some WinXP programs to verbally chat and make phone calls from WinXP. In order for her to use the mic under winXP, it has to first be working in openSUSE Linux which is the virtual box host operating system.

My wife is a big winXP fan and she mostly dislikes Linux and hence she has no patience for Linux. If anyone can totally mess up a Linux mixer setup, it is her. She has the knack. In order to ensure she does not mess up the openSUSE Linux microphone configuration in the mixer, I have a screen print of the proper microphone configuration, that is a jpg on her desktop. So when she boots the PC, and she needs to know the correct microphone configuration, she simply compares the mixer configuration, against the jpg image of the mixer.

That simple jpg has saved her a lot of frustration, and saved me many dozens of minutes of having my ear bent by a frustrated wife :slight_smile:

“Thanks for nothing” or what?

I and many other users would be grateful, if you would post the output of the command!

Especially those, who have the same card and search by PCI-ID.