Install on Raid 0 (so called fake raid) - which parameter to use to boot install DVD?

HI, I’m struggling with installing 15.1 on a classic AMD 990FX motherboard that has a raid 0 matrix setup from BIOS. So called “fake raid”.
Leap 14.3 worked out of the box (even on UEFI) but 15.1 does not see the raid matrix.
Probabbly missing the raid driver when boots the install kernel. I’ve tried to figure out which boot parameter should I add (tried dmraid=true is it would be in Debian 9 but it didn’t work).
I didn’t find this documented anywhere (or I did not understand what I should). Please help, this is likely something effortless but I can’t find a solution to it.


RAID 0 is not “fake raid” or at least in the sense that it doesn’t provide any fault tolerance and in fact makes yous system extremely vulnerable to catastrophe due to disk failure… It is striping without data duplication which is very fast but if only one of the disks in your set fails, then the entire set fails. Very bad, and never to be used for anything that’s essential like systems. Used only for things like logs which might need to be extremely fast (for highly verbose logging) and is no big deal if lost.

IIRC Fake RAID sometimes has generally referred to software RAID.

Bottom line.
If it really is RAID 0, don’t do it. I’ve seen it possible on some RAID, but know what your are doing. Buy an SSD instead if you want faster disk performance.
I’m guessing there should be an option to set up RAID 1, then that’s a good option which mirrors data on to both disks so that if one disk fails then the other if necessary can carry on by itself until the bad disk is replaced.

As for openSUSE (any version) installing on hardware RAID, if your hardware RAID is set up properly, it should present as a single, rather generic disk. In rare cases, a disk driver might need to be installed and specified, but that is very rare. If this is truly a stumbling block, then you need to identify the RAID chip/controller and if necessary post it for others that can help.


Thanks. Your objections are noted but apart from that I can’t make much use of them.

It’s a 12 year old machine and I won’t upgrade it with an SSD, etc, etc, but it’s very fast for it’s age and I do use it as a client machine.

Now, as noted above - up to Leap 14.x I didn’t have any issues with this, but now as I wanted to upgrade, 15.1 simply doesn’t see the array (and yes, it’s properly set up and working for a couple of years, running multiple OSes on it).
It’s likely because, unlike 14.x, Leap 15.1 doesn’t load the appropriate module to see the raid array of this kind (probably dmraid), so the information what I’m looking for, is how to make it load the proper module during booting the install DVD.

All the best,

Fake Raid = BIOS assisted RAID. Which is a kind of hybrid software hardware RAID But you can have just pure Software RAID and pure Hardware RAID which is not FAKE RAID.

Yes, it’s BIOS assited or fake raid.
It’s already as is, just want to upgrade the Linux on it

Another reason to avoid BIOS RAID is that when the motherboard dies, you lose all data on the disks too, as you’re highly unlikely to find a replacement motherboard that is compatible, unless that particular motherboard model is still available. At 12 years of age, there’s probably slim chance of that happening. Better to backup everything important, and install 15.1 fresh, without involving any form of BIOS RAID.

I’ve been running openSUSE in multiboot on software RAID1 for over a decade.

rotfl! Allright. So how do I boot it to be aware of fake raid?

This is regression and you should really open bug report.

I don’t think you can or should. The idea of BIOS RAID is to present to the OS like hardware RAID, so the OS doesn’t know, seeing only one disk, regardless of the underlying disk count. With BIOS RAID 0, YaST should only see one disk. RAID configuration is entirely in BIOS setup. How many disks does YaST show you?

I am not sure here about the problem description.
The title says that the install DVD will not boot (without explaining what the OP sees, just nothing, some error message?).

Later in the first post there is talking about Leap 15.1 “not seeing the RAID device”. But as long as the DVD can not boot, there no installer loaded, let alone LEAP 15.1.

And when the install DVD does not boot, I assume there is no YaST where one can ask anything from.

What did I miss here?

Then the @OP should clarify what he sees in detail after booting the DVD…
I had read the attempt to add kernel parameters as having successfully boot the DVD and trying to add the kernel parameters as when presented with the GRUB boot screen.

And, yes…
dmraid supported might have been dropped because the kernel no longer supports it.
See the notes and Discussion in the following ArchWiki article on how to install on Fake RAID… You may have arrived at a crossroads where you may have to disable your Fake RAID because the technology is no longer supported (The alternative which is to never upgrade or update to newer kernels is likely the poorer choice by far).
And that’s a big drawback of all hardware, you won’t likely be able to set up with mdmraid because the intructionset is embedded in hardware… and this seems to be an important distinction between real RAID and Fake Raid that the OS must support the RAID management.

I don’t expect that the openSUSE maintainers can be expected or would agree try to support something that has been clearly deprecated in the kernel mainstream.


Ok, thanks all. Let me clarify.
I also use mdadm when seting up a server to install with sofware raid or a server with a proper hardware controller.
Aside from all that, this case has nothing to do with either.

The boot image (DVD) does boot quite properly, but unlike when booting Leap 14.x, getting to the partition setup it sees plain sda and sdb disks, and offers me to create new partiotions etc, etc. SO, unlike so far (as with Leap 14.x), it does not see/read the raid matirx.
In my opinion, this is because it does not load the dmraid module during boot (which usually makes sence out of the fake raid setup).

This article is the one tha put the idea in my head, that I need to add a boot parameter to have it load the proper module or driver:

I hope this helps you to help me (although I’d say that I’m the only “veteran” for fake raids here, heh)


Yeah, this makes the most sence so far. I’ll dig around a bit more prior to that. Thanks

OK, that makes more sense. But your title does not cover your problem then.
BTW there never was an openSUSE LEAP 14.x. At first I thought this was a typo of you and that you maen 43.x, but it seems chronical ;). Can you confirm what it should be?

In the link I provide,
Read the “Load dmraid” section, the “Troubleshooting” section and the Discussion section on dmraid.


Auhh sorry. This versioning logic is confusing to me.

istvan@~ ] $ cat /etc/release
NAME=“openSUSE Leap”